PDA

View Full Version : Bioshock screwed after running in dx9 mode on vista


Armed_Baboon
08-23-07, 08:37 PM
using the -dx9 tag and the FOV hack severely screwed my installation of Bioshock. I went from totally trouble free gaming to having almost all of the problems people are reporting. when I run in dx9, as soon as I access a vending machine the game just freezes. so I remove the -dx9 tag to go back to playing in dx10 mode. whoah. everything is screwed.

now when I try to change any settings in the graphics options, I hit apply and it freezes/crashes to the desktop. sometimes when I start the game I don't even get to the disclaimers that pop up in all the different languages.just a black screen crash. also have had the sound bug a few times. managed to go into the config file and manually set the resolution, that works some of the time. so after a few restarts I can normally get in and play and all is well...

and after all that I really got sucked into it last night, very cool game.

Ideally I'd like to reinstall the game, but alas i got it from steam, so I'm not quite so keen to use up all that download quota to download it again...


someone else suggested that my dx10 installation might have somehow been corrupted and to install the DX10 SDK?

any other ideas?

nekrosoft13
08-23-07, 09:12 PM
1) don't have to reinstall game in steam, just open game list, select the game and verifly the integrity of the files

2) Don't install SDK, that if you want to develop your onw games, all you need is redist.
latest one can be found here
http://www.microsoft.com/downloads/details.aspx?FamilyID=cb7397f3-0949-487b-9247-8fee451bf952&displaylang=en

also you didn't mention what video driver you are using, update to the latest 163.44

Armed_Baboon
08-23-07, 10:54 PM
thanks for your post nekrosoft13, I've been reading your posts for a long time :-)

1) don't have to reinstall game in steam, just open game list, select the game and verifly the integrity of the files

I've done that a few times, with no difference.

2) Don't install SDK, that if you want to develop your onw games, all you need is redist.
latest one can be found here
http://www.microsoft.com/downloads/d...displaylang=en

ok, that's great. I thought the only way was to install the sdk. now I know :headexplode:


also you didn't mention what video driver you are using, update to the latest 163.44

yep on 163.44

on an 8800GTX and e6850 @ 3GHZ

Dirthead
08-23-07, 11:16 PM
I do not want to sound like a smartA$$ but why run a 8800gtx card in dx9 with a E6850 cpu??Really no reason too.

Hate to say it but uninstalling and reinstalling might be the only thing todo as it sounds like key game files are broke.

Good luck

Armed_Baboon
08-23-07, 11:39 PM
was because the FOV hack (which I didn't really think was much of an issue after seeing the difference) doesn't work in DX10.

and I just had to fiddle...

Dirthead
08-23-07, 11:50 PM
k.....

fizix
08-24-07, 01:12 AM
Hey can somebody PLEASE tell me how to run bioshock in dx9 mode while in vista? Thank you!

Armed_Baboon
08-24-07, 03:08 AM
I'm such a dumb arse (no comments please).

I've fixed the problem, while running in dx9 mode I decided to check the compatibility mode to run in xp sp2 mode... unchecking this fixes all the problems! yay!

Fixix, to run in dx9 mode, you need to add the switch "-dx9" without the quotes to the shortcut options. to do this, right click on the shortcut and select properties. from there you should see a text box labelled "Target:" and in the text box should be "C:\program files\...\bioshock.exe"

you need to add -dx9 to the end of that, so it will look like:

"C:\program files\...\bioshock.exe" - dx9

leave the quotes in.

if you running the steam version, right click on bioshock in your favorites in steam and select properties, click on launch options and enter -dx9.

unless you are having bad performance issues I wouldn't bother. the fov "problem" seems to be a beat up to me. everything is forgotten once you get engrossed in the game. even the lack of aa.

I'm off to gaming heaven again now... got a big daddy to sort out..

lumpyhed
08-24-07, 06:43 AM
OR in Game Explorer simply right-click the game shortcut and choose DX9 from the dropdown menu. :)

nekrosoft13
08-24-07, 07:28 AM
thanks for your post nekrosoft13, I've been reading your posts for a long time :-)



wow, i have a fan

glad you got it fixed.