PDA

View Full Version : Bioshock - Worked perfectly in the beginning... now a blue screen of death...


Alstroph
08-26-07, 04:15 PM
Hello, I purchased Bioshock recently. The game ran fine at first... but when I got to the part of the game (about an hour in I guess) where you first start interacting with the daughters I got a blue screen of death complaining about my graphics drivers. I let my computer restart and tried getting past the crashes by using very frequent quicksaves. Doing this I was able to progress about two more rooms (after about 10 hard resets...) until my quicksave became corrupted (the game crashes when I try to load it).

My computer specs:
Sony Vaio VGN-SZ330P
Intel Duo core 2 2.0GHZ
2 GB RAM
Nvida GeForce Go 7400 128MB (With newest DNA-Force Drivers)

Any help would be greatly appreciated. :)

radekhulan
08-26-07, 04:55 PM
I had the same problem. Was playing for 2+ hours without any problems, and after that game started crashing after 30-60 seconds in game (nvlddmkm, page_pool). Uninstalled my NVIDIA and Creative drivers, installed them again, and it works now well (again). See no logical explanation how this could happen / help though...

Computer is otherwise 100% stable, *never* had any crash.

crainger
08-26-07, 05:10 PM
Have you tried non modded drivers?

Alstroph
08-26-07, 05:49 PM
I'm actually installing the default drivers now to try those. I'll report if it works.

PaiN
08-26-07, 06:16 PM
Could be a heat or overclocking issue, also. Even from a "factory" OCd card or a stock card not getting enough fresh air.

Alstroph
08-26-07, 06:23 PM
Went back to default drivers... no luck. The only message I was able to register was something like General fault in non paged area.

I don't think the issue is with heat... a few of the times I tried the game my computer had been off for a few hours and instantly crashed. I have not OCed this computer.

Where does Bioshock post new patches? I wasn't able to find an autoupdater. Also... where can I find the newest drivers for a Ge Force Go 7400 series video card? Anyone know why Nvidia forceware doesn't support the go series?

LurkerLito
08-26-07, 06:47 PM
Nvidia does support them but not officially, I think they want you to only get them from your laptop manufacturer.

This is the place that mods the inf files so you can use the latest drivers:
http://www.laptopvideo2go.com/

Good luck.

Alstroph
08-26-07, 07:01 PM
Thanks - I'll see if the newest drivers give me troubles.

Alstroph
08-26-07, 07:36 PM
It seems as if those drivers at laptopvideo2go worked. I got past the spot that was giving me troubles before. Thanks for the help :)

Alstroph
08-27-07, 06:07 PM
I went back to play Bioshock and the problem is not fixed... still crashing. Any more suggestions?

grey_1
08-27-07, 06:19 PM
I tried playing with vsync enabled. This is after first playing through without it, no problems.

After enabling vsync I couldn't play more than 5 minutes without lockups or hard crashes, dis able it and all is well again. It's repeatable too, I just don't have an explanation for it. 163.44s btw.

crainger
08-27-07, 07:10 PM
!! I hope my Bioshock plays ok with V-sync. I like my V-sync... :D

AngelGraves13
08-27-07, 07:11 PM
Only problem here was sound. got that fixed with a format. haven't crashed yet.

lee63
08-27-07, 08:25 PM
I'm getting nothing but crashes and BSOD :( I have tried three different drivers and lowered my clocks on my GPUs and CPU and it still happens, Ill try the vsync thing and see if it helps (lee63)

EDIT: I give up on this am until its patched :thumbdwn:

jAkUp
08-27-07, 08:53 PM
I'm getting nothing but crashes and BSOD :( I have tried three different drivers and lowered my clocks on my GPUs and CPU and it still happens, Ill try the vsync thing and see if it helps (lee63)

EDIT: I give up on this am until its patched :thumbdwn:

Can you try setting everything to stock including CPU and GPU?

Also make sure you are running these sound drivers, Bioshock seems to be sensitive to sound drivers:

ftp://202.65.194.212/pc/audio/WDM_R174.exe

lee63
08-28-07, 08:01 PM
GPUs and CPU at stock, all voltages set auto except the ram which is at 2.3 suggested by GSkill, using the Bioshock drivers and the latest audio drivers, this is all on a clean install of XP32. I get past the loading screen and for a split second I thought it would be ok, until..... drum roll.... my rig completely shuts down:banghead: :banghead: :banghead: I give up with this game for now :thumbdwn:

grey_1
08-28-07, 08:10 PM
GPUs and CPU at stock, all voltages set auto except the ram which is at 2.3 suggested by GSkill, using the Bioshock drivers and the latest audio drivers, this is all on a clean install of XP32. I get past the loading screen and for a split second I thought it would be ok, until..... drum roll.... my rig completely shuts down:banghead: :banghead: :banghead: I give up with this game for now :thumbdwn:
Disabling CTHelper in msconfig fixed FEAR crashes for me..reaching I know, but just a guess.

jAkUp
08-28-07, 08:20 PM
GPUs and CPU at stock, all voltages set auto except the ram which is at 2.3 suggested by GSkill, using the Bioshock drivers and the latest audio drivers, this is all on a clean install of XP32. I get past the loading screen and for a split second I thought it would be ok, until..... drum roll.... my rig completely shuts down:banghead: :banghead: :banghead: I give up with this game for now :thumbdwn:

Try disabling SLI.

lee63
08-28-07, 09:31 PM
Try disabling SLI.Tried that ;)

jAkUp
08-28-07, 10:04 PM
Damn that sucks :( My last suggestion, try the DX August Update:

http://www.microsoft.com/downloads/details.aspx?FamilyID=cb7397f3-0949-487b-9247-8fee451bf952&displaylang=en

sfrappell
09-03-07, 10:31 AM
MY PROBLEM IS FIXED - :captnkill:
I was getting a different BSOD error code almost every time (I was suspecting memory), however I have just discovered what was causing my blue screen errors while playing Bioshock. I noticed that just before the game would pause and the blue screen would occur, my second lcd monitor would turn off - then the BSOD would occur. I didn't notice this until today while I was going through every possible solution in attempt to resolve this annoying problem. No other games have this Blue Screen problem except Bioshock which usually allows 5-10mins of gameplay before it BSOD on me.

Today when I noticed the second screen flicker I thought I may as well disable the second monitor extension as it is possible that it may affect the video card. Well, magic followed....... I just finished playing 4 hours straight. I'm happy to say I have resolved my problem. Additionally I have other people that have confirmed they have also resolved their issues by disabling the 2nd monitor while playing games. This is simply unchecking a box in Windows display settings, you don't need to touch the cabling.

I have changed my drivers back to the certified Nvidia drivers (not the BETA) and the game still works fine. Hopefully some of you having pain will now be able to avoid the BSOD. I plan on disabling my second monitor during all games now. As it will likely improve performance aswell.

Cheers,
Good luck - Psycho