PDA

View Full Version : Video too bright!


iNfernum
09-20-07, 04:22 AM
Hey all,

First of all, nice to be here, i am glad i finally found this nice forum.

I got a small problem, which is , whenever i try to play any video using WMP11 or Media player classic (my favorite) it is way too bright.

I am running on the following:

1) AMD X2 3800+
2) 2xXFX nVIDIA GeForce 8600GT (SLi mode activated) nVIDIA Forceware 162.18
3) 2GB Kingston RAM
4) Windows XP w/SP2 with latest updates

I read alot about this problem and its a gamma correction issue but it wouldnt work with me cause when i adjust gamma in the color correction tab, it affects all the display, which is not what i am aiming for. i just want the video to run normally not adjust all my display. any ideas?

XDanger
09-23-07, 10:21 AM
overlay,
Video and Television in Control panel ??

JaylumX
09-23-07, 12:54 PM
Sounds like the VMR9 colour range bug. I still don't understand why it has not been fixed after all this time (I first came across it when I had my 9800pro). If you are on windows XP there is an easy way to fix it. Follow the instructions bellow.

Video color-space range for DVI-only1 outputs is erroneously set to standard mode (16-235) instead of extended mode (0-255).
A new detection feature to apply Standard CSC mode to TV outputs (including NTSC, PAL, 480i, and 576i), included DVI-only outputs by mistake.
Note: The driver correctly applies extended mode to analog outputs, and standard mode to TV outputs (including NTSC, PAL, 480i, and 576i).
A future driver release will correct this and apply the extended-mode color space to DVI-only outputs. You can work around this issue by forcing either standard or extended mode as follows:

1) Launch regedit and determine the current primary display card by looking in
"HKey_Local_Machine\Hardware\DeviceMap\Video" and note the GUID (global unique identifier assigned by Windows), which is the long string in brackets { } at the end of the entry "\device\video0".

2) Look in "HKey_Local_Machine\SYSTEM\CurrentControlSet\Contr ol\Video\{GUID}\0000" where {GUID} is the number derived from the previous step.

3) Open the "0000" directory and create a new DWORD called "VMRCCCSStatus" and give it a value of
0x3 - to force use of the standard YUV range of 16-235
0x1 - to force use of the extended YUV range of 0-255

A word to note. The options are backwards (don't ask me why, I don't know) but to get the correct colour range, use 0x3 rather than 0x1.

callistostg
09-23-07, 08:15 PM
I've been experiencing similar problems with video playback, and that regedit cleared everything right up. Everything's looking quite fantastic now. :thumbsup:

iNfernum
09-25-07, 03:55 PM
Damn i did everything..

I reinstalled the chipset.. nforce 4, latest one
i reinstalled the vga driver, latest one
I reinstalled klite codec pack, also latest one, after uninstalling the old one
and i tried your trick here first thing..

Nothing worked.

Weird thing, VLC Player works fine!