PDA

View Full Version : 7600 GT AGP Black Screen!


nemesis_rebirth
09-27-07, 05:41 AM
Ok, here's the story :
I bought myself a Club3d 7600GT AGP, but it ~merely~ works at all :
With the default windows driver, it works normally, I can go up to 1280x1024 with no problem at all.
As soon as I install nvidia drivers, I get a black screen : the screen blinks once first (as always when installing a graphic driver), and then a second time but it stays black. :/
If i reboot, I get a black screen after XP has loaded, and then it reboots on its own after a minute. I've tried a few versions of the driver (last version, or the one on the cd), with no luck.
The screen is a 22" lcd (1680x1050), dvi.

Any idea?

Thanks

Revs
09-27-07, 06:06 AM
What happens if you boot up in safe-mode. If it works, boot in to Windows and have a look in the log files in Administrative Tools>Event Viewer. See if it sheads any light on the problem.

nemesis_rebirth
09-27-07, 06:18 AM
Safe mode works fine.
The log viewer shows this relevant error :

==========
Source : nv
Description : "The driver nv4_disp for display peripheral \Device\Video0 got stuck in an infinite loop. It generally means a problem with the peripheral itself, or with the perpheral driver programming the hardware in an incorrect way. Contact you hardware manufacturer to obtain driver updates if there are any." (I tried to translate it as well as I could)
==========

(BTW, I have the same problem on my linux partition, when using the nvidia drivers, it makes the display black and Xorg gets stuck)

Revs
09-27-07, 10:52 AM
That error generally points to a hardware problem. Is your PC overclocked? If not, I would suggest you returned the card for testing.

nemesis_rebirth
09-27-07, 11:30 AM
The pc is not overclocked.
I'm going to try the card on someone else's pc tonight to be sure.