nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X won't start - P4 and MDK9.1 (http://www.nvnews.net/vbulletin/showthread.php?t=10000)

jynyl 04-11-03 08:01 AM

X won't start - P4 and MDK9.1
 
Fresh install of MDK9.1, X works ok with distro drivers. I installed the 4349.run drivers and X won't start.
Hardware: P4 2.4GHz, 256MB RAM, shuttle AV49 motherboard, GeForce4 MX440 64MB.
System is Mandrake 9.1.

/var/log/XFree86.0.log has no EE errors. The last two lines are
NVIDIA(0) AGP 4x successfully initialised
NVIDIA(0) setting mode "1280x1024"

This is the correct size setting for the LCD monitor.
This hardware worked ok with MDK9.0 and the 4191 nvidia drivers.

When I try to boot into X, or start X from runlevel 3, the monitor just goes blank, and there's no response to the keyboard.

Any suggestions?

TIA

Peter

Andy Mecham 04-11-03 02:15 PM

Does disabling AGP help?

--andy

jynyl 04-11-03 02:18 PM

? disable AGP ?

- how to I do that?

(sorry, I'm not expert at these things)

TIA

Peter

Andy Mecham 04-11-03 03:01 PM

Add
Code:

Option  "NvAgp" "0"
to the Device section of your XF86Config file.

--andy

jynyl 04-11-03 03:21 PM

thanks

tried that, but symptoms are the same.
That is, ran startx from the command line and screen just goes black. The /var/log/XFree86.0.log file stops at the same line.

Anything else I can look at?

TIA

Peter

jynyl 04-11-03 03:59 PM

1 Attachment(s)
config and log files attached for reference.
This log was done when NvAGP set to 0.


Peter

bwkaz 04-11-03 05:00 PM

Is your kernel using SMP? There's a known SMP+DVI bug in the drivers... You can grep the kernel config file (wherever it is; I think Mandrake puts it in /boot, but I don't know for sure) for CONFIG_SMP, and post what that comes back with.

But it does sound like you're using DVI, for sure.

Andy Mecham 04-11-03 05:10 PM

Sigh. That would explain quite a bit of the laptop hangs.

--andy

jynyl 04-11-03 05:22 PM

Regarding SMP, in /boot there is a link of config to
config-2.4.21-0.13mdk
There is also a file config-2.4.21-0.13mdksmp.
On boot up, there are options for linuxsmp and linux. I use linux. I don't know why MDK installed the SMP option as the PC has only one P4 CPU.

cat config-2.4.21-0.13mdk | grep -i dvi
gives nothing

cat config-2.4.21-0.13mdk | grep -i smp
gives
#CONFIG_SMP is not set


BTW, noting Andy's post, this is a desktop PC, not a laptop.


TIA

Peter

alien999999999 04-12-03 11:00 AM

I have exactly the same problem, I'm using the standard 9.1 installation and no X with the new drivers, no matter what I change it stops after setting the resolution.
Now I already have installed the same driver for two others using mdk9.1 with no problem at all, one even has the exact same 3D card.
P4+GeForce4 Ti420 : no problem
Athlon XP 1800+GeForce2 MX400 : no problem
Athlon XP 2200+GeForce2 MX400 : yes problem
it seems to be random, the only thing I can think of is that it's mobo related?
all 3 are desktop PCs with more or less the same standard settings installed with the exact same mdk9.1 CDs
what the hell is the problem? my mobo is KT400, I know the others are not using that mobo.

can anyone plz help?

bwkaz 04-12-03 11:11 AM

There is a thread here regarding the KT400 motherboard chipset. In short, yes, that is your problem. There are options you can pass to the kernel module, or you can disable AGP, to work around the problems.

I believe this issue is also noted in the errata for the 4349 driver -- the errata is available on nVidia's FTP site, and I believe it's also linked from the driver download page.

Tector 04-12-03 01:40 PM

This is not just a KT400 problem. I have the same problem with an Nforce2 based M/B and have tried all the suggested fixes to no avail. You would think that an Nvidia based M/B chipset would work with an Nvidia graphics card. X never gets far enough to even write out an error log so it's pretty hard to diagnose the problem.


All times are GMT -5. The time now is 09:36 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.