nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL) (http://www.nvnews.net/vbulletin/showthread.php?t=100468)

rogene 10-16-07 07:40 PM

Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
I recently updated my drivers to v. 100.14.19 for my GeForce 7600 GS card. Since doing so, Firefox 2.0.0.5 crashes when I try to run applets that rely on JOGL (SUN's Java for OpenGL).

Here is an excerpt from the nvidia-bug-report.log file.

Quote:

gam_server[5230]: segfault at 000000000000002e rip 00000034df243057 rsp 0000007fbfffde60 error 4
ioctl32(firefox-bin:5750): Unknown cmd fd(50) cmd(80045500){00} arg(ffffc590) on /dev/snd/controlC0
In my system log file, I find the following:
Quote:

Oct 16 11:50:09 localhost kernel: ioctl32(firefox-bin:5750): Unknown cmd fd(50) cmd(80045500){00} arg(ffffc590) on /dev/snd/controlC0
Oct 16 11:50:09 localhost last message repeated 3 times
Oct 16 11:50:09 localhost kernel: ioctl32(firefox-bin:5750): Unknown cmd fd(51) cmd(80045500){00} arg(ffffc590) on /dev/snd/controlC0
Oct 16 11:50:10 localhost last message repeated 45 times
I am running Linux 2.6.9 (Centos 4.5) on a dual x86_64 arch.

I don't speak video card, so I would appreciate any help in determining whether I have a problem that has been solved in the past, or whether this is something new that would benefit by my submitting a bug report.

I have tried to search for clues (aw, man! nvidia - you MUST get rid of that timer that only allows one search every 60 seconds...) but have not yet found any matches.

Might someone interpret what these messages mean, and suggest a corrective course of action?

Thanks much in advance for your help.

rogene 10-18-07 12:57 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
I submitted the file as a bug report - when would I expect to hear back from someone?

netllama 10-18-07 01:00 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
If you're asking for assistance here, then you need to follow the instructions in the sticky posts.

rogene 10-18-07 01:25 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
C'mon, man... I don't speak video card, but I did spend money on this product, so could you please back off on the scolding and help me out just a bit more here??? I *have* tried to follow the instructions in the stickies. But there are many stickies and many of them are several years old and there are many machine configurations to consider and if I were an expert, I wouldn't be needing to post here.

I ran this command from one of the stickies "Installing NVIDIA Linux graphics drivers on recent distributions (FC, Ubuntu, etc)" to make certain that I am running the latest version of required libraries:
Quote:

[root@localhost js]# yum install kernel-smp-devel xorg-x11-server-sdk pkgconfig
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: xorg-x11-server-sdk
Nothing to do
Now what, eh?

I don't know what the heck SELinux is, so I didn't change the security context also listed on that same stickie.

The sticky entitled ": If you have a stability problem, PLEASE read this first" was posted in 2005 WELL BEFORE THE LATEST DRIVER WAS RELEASED. I am not going to screw around with my system and apply commands blindly because someone said so two years ago in response to two year old versions of Linux kernels and video drivers. (Was this card even available two years ago? I don't know.)

Yes, I have searched the other postings. Which, I should mention, was a real pain because of the restriction that users can only perform one search every 60 seconds.

Look. I am not some kid trying to run the latest video game - I am trying to make a living as part of a web 2.0 startup and since upgrading to the latest version of the Nvidia drivers, JOGL applications crash big time.

I emailed a copy of nvidia-bug-report.log thanks to what I read in the sticky "If you have a problem, PLEASE read this first". So now when am I going to be contacted by a human that can help me to find out what the hell is going on???

Thanks.

rogene 10-18-07 01:27 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
1 Attachment(s)
Bug report uploaded to forum.

netllama 10-18-07 01:32 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
What are the steps required to reproduce this problem?

rogene 10-18-07 01:33 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
BTW, I reported this to SUN as well, recognizing that the problem may exist in the interaction between your card and their latest versions of JOGL and/or JNLP.

rogene 10-18-07 01:53 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
Steps to reproduce the problem:
1) Point browser to URL of web page that contains a JOGL applet
2) Browser crashes
3) Repeat

Try this - Download the NASA Worldwind Java SDK here:
http://worldwind.arc.nasa.gov/java/index.html

In the directory <installbase>/Worldwind/src/gov/nasa/worldwind/examples/applet is an html file named index_applet.html

Per a discussion on the Worldwind and JOGL forums, you will want to make the following replacement (cut & paste). All this does is make certain that you are getting the latest, stable releases from Sun.

Code:

<applet id="wwjApplet" name="wwjApplet" mayscript code="org.jdesktop.applet.util.JNLPAppletLauncher" width=100% height=70%
      archive="http://download.java.net/media/applet-launcher/applet-launcher.jar, http://download.java.net/media/jogl/builds/archive/jsr-231-webstart-current/jogl.jar, http://download.java.net/media/gluegen/webstart/gluegen-rt.jar, worldwind.jar">
  <param name="codebase_lookup" value="false">
  <param name="subapplet.classname" value="gov.nasa.worldwind.examples.applet.WWJApplet">
  <param name="subapplet.displayname" value="WWJ Applet">
  <param name="noddraw.check" value="true">
  <param name="progressbar" value="true">
  <param name="jnlpNumExtensions" value="1">
  <param name="jnlpExtension1" value="http://download.java.net/media/jogl/builds/archive/jsr-231-1.1.1-rc5/webstart/jogl.jnlp">
 </applet>

NASA forgot to sign this release of their applet so you will need to do a quick jarsign to allow it to run in the browser.

Place index_applet.html and worldwind.jar in the same directory under a web server.

Then... try to open index_applet.html and... Boom! Not even time to get any useful error messages out of the java console.

My bigger concern is that the problem is *not* my installation, but perhaps some incompatibility between JOGL and this driver that would impact end users. No one goes back to a web site that just crashed their browser.. know what I mean?

Please let me know whatever I need to send or try to get to the source of the problem. I can even post my signed version of the jar file and the edited html file.

Thanks

rogene 10-18-07 06:12 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
I just received an email from Roland Hui from Nvidia who received my bug report and who is working with me to reproduce the problem.

Thank you very much to anyone who may have helped to bring this to his attention.

rogene 10-21-07 10:53 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
If anyone else wants to try to duplicate this problem, here is an easier way -

Point your browser to https://jogl-demos.dev.java.net/applettest.html

Crash!

Erwan Le Pennec 10-22-07 05:21 AM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
I've juste tried this with my laptop (NV110M,2.6.22 (fc6),100.14.23) and the demo seems to work perfectly...

Erwan, who imagines how hard it is to test every functionnality on every card!

rogene 10-22-07 12:54 PM

Re: Segfault in Firefox (GeForce 7600, Linux 2.6.9, JOGL)
 
Thanks for your reply. Firefox 2.0.0.5 as browser?

I don't know what NV110M is, but I see you are running the beta version of the next version of the driver, and you have a more recent linux kernel. This suggests trying the beta version myself, with hopes that this issue has been resolved.

Updating the Linux kernel would be quite a bit more work just to see if it fixes the problem. I have a dual x86-64 with an ASUS motherboard on which the Linux 2.6.9 (CentOS 4.5) version is supposed to be more stable. I don't want to screw up the rest of the machine until I can diagnose this more specifically as a problem with the kernel. (This is the help I came here expecting to find!)

Yes, I imagine it is difficult to test every functionality on every card. But at the moment, I am concerned more about how difficult it is going to be to start a successful business that relies on JOGL applets, if customers that go to the page have their browser crash.

I will be more comfortable when I know why this is occurring - I will have a target to work around. Hopefully, I will hear back from Roland Hui by the end of the week.

But in the meantime, any additional assistance here would be greatly appreciated!!!


All times are GMT -5. The time now is 03:38 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.