nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Continued Struggle with Error 17 (http://www.nvnews.net/vbulletin/showthread.php?t=100503)

Phyre 10-17-07 11:39 AM

Continued Struggle with Error 17
 
I'm trying an install of Ubuntu 7.04 on a stand-alone box, i.e. no dual boot with Windows. It's just a straight up Linux box.

The problem I'm having seems to stem from the use of SATA drives, and I can't seem to figure out the issue as of yet. I keep getting the GRUB Error 17 upon rebooting.

I've set Primary Master IDE to None and Primary Slave IDE to None in the BIOS. Primary IDE controller has even been disabled in the BIOS. After this and a clean install, I still get Error 17.

I've not started messing too much with the GRUB stuff as my skills are old, rusty, and not that awesome at the moment. I have tried the SuperGrub disk to no avail. I'll post that link when I get home tonight after work. I'm basically just trying to get some help on getting this going. I can't remember the drive setup (partitioning, etc.) right offhand at the moment. But, I can get the information and post it tonight.

Can you guys think of anything else that might be helpful for me to post to help remedy this issue?

Phyre 10-17-07 06:55 PM

Re: Continued Struggle with Error 17
 
Okay, here is some information that might help with the issue. If there is anything else that may be needed, just let me know.

Code:

sudo fdisk -lu
Device      Boot    Id    System
/dev/sda1            83    Linux
/dev/sda2              5    Extended
/dev/sda3    *      83    Linux
/dev/sda5            82    Linux swap / Solaris
/dev/sda6            82    Linux swap / Soaris

I'm not sure what is up with two swap partitions, but that's what I'm getting. I also used the auto-partition for this install. I actually don't like doing it that way, but thought it might help with the problem.

This is the content of the menu.lst file:

Code:

title    Ubuntu, kernel 2.6.20-15-generic
root      (hd0,0)
kernel    /boot/vmlinuz-2.6.20-15-generic root=UUID=541dbbc2-56ac-4035-b96a-ec0934f86elb ro quiet splash
initrd    /boot/initrd.img-2.6.20-15-generic
quiet
savedefault

title    Ubuntu, kernel 2.6.20-15-generic (recovery mode)
root      (hd0,0)
kernel    /boot/vmlinuz-2.6.20-15-generic root=UUID=54ldbbc2-56ac-4035-b96a-ec0934f86elb ro single
initrd    /boot/initrd.img-2.6.20-15-generic

title    Ubuntu, memtest86+
root      (hd0,0)
kernel    /boot/memtest86+.bin
quiet

The device.map file contents are as follows.

Code:

(hd0)    /dev/sda
(hd1)    /dev/sdb

Thanks,
Phyre

grey_1 10-18-07 03:25 PM

Re: Continued Struggle with Error 17
 
I think it's trying to RAID your drives. If you're up to it, unplug one drive, reinstall on the other. I bet that solves it for you.

Just a suggestion, try Debian 4.0.
http://www.debian.org/CD/netinst/

On the surface it looks just like Ubuntu, but I have had absolutely 0 of the glitches with Debian that I had with Ubuntu.

GL


All times are GMT -5. The time now is 12:14 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.