nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Ubuntu Gutsy amd64 with 8500GT = black screen (http://www.nvnews.net/vbulletin/showthread.php?t=101140)

bugchong 10-27-07 11:43 PM

Ubuntu Gutsy amd64 with 8500GT = black screen
 
1 Attachment(s)
After installing the nvidia driver 100.14.19, when X starts up the LCD monitor goes into standby mode and the machine is dead (ctrl-alt-del works sometimes). I've tried using the nvidia installer, the Restricted Driver Manager, and envy, all with the same results. Running under vesa at 640x480 works.

I've looked at http://www.nvnews.net/vbulletin/showthread.php?t=99456 and http://www.nvnews.net/vbulletin/showthread.php?t=99693, but I don't have the same issue with older drivers being loaded or the "PCI: Failed to allocate mem resource" problem.

Any ideas?

Thanks,
Gad

Other info:
OS: Ubuntu Gutsy amd64, kernel 2.6.22-14-generic
Video: ASUS EN8500GT
Mobo: ASUS M2N-E SLI (nForce 500 chipset)
CPU: AMD 64 5200+

netllama 10-28-07 12:03 AM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
In your X log I see:
(II) NVIDIA(GPU-0): No display devices connected; falling back to: CRT-0
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0

However, I don't see anything to suggest that the system hung. How did you make this determination?

bugchong 10-28-07 12:24 AM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
I don't know if it's crashed or not, because the monitor is in standby (no signal). The num lock works, alt-sysrq works, and ctrl-alt-del works sometimes. Otherwise, I can't do anything like go to the console with ctrl-alt-f1.

netllama 10-28-07 12:43 AM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
The monitor is in standby because its not getting detected. You should verify that you're cabling isn't at fault.

bugchong 10-28-07 12:57 AM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
Thanks for replying.

The same monitor+cables (dvi) work fine under the vesa driver.

netllama 10-28-07 01:02 AM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
The vesa driver doesn't probe for an EDID, or anything else. It just fires off a generic mode, and hopes for the best. In other words, just because vesa works doesn't mean that you don't have faulty hardware.

bugchong 10-28-07 02:08 AM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
That was it!

Using the DVI cable, the monitor was not being identified (came up as "Generic Monitor" when configuring X). I changed the cable from DVI to VGA, and the monitor is correctly identified and thus the NVIDIA driver runs correctly.

Thanks netllama!

Cheers,
Gad

Hakura 11-11-07 03:45 PM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
Well here my driver isn't detected, it shows some stuff when I turn on the computer, kind of retries 3 times and then the Low Graphics settings are activated... I set up "NVIDIA -> GeForce 8 Series" but it still loads as Low Graphics and I can't use apps like Google Earth.

When I type #glxinfo | grep rendering
to check if the GLX is working, it says it's missing...

My xorg.conf looks fine...
Restrict hardware is enable and bla bla bla

Any idea of what's happening?

I'm new to ubuntu/linux but my friend helped me, we tried everything and it still didn't work... If anyone could help..

netllama 11-11-07 04:30 PM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
See the forum sticky posts.

tuxie_ 11-13-07 02:44 AM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
1 Attachment(s)
Hello, These are my system's specs:

AMD 64 X2 6000+
mother board Gigabyte GA-M57SLI-S4
graphics card PCI-E Gigabyte Nvidia geforce 8500GT 512 Mb

I installed the comfusion distro, which has ubuntu+compiz+fusion already installed. I tried to install the nvidia driver using envy (in this case, the aplication didn't find the driver), automatix and downloading the driver directly from the nvidia web page. After installing the driver (with automatix or by following the instructions from nvidia's site), I restart the system, but there's an error and I have to restore the old configuration(running dpkg -reconfigure -phigh xserver-xorg) in order to continue. I attached the log. Hope you can help me. Thanks!

netllama 11-13-07 11:06 AM

Re: Ubuntu Gutsy amd64 with 8500GT = black screen
 
You have the 1.0-9755 nvidia kernel module loaded with the 100.14.19 X driver. This is an Ubuntu bug, and is documented in the forum sticky posts.


All times are GMT -5. The time now is 07:09 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.