nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   100.14.19/23 module fails to build on gcc-4.3 (http://www.nvnews.net/vbulletin/showthread.php?t=102265)

siddly 11-13-07 12:35 PM

100.14.19/23 module fails to build on gcc-4.3
 
Reported in the openSUSE Factory mailing list. No further info, but I shall try doing it later and post the error.

zander 11-13-07 01:19 PM

Re: 100.14.19/23 module fails to build on gcc-4.3
 
Please post the nvidia-installer.log file.

siddly 11-14-07 07:28 PM

Re: 100.14.19/23 module fails to build on gcc-4.3
 
Seems as a result of an online update, builds here fine. Apologies for the bum steer.

chema 11-19-07 10:55 AM

Re: 100.14.19/23 module fails to build on gcc-4.3
 
Hi:
I use openSUSE 10.3.1 (i586) Alpha0 with this kernels:
kernel-default-2.6.23.1-13
kernel-default-2.6.24_rc2_git4-2
kernel-default-2.6.24_rc2-4
this gcc packages:
gcc43-4.3.0_20071109-2
gcc43-c++-4.3.0_20071109-2
libgcc43-4.3.0_20071109-2
and I try this drivers:
100.14.19 169.04 and 96.43.01
I can't compile any driver
This is the last messages I see:
Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 169.
04). As part of installing this driver (version: 169.04), the existing driv
er will be uninstalled. Are you sure you want to continue? ('no' will abort
installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.24-rc2-git4-2-default/source'
-> Kernel output path: '/lib/modules/2.6.24-rc2-git4-2-default/build'
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
I see other errors.I can't make Makefile link for makefile.kbuild and others errors
Any idea?
Regards

chema 11-19-07 05:49 PM

Re: 100.14.19/23 module fails to build on gcc-4.3
 
Hi all:
Using kernel 2.6.24-rc2-git4-2 and module:x86-169.04 it works if I patch with something like this::

--- nv-linux.h-dist2007-11-16 13:17:04.000000000 +0100
+++ nv-linux.h2007-11-16 15:04:27.000000000 +0100
@@ -12,9 +12,11 @@
#ifndef _NV_LINUX_H_
#define _NV_LINUX_H_
+#undef CONFIG_PARAVIRT
#include "nv.h"
#include <linux/autoconf.h>
+#undef CONFIG_PARAVIRT
#include <linux/version.h>
#include <linux/utsname.h>
--- conftest.sh-dist2007-11-16 13:06:29.000000000 +0100
+++ conftest.sh2007-11-16 15:06:41.000000000 +0100
@@ -29,6 +29,9 @@
ARCH=`uname -m | sed -e 's/i.86/i386/'`
CFLAGS="$CFLAGS -I$OUTPUT/include2 -I$OUTPUT/include \
-I$HEADERS -I$HEADERS/asm-$ARCH/mach-default"
+ if [ "$ARCH" = "i386" ]; then
+CFLAGS="$CFLAGS -I$HEADERS -I$HEADERS/asm-x86/mach-default"
+ fi
else
CFLAGS="$CFLAGS -I$HEADERS -I$HEADERS/asm/mach-default"
fi

I'm sorry,now I can't find where I found this patch.
Regards

zander 11-19-07 07:41 PM

Re: 100.14.19/23 module fails to build on gcc-4.3
 
It's attached to a SuSE bug (see https://bugzilla.novell.com/show_bug.cgi?id=341801); please note that this patch is only needed if you build the kernel in a separate output directory. An equivalent change should be needed for Linux/x86-64.

siddly 11-19-07 07:42 PM

Re: 100.14.19/23 module fails to build on gcc-4.3
 
Seems it's was a x86 build failure. Both .19 and .23 buillds on x86_64.


All times are GMT -5. The time now is 10:21 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.