nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia_drv.so undefinded symbol in xorg-x11-server 1.4.99 (http://www.nvnews.net/vbulletin/showthread.php?t=102335)

sangu 11-14-07 08:47 AM

nvidia_drv.so undefinded symbol in xorg-x11-server 1.4.99
 
$cat /var/log/Xorg.0.log
Quote:

[...]
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia_drv.so: undefined symbol: xf86GetPciVideoInfo
(EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 1.4.0.1, module version = 1.2.3
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.4.0.1, module version = 1.2.2
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(EE) No drivers available.
OS : Fedora rawhide 20071114
Nvidia driver : 100.14.19

netllama 11-14-07 09:04 AM

Re: nvidia_drv.so undefinded symbol in xorg-x11-server 1.4.99
 
According to your bug report, the driver installation was aborted abnormally. How did you install 100.14.19 ?

sangu 11-14-07 09:18 AM

Re: nvidia_drv.so undefinded symbol in xorg-x11-server 1.4.99
 
Quote:

Originally Posted by netllama
According to your bug report, the driver installation was aborted abnormally. How did you install 100.14.19 ?

I installed nvidia driver packages in livna repository.

http://livna-dl.reloumirrors.net/fed...elopment/i386/

netllama 11-14-07 09:32 AM

Re: nvidia_drv.so undefinded symbol in xorg-x11-server 1.4.99
 
Unless the official NVIDIA driver package from NVIDIA's website also exhibits the same problem, you should report this bug to Livna.

sangu 11-14-07 09:39 AM

Re: nvidia_drv.so undefinded symbol in xorg-x11-server 1.4.99
 
Quote:

Originally Posted by netllama
Unless the official NVIDIA driver package from NVIDIA's website also exhibits the same problem, you should report this bug to Livna.

nvidia driver(livna package) works well in xorg-x11-server 1.3.0.

then, what "the driver installation was aborted abnormally" means?

AaronP 11-14-07 10:42 AM

Re: nvidia_drv.so undefinded symbol in xorg-x11-server 1.4.99
 
The master branch of the X server contains some major ABI changes that are not yet supported. Normally, the driver would complain and refuse to load, but because some vital symbols were removed from the server, it doesn't even get that far. I'm not sure where you got a "1.4.99" version of X because there's no release with that version, but support for the new ABI will be provided once it has been finalized and a real 1.5.0 X server has been released.

sangu 11-14-07 06:15 PM

Re: nvidia_drv.so undefinded symbol in xorg-x11-server 1.4.99
 
Quote:

Originally Posted by AaronP
I'm not sure where you got a "1.4.99" version of X because there's no release with that version, but support for the new ABI will be provided once it has been finalized and a real 1.5.0 X server has been released.

New xorg server packages were updated in Fedora Development (rawhide 20071114).

See Also :
* Severe X breakage heads up
* http://koji.fedoraproject.org/koji/b...?buildID=24291


All times are GMT -5. The time now is 01:21 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.