nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Requesting texture compression in my application crashes on latest nvidia driver (http://www.nvnews.net/vbulletin/showthread.php?t=102533)

esok 11-16-07 04:48 PM

Requesting texture compression in my application crashes on latest nvidia driver
 
1 Attachment(s)
I have written an application that loads images and asks them to be compressed with the ARB texture compression extensions, which I save to disk and reuse at a later time. I have verified that texture compression is supported in the driver (at least according to the GL extensions). When I first request texture compression, I get the following error message in the console:

depc_bin: glx_texture_compression.c:58: __indirect_glGetCompressedTexImageARB: Assertion `image_bytes >= ((4 * reply.length) - 3)' failed.

I am attaching a bug report, gzipped.

I just upgraded to Fedora 8 and I'm using the livna packages to install the nvidia accelerated driver. The same program worked just fine on the same machine under Fedora 5 with an older driver. I also tried the 96xx series driver under Fedora 8 with the same crash.

AaronP 11-16-07 05:48 PM

Re: Requesting texture compression in my application crashes on latest nvidia driver
 
Can you provide a copy of your application that reproduces the problem, please?

esok 11-28-07 08:25 AM

Re: Requesting texture compression in my application crashes on latest nvidia driver
 
I found the problem. The Mesa OpenGL drivers were being used instead of the nvidia ones. Once I removed Mesa everything worked. Thanks.


All times are GMT -5. The time now is 08:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.