nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   169.04 - Faster RENDER ? Benchmark. (http://www.nvnews.net/vbulletin/showthread.php?t=102691)

Jarzebski 11-19-07 07:59 AM

169.04 - Faster RENDER ? Benchmark.
 
Here is benchmark RENDER extension with Compiz / KWIN

http://www.jarzebski.pl/read/nvidia-...inux-driver.so

faba 11-19-07 11:39 AM

Re: 169.04 - Faster RENDER ? Benchmark.
 
Are those values fills per second or seconds to fill? Because at first look it seems that the new driver is actually slower...

Jarzebski 11-19-07 11:44 AM

Re: 169.04 - Faster RENDER ? Benchmark.
 
fills per seconds. yes - new driver is slower

ZeroDivide 11-19-07 12:41 PM

Re: 169.04 - Faster RENDER ? Benchmark.
 
I have also done some benchmarks with conflicting results.

render_bench - http://www.rasterman.com/files/render_bench.tar.gz
--------------------------------------------
100.14 - http://pastebin.ca/784452
169.04 - http://pastebin.ca/779109

xrenderbenchmark - http://people.freedesktop.org/~zack/...chmark.tar.bz2
-------------------------------------------
100.14 - http://pastebin.ca/784454
169.04 - http://pastebin.ca/784457

The render_bench results show a huge speedup, but xrenderbench doesn't show much change at all. I've also run expedite but it was so slow that i just gave up.

btw, i'm running all these tests on a 8800 gts without compiz or composite enabled.

Sblantipodi 11-19-07 04:34 PM

Re: 169.04 - Faster RENDER ? Benchmark.
 
Quote:

Originally Posted by Jarzebski
fills per seconds. yes - new driver is slower

wow :(

But I nee to say something here:
I have a 8600M GT 256Mb built in/1GB TurboCache with a T7300 2Ghz, 2Gb ram.

Quake 4 id_perftest (1280x800 high quality):
Linux 169.04: 99.46FPS
Windows Vista 169.04: 58.34FPS

zbiggy 11-19-07 07:01 PM

Re: 169.04 - Faster RENDER ? Benchmark.
 
1 Attachment(s)
Quote:

Originally Posted by Jarzebski
fills per seconds. yes - new driver is slower

New driver is much much faster (up to 127 times faster in one of benchmarks). XRender is speed devil now on Nvidia.
Nvidia says about XRender speedup not X speedup so do not use x11perf for measurement.

See GF6150.html.txt for my results of render_bench.tar.gz on Athlon64 3000+ and Geforce 6150.
(save it to disk and rename GF6150.html.txt to GF6150.html)

My Geforce 6150 performed every test in less than 1 second and was always faster than software Imlib2 renderer. In some test much faster than Imlib2. This is what I call hardware acceleration.

The 3rd row in every test measures full software render using Imlib2.
It was slower so in red because my CPU had bad day.


And remember that applications which really uses and benefits from XRender just begin to appear.
For example Firefox 3.0

Dr. Tyrell 11-19-07 08:46 PM

Re: 169.04 - Faster RENDER ? Benchmark.
 
Correction: My HP with "non-standard" 7400Go actually running a bit smoother.
I had accidentally turned on some super-intensive settings in my apps/games.
So, tested with 100.14.23 and then 169.04
169.04 is better all around!!!

<<<MISTAKE>>>
HP 7400Go here, and it's slower.
In fact I get render problems if I slide the performance slider all the way right.
One example, BZflag maxes at 29fps with 169.04.
<<<MISTAKE>>>

The Doctor

ZeroDivide 11-19-07 10:40 PM

Re: 169.04 - Faster RENDER ? Benchmark.
 
The render_bench speedup is impressive, but I haven't found any real world apps to test xrender with. Evas has an xrender backend, but its slow as a dog for some reason. Does anyone know of an app that relies heavily on xrender that can be used to see if the render_bench results hold up in the real world?

I'm starting to think the render_bench results are some kind of fluke :(

ZeroDivide 11-20-07 01:50 AM

Re: 169.04 - Faster RENDER ? Benchmark.
 
It turns out that setting InitialPixmapPlacement=2 actually shows some improvements in benchmarks other than render_bench. But it's a shame that it also slows down other apps like firefox, at least in my case :(

expedite
InitialPixmapPlacement=2
-----------------------------------
nvidia-169.04 xrender - http://pastebin.ca/790277
nvidia-100.14 xrender - http://pastebin.ca/790281
nvidia-169.04 X11 - http://pastebin.ca/790279

xrenderbenchmark
InitialPixmapPlacement=2
-----------------------------------
nvidia-169.04 - http://pastebin.ca/790286
nvidia-100.14 - http://pastebin.ca/790287

Lithorus 11-20-07 08:57 AM

Re: 169.04 - Faster RENDER ? Benchmark.
 
The original benchmark is crap. The older driver was tested with Compiz and the new driver was tested with kwin. How can you call that a benchmark??

I'm not saying that compiz is better than kwin, just that you should atleast have used the same window manager.

Jarzebski 11-20-07 09:56 AM

Re: 169.04 - Faster RENDER ? Benchmark.
 
You are dalton ?

Left Column - 100,14
Right Column - 169.04

YELLOW COLOR = With Compiz
BLUE COLOR = With KWin

too hard ? sorry.

Lithorus 11-20-07 02:44 PM

Re: 169.04 - Faster RENDER ? Benchmark.
 
Quote:

Originally Posted by Jarzebski
You are dalton ?

Left Column - 100,14
Right Column - 169.04

YELLOW COLOR = With Compiz
BLUE COLOR = With KWin

too hard ? sorry.

The new table makes much more sense now, thx.

The table before did really look like that the first column was with compiz and the second was with kwin. Never occured to me that it would be identified by the colors. Might have been in the text though, but I don't read polish :)

Edit:
Btw. I get 40800/sec in the Fill 300x300 trapezoid test with the new drivers. (7600GT)


All times are GMT -5. The time now is 09:28 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.