nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Compiz Fusion no go on 169.04 (http://www.nvnews.net/vbulletin/showthread.php?t=102723)

dahveed3 11-19-07 05:30 PM

Compiz Fusion no go on 169.04
 
1 Attachment(s)
My Compiz Fusion on OpenSUSE 10.3 works with 100.14.23, 100.14.19 but not with the new beta 169.04. Normally the system loads Compiz with compiz-manager, then I use the icon to reload it so I get my decorator of choice.

To show you what's going on I started it my old way:

export __GL_YIELD="NOTHING"
compiz --replace --sm-disable --ignore-desktop-hints ccp &

I got:

compiz (core) Trying 'usr/$LIB/libIndirectGL.so'
compiz (core)-FATAL: No GLX FB Config for default depth, this isn't going to work.
compiz (core)-Error: Failed to manage screen : 0
compiz (core)-FATAL: No manageable screens found on display : 0.0

Bug report attached. If I uninstall the new driver and reinstall the 100.14.23, Compiz works fine.

AaronP 11-19-07 06:46 PM

Re: Compiz Fusion no go on 169.04
 
Please attach the output of nvidia-settings --glxinfo

meierkurt 11-19-07 07:07 PM

Re: Compiz Fusion no go on 169.04
 
Add "--no-libgl-fallback" to compiz Commandline.

meierkurt 11-19-07 07:11 PM

Re: Compiz Fusion no go on 169.04
 
http://forum.compiz-fusion.org/showp...9&postcount=12

dahveed3 11-19-07 07:18 PM

Re: Compiz Fusion no go on 169.04
 
Oh my! Sorry, I just got back from going back to 100.14.23. I can tell you that I had a fully positive glxinfo report, whether running glxinfo, using glxgears, or clicking the glx information within nvidia-settings. It reported the correct OpenGL versions, NVidia drivers, Direct Rendering:yes, etc. Lot's of the usual numbers and stuff too, but of course I can't remember those.

3D OpenGL games were working fine. Only Compiz couldn't get itself going. As soon as I restored 100.14.23, Compiz Fusion is completely back running fine.

If you really, really, really need that information then I'll restore the 169.04 for you. I hope not. I've already switched back and forth twice today. :)

But if you need it, let me know and I'll sacrifice a few minutes for helping to fix this. I'll be leaving until around 11PM here in the eastern US though. I'll check back here when I get back and see if I'm needed. There's a few other folks over at the Compiz Fusion forums complaining about this in both the Packages, OpenSUSE thread and the Packages, NVidia drivers on OpenSUSE thread. They got the same error messages when Compiz was attempting to load that I did. But there are others being thankful for improved Compiz Fusion performance using the new driver. So it appears to effect certain configurations, hardware, I have no idea what.

dahveed3 11-19-07 07:30 PM

Re: Compiz Fusion no go on 169.04
 
Thanks for the link and suggestion. :)

Unfortunately, I am not getting the error line saying that the indirect fallback failed as the other poster of the error messages got. I don't think that is failing. It's the following No GLX Config for default depth and no manageable screens that are the failing lines.

I'll be back later, sorry that I have to leave for a bit now. If the situation is the same I'll reinstall the new driver and post up the nvidia-settings --glxinfo.

dahveed3 11-19-07 10:28 PM

Re: Compiz Fusion no go on 169.04
 
1 Attachment(s)
Okay, hope everyone hasn't gone to sleep.

Here's the resulting text from nvidia-settings --glxinfo with the 169.04 driver installed. I hope it doesn't matter that I ran it while su'd to root because I didn't want it to hide some configuration file somewhere in my home folder where I couldn't delete it later. I generally do nvidia-settings stuff from kdesu or gnomesu anyway.

3D works fine, just no Compiz. I hope this helps somehow. I'll be returning to the driver that works (100.14.23).

First I'll try, hey wait a minute I'll do it right now, starting Compiz with that no fallback command.

Hoky smokes, Batman --no-libgl-fallback worked!!!

Now, how the --- do I get that into the fusion-icon and compiz-manager starting scripts? See, when I right clicked fusion-icon and selected reload window manager Compiz turned itself off again. I need to do that to get the kde or gtk decorators (depending whether I'm in KDE or Gnome at the time) to replace emerald, although I suppose I could just do kde-window-decorator --replace, eh? Kind of defeats the use of either compiz-manager or fusion-icon if neither one would start Compiz correctly.

Maybe I'll search around in the Compiz Fusion forum for someone who has posted where and what to add to those ini files. Pretty sure the fusion-icon one is in the hidden /home/me/.kde/.config/.compiz folder (something like that), but I'm not sure that's where its startup script is. I know where the compiz-manager one is (or at least I found it at one time, suppose I can find it again). But again, not sure where in the ini file to put that no fallback command.

How come the previous drivers never needed that? Think that's the whole problem here?

dahveed3 11-19-07 11:21 PM

Re: Compiz Fusion no go on 169.04
 
I edited the compiz-manager file in /usr/bin/compiz-manager to add --no-libgl-fallback to the compiz options line. And that works.

However, trying to do the same to /usr/lib/python/site-packages/FusionIcon/data.py did not change how Fusion Icon starts Compiz. So if I hit Reload Window Manager on Fusion Icon it turns on Compiz, but without it working and Kwin not doing its job either. Gotta change Fusion Icon to use Kwin, then run compiz-manager to get things back to normal. Then of course to get rid of Emerald I have to do kde-window-decorator --replace &.

Hmm. I appear to need this no-libgl-fallback to be specified, but don't really know how to get Fusion Icon to do that. Perhaps that's not the correct file to edit (I deleted it and renamed the backup file back to data.py, since it hadn't worked).

There's got to be a way to edit what Fusion Icon does. I'll look around some more.

Anyway, I suppose this is a better way to run Compiz anyway as falling back to indirect rendering doesn't sound as nice as just using direct rendering, which seems to be working fine.

Guess it's not a driver problem but rather actually an improvement! It's one of those features, like Microsoft used to say a lot, "it's not a bug, it's a feature!"

Heh heh. I'll go run over to the Compiz Fusion forum unless someone who knows what to do can help out here. Any idea how to get the change into the Fusion Icon script by editing?


All times are GMT -5. The time now is 02:32 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.