nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   no video during POST for GeForce8500GT (http://www.nvnews.net/vbulletin/showthread.php?t=102893)

dsbrown 11-21-07 11:05 PM

no video during POST for GeForce8500GT
 
Dear List Members,

<short version>
openSuSE 10.3 on x86_64 Intel Core2Duo CPU, ASUS P5K motherboard and GeForce8500GT video card. The only video output now occurs *after* Linux has booted up and is ready for user logon. No video is present during the POST. This happened after updating the nVidia driver to version 100.14.19 for x86_64 Prior to that I got video output during POST as well.

<long version>
Installation of openSuSE went fine with no error messages. Updates also fine. Because this is going to be a scientific (medical imaging) workstation I needed to enable 3D and Xgl and compiz. Referred to the openSuSE wisdom at
http://en.opensuse.org/NVIDIA
which recommends a "one click" installation followed by several steps to enable Xgl, etc.

The "one click" method went to completion without error messages. I then used the three invocations of nvidia-xconfig with suggested parameters to permit Xgl operation. No errors during this time although at one point a "black screen and evident lack of synch" occured. The xorg.conf file was (as expected) overwritten each time these commands were issued.

Instructions then said to log off, restart X (ctrl-alt-bspace) and I got a blank screen with no video output from the card (monitor light orange instead of green). SSH'ed into the machine and restored xorg.conf from a backup copy. Then restart X and I am able to log on.

Tried sax2 to set up the nVidia card but again got a black screen (no video) when logging off, on again. SSH once again helped to fix it. But still no 3D and still no Xgl. In fact glxinfo reports display 0.0 non existent and glxgears of course does not run.

Cold boot. Surprisingly (and disturbingly) there is no video during the POST. Only video I get is after Linux and X have taken control of the card. It is as though the motherboard BIOS does not recognise the video card. And because I can see no video during POST I have no way to get at the BIOS settings to see if they have changed, or even to try any other settings!

The card can connect to the monitor (an IBM P275 aka 6632 21-inch monster) with VGA and digital. There is no video output on eiither connector during POST now. Previously I was only able to get output on the VGA connector, being unaware of how to activate the digital.

Is there perhaps a low-level utility that allows the nVidia chipset / bios to be examined and if necessary, reverted from the changes that nvidia-xconfig seems to have wrought?

And is there a way to swap between ananlogue and digital outputs? I would like to use the digital for better display results if possible. Another low-level utility perhaps?

In the meantime I can substitute another nVidia card (a 7800GT) to prove whether the card's "personality" has undergone a change.

Thank you in advance for your patience and advice,
Denis

energyman76b 11-22-07 06:46 AM

Re: no video during POST for GeForce8500GT
 
go to bios. check that your 'first' or 'primary' graphics adapter is set to 'pcie' or 'agp' or whatever you use. if you can't go to bios because everything is black, try to get a pci-card somewhere and plug it in. a lot of computer users have one laying around somewhere ...

dsbrown 11-22-07 06:50 AM

Re: no video during POST for GeForce8500GT
 
Thanks "energyman76b"

Will give that a try with a 7800 card tomorrow.

Regards,
Denis


All times are GMT -5. The time now is 10:10 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.