nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   trouble installing new nforce driver (http://www.nvnews.net/vbulletin/showthread.php?t=10338)

lmetza 04-17-03 07:46 PM

trouble installing new nforce driver
 
Im trying to install the linux drivers (nforce) the new ones thet where released (0256) but they wont work for me.
This is the error message i get when installing the new nforce drivers for linux (srpm).

root@localhost drivers]# rpm --rebuild NVIDIA_nforce-1.0-0256.src.rpm
--rebuild: unknown option
[root@localhost drivers]# rpm --rpmbuild NVIDIA_nforce-1.0-0256.src.rpm
--rpmbuild: unknown option
[root@localhost drivers]#

Here is part of the error messgae when i try from tarball.

nvcrush.c: In function `Nvaudio_mmapwrite':
nvcrush.c:426: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nvcrush.c:426: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nvcrush.c:426: too few arguments to function `remap_page_range_R2baf18f2'
nvcrush.c: In function `Nvaudio_mmap':
nvcrush.c:465: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nvcrush.c:465: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nvcrush.c:465: too few arguments to function `remap_page_range_R2baf18f2'
make[2]: *** [nvcrush.o] Error 1
make[2]: Leaving directory `/home/dan/drivers/nforce/nvaudio'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/dan/drivers/nforce/nvaudio'
make: *** [nvaudio_make] Error 2

Snyperx 04-20-03 09:01 AM

I to am getting basically the same error when trying to install the drivers on a Red Hat 9 install. I read in another post that Red Hat seperated the build function into it's own command.

rpmbuild --rebuild

I , however, could not get it to work. It says Unknown Command. I ended up trying to install the rpm-build RPM package from disk 2, but still get the Unknown Command error. So I am now at a lose, I can not get the drivers to install. I tried noth the SRC.RPM install and TAR install. Neither will work. If anyone has some insight as to how to get these installed it would be greatly appreciated.


NOTE; I am trying to install the lastest version of the Nforce drivers.:confused:

simoneves 04-20-03 07:09 PM

Me too...
 
I just got this too. For completeness, here's what I've done so far...

1. Installed RH9 in text mode to get around described problems with default "nv" driver and LCD panels (even though mine isn't DVI).

2. Rebooted to Run Level 3

3. Found Kernel Source RPM on Install Disk 2 and installed it.

4. Did "rpmbuild --rebuild NVIDIA_nforce-1.0-0256.src.rpm" and got the same "too few arguments to function" error message as the first post in this thread.

System is an Athlon XP2100+ on an FIC AU11 nForce2 board with an EVGA GeForce FX 5200 card.

Please help...

xrehash 04-21-03 11:18 AM

Similar Problem
 
I too am running redhat 9 & I have all my system components work correctly on a A7N8X Deluxe board with an Athlon XP 2400+ chip, with the exception of USB. When I try to install the latest drivers using the correct form:

rpmbuild --rebuild <nforce-src.rpm file>

I get the same compile error.....

The code seems buggy or is not designed for the new libs available in redhat 9.

willhang 04-21-03 12:37 PM

Me too.......:-(

I hope someone helps us soon.....

lmetza 04-23-03 10:02 PM

anyone try the prepackaged ones yet?

simoneves 04-24-03 12:50 AM

Erm...
 
There isn't a pre-packaged one for Red Hat 9.0 yet. That's what we're waiting for... :)

dnoyeB 04-24-03 07:52 AM

rpmbuild
 
You have to install the rpm for rpmbuild. Its a seperate package not installed by default it seems.

I am kind of frustrated myself with NVIDIA's linux support. Seems like some people have had success but not bothered to come back and report how. I'm still trying to install the drivers in RH8 and getting network problems with the driver.

Reminds me of the old tulip vs. Linksys days...

simoneves 04-24-03 11:24 AM

Sorry, I meant there was no RPM for the actual drivers yet. My system already had rpmbuild on it (I did a Workstation Install), but I was getting compile errors building the SRPM...

I then found a built RPM for the previous release (0246, I think) which is network-only, made by a guy called Pheran on the nForcersHQ.com forum. This worked just fine to get the network going.

As for sound, it seems to play the Red Hat test sound fine, but I don't get any sound from (eg.) TuxRacer, so maybe that's a different thing which the proper driver will fix when NV get around to releasing it (or fixing the SRPM)

Sorry for the confusion...

Simon

meterman 04-25-03 10:27 PM

Sound and Network for RH9
 
Hey guys--

RH9 appears to have proper onboard NVIDIA audio like on my A7N266-VM. I recall reading on the Redhat Shrike mailing list archive that there is an issue (and fix) regarding the sound in Tux racer.

The 0256 nvnet driver appears to work well with the "original" RH9 kernel 2.4.20-8. Download the 0256 tar file, unpack it, and edit the /nforce/Makefile to remove the subdirectory reference to NVaudio. The standard make and make install then work correctly, including adding nvnet to modules.conf.

Several posters including myself have had problems installing nvnet on upgraded RH9 kernels. Any ideas in this area?

FWIW . . .
Meterman

tho 06-05-03 10:36 AM

Prepackaged nforce driver for RedHat 9
 
This was discussed in http://www.nvnews.net/vbulletin/show...threadid=11630 , too. I prepared packages for RedHat 9.
Have a look at http://www.rcs.ei.tum.de/~hopfner/nvidia/ this might help.

Cheers,
Tom.


All times are GMT -5. The time now is 02:05 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.