nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Resolutions missing (http://www.nvnews.net/vbulletin/showthread.php?t=103869)

ambro887 12-07-07 05:33 PM

Resolutions missing
 
1 Attachment(s)
Many resolutions are missing on my system.
I have a Toshiba Tecra S5 laptop with Quadro NVS 130M.
Tried drivers 100.14.19, 100.14.23, 169.04
The LCD native resolution is 1680x1050, and the resolutions availabe are:
640x512, 700x525, 800x512, 1280x1024, 1400x1050, 1600x1024, 1680x1050.
Many resolutions (which are available in WinXP) are missing, like 800x600, 1024x768 and 1280x800. There is no 16:10 resolution between 800x512 and 1600x1024, which makes playing many games quite sad - either bad fps or terrible graphics. I haven't found any way to add custom resolutions.

xbobmx 12-07-07 05:40 PM

Re: Resolutions missing
 
http://tldp.org/HOWTO/XFree86-Video-Timings-HOWTO/

ambro887 12-07-07 05:52 PM

Re: Resolutions missing
 
I've read section 2 but it doesn't work. My Screen section is like that:
Code:

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport  0 0
                Depth    24
                Modes "1680x1050" "800x512" "800x600" "1024x768" "1280x800" "1280x1024" "1400x1050"
        EndSubSection
EndSection

The resolutions I added are ignored and not available:
Code:

(--) NVIDIA(0): Connected display device(s) on Quadro NVS 130M at PCI:1:0:0:
(--) NVIDIA(0):    Toshiba Internal LCD (DFP-0)
(--) NVIDIA(0): Toshiba Internal LCD (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): Toshiba Internal LCD (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0): No valid modes for "800x600"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "1280x800"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):    "1680x1050"
(II) NVIDIA(0):    "800x512"
(II) NVIDIA(0):    "1280x1024"
(II) NVIDIA(0):    "1400x1050"
(II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050


AaronP 12-07-07 07:10 PM

Re: Resolutions missing
 
Please start X with xinit -- -logverbose 6 and then generate and attach a new bug report.

ambro887 12-08-07 06:25 AM

Re: Resolutions missing
 
1 Attachment(s)
Here it is

ambro887 12-08-07 06:35 AM

Re: Resolutions missing
 
this was with no modes specified; if I specify modes as above nothing changes in the log except what I have already mentioned

AaronP 12-08-07 10:26 PM

Re: Resolutions missing
 
Most of those modes are rejected due to the very narrow range of valid refresh rates reported by your monitor:
Code:

(--) NVIDIA(0): Valid HSync Range            : 64.0 kHz - 66.0 kHz
(--) NVIDIA(0): Valid VRefresh Range        : 59 Hz - 61 Hz

You can override the EDID and specify your own sync ranges by adding the UseEDIDFreqs X config file option to the Device or Screen sections and the appropriate HorizSync and VertRefresh options to the Monitor section.

ambro887 12-09-07 05:29 AM

Re: Resolutions missing
 
Thanks, now I get much more resolutions, but there are still no more 16:10 resulutions. If I specify "1280x800" in Modes it still doesn't work; the driver only probes for certain resolutions and this one is not one of them.
Code:

(WW) NVIDIA(0): No valid modes for "1280x800"; removing.

AaronP 12-09-07 11:03 AM

Re: Resolutions missing
 
There's no standard 1280x800 mode and your EDID doesn't define one. You'll need to add custom modes with the ModeLine statement in the Monitor section. See the xorg.conf, gtf, and cvt man pages for more details on how to do that.


All times are GMT -5. The time now is 06:22 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.