nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   RH 9.0 and LAN driver (http://www.nvnews.net/vbulletin/showthread.php?t=10465)

ricosman 04-20-03 12:32 AM

RH 9.0 and LAN driver
 
I'm very new to the linux world. I just built a box with the intent of learning linux (old windows person). I am using an Asus A7N266-VM motherboard and all of it's on-board peripherals (Audio, LAN, and Video). All are using the GeForce Chipset and MCP-D integrated multimedia chipset. I loaded Redhat 9.0 without a problem, and it loaded the drivers for the soundcard and the videocard great. I can't, however, get the LAN to work. The driver is not listed as installed. I'm on the Nvidia website, but they only list drivers for RH 8.0. Will RH 8.0 drivers work with RH 9.0 for lan? Also, how can I install them?

Thanks!!

Rico

AranC23 04-23-03 02:45 PM

The release notes explain all...
 
IIRC, the release notes or readme discuss the nvnet driver installation pretty thouroughly... have you followed the instructions found in that document? It discusses changes to your modules.conf file if nothing else...

davecs 04-24-03 06:13 PM

I am using Mandrake 9.1 with the same motherboard. I got the video driver *.run file to load at the second attempt (ie re-installing Mandy from scratch) but for the life of me I cannot get nvnet to work. There is a line in my modules.conf file which says:

alias eth0 nvnet

but when I start a terminal as root and type 'alias<enter>' none of the aliases defined in modules.conf are reported.

Also I am getting horizontal distortion on my monitor (Xiod 17" LCD, made by Samsung, Serial IM17RU). This did not happen when I used a PC-Chips motherboard.

Could the problem be that modules.conf is not being called? If so how would I fix it?

DAVE

AranC23 04-25-03 10:10 AM

The alias shell command reports shell aliases, it is totally unrelated to the modules.conf file.

Does your current configuration attempt to bring up eth0? Does lsmod (as root) show nvnet as being loaded?

Does dmesg show any messages regarding nvnet?

davecs 04-25-03 04:59 PM

I'll check when next in Linux. Unfortunately I can't connect to the net except in Windows!

davecs 04-26-03 05:25 PM

AranC23 asked:

The alias shell command reports shell aliases, it is totally unrelated to the modules.conf file.

Does your current configuration attempt to bring up eth0? NO

Does lsmod (as root) show nvnet as being loaded? NO

Does dmesg show any messages regarding nvnet?

No, The only mention of bits that seem relevant to networking and internet are:

Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket

NFORCE: IDE controller at PCI slot 00:09.0
NFORCE: chipset revision 195
NFORCE: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda: DMA, hdb: DMA
ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc: DMA, hdd: DMA (I put space between : and D to prevent "Smiley")

NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.

Does this tell you anything?

DAVE

scritch 04-29-03 11:26 AM

I ran into the same problem (no lan) with my Shuttle SN41G2 with Redhat 9. I tried installing the .rpms for the problem but they wouldn't show up when i tried to do a modprobe nvnet.

Then I downloaded the .tar.gz version of the nforce drivers, and got them to work. After you un-tar the drivers, you'll find there's a nforce/nvnet directory under your current directory. I did the following that works:
cd nforce/nvnet
make clean
make
make install
modprobe nvnet

and then made sure that my "alias eth0 nvnet" line was in /etc/modules.conf file.

This worked quite well with the 2.4.20-8 kernel that comes on the RedHat 9 base install, but when i upgraded to 2.4.20-9 it wouldn't work, so I am booting from 2.4.20-8 from the grub boot-loader screen until I can find the new driver from NVIDIA that supports Redhat 9.

davecs 04-29-03 05:21 PM

I think that's the problem: Mandrake 9.1 is using a "bleeding edge" kernel which has been modified with Supermount, etc., and hopefully nVidia will update their driver to cope soon.

(I've read somewhere that Mandrake are not fussy about including the latest stuff if they think it is stable, and this applies to the Kernel which I think is 2.4-21).

Meanwhile I still have Windows 98SE to connect to the net. As far as Linux is concerned, I love playing with it, and it is fun watching the software catching up with Windows. It will nose in front in the not-to-distant future, by which time I hope I have solved all my problems!

davecs 04-29-03 06:20 PM

See the thread on nForce2 and Mandrake 9.1 ,
it seems that in Mandrake 9.1 you have to install the kernel-source rpm before the instructions given by nVidia work.

It did for me!

Possibly something similar works for Red Hat people?

Now to sort out the video driver problems!

DAVE

urick_the_red 04-30-03 11:30 PM

I have exactly the same problem...


All times are GMT -5. The time now is 12:14 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.