nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RH 9.0 and LAN Driver (http://www.nvnews.net/vbulletin/showthread.php?t=10466)

ricosman 04-20-03 12:35 AM

RH 9.0 and LAN Driver
 
I'm very new to the linux world. I just built a box with the intent of learning linux (old windows person). I am using an Asus A7N266-VM motherboard and all of it's on-board peripherals (Audio, LAN, and Video). All are using the GeForce Chipset and MCP-D integrated multimedia chipset. I loaded Redhat 9.0 without a problem, and it loaded the drivers for the soundcard and the videocard great. I can't, however, get the LAN to work. The driver is not listed as installed. I'm on the Nvidia website, but they only list drivers for RH 8.0. Will RH 8.0 drivers work with RH 9.0 for lan? Also, how can I install them?

Thanks!!

Rico

Marty 04-20-03 01:51 PM

:D
Hello Newbie;

You should just download the source rather than the pre compiled redhat 8.0 rpms. This way you will create a driver tailored to your system. At the bottom of the download area for the nforce drivers, look for NVIDIA_nforce-1.0-0256.src.rpm
save this file to a convenient spot in your home directory and then open a terminal and log in as root by typing su and then givinig it your root password. Then cd to where you saved the .src.rpm file and type rpmbuild --rebuild NVIDIA_nforce-1.0-0256.src.rpm Please note that there are 2 - signs before the rebuild command ( -- not -). The system will chew on it a while and spew out many lines of stuff. Towards the end it will give you a "wrote" statement with a path to where the new driver it just built can be found. It should be in /usr/src/redhat/RPMS/i386
You should cd to that directory and then type rpm -ivh NVIDIA_nforce-1.0-0256.i386.rpm You should see 2 lines of dashes as it installs. You will need to restart your computer to let kudzu find the network card and configure it. It should now work.

Good Luck;
Marty

Marty 04-22-03 05:35 PM

:D
Hi Rico;
I may have spoeken prematurely. I have the same motherboard as you do and was running RH 8 without problems. I just installed RH 9 on it and had a similar problem with the network card. I found that by putting a pci network card in the machine and rebooting, kudzu woke up and found the onboard card as well as the second one. I then removed the second one and told kudzu to forget the second card. All went well till I upgraded the kernel to 2.4.20-9. That kernel won't see any nic, no matter what. I tried all sorts of things, but it wouldn't work. I went back to 2.4.20-8 (the original kernel from the CD's) and all was fine again. This is the first time I ever had a problem with a kernel upgrade from RH. The instructions I gave you in the last post do not apply as they won't install under RH 9, which seems to have native support fot the onboard sound and nic. The native graphics support is very helpful, but won't run open GL. You will need to install the newest Nvidia driver for that. It's very easy to do, as long as you are booted into run level 3 as root. (To do this edit /etc/inittab and change id:5:initdefault: to id:3:initdefault: Then reboot and give it your root password. After you download the file from nvidia website, execute it by typing sh a space and then the name of the driver. You will then need to edit /etc/X11/XFree86config one time. Just change the driver from "nv" to "nvidia" and make sure the load "glx" line is present in Section "module". After that is saved, you won't have to mess with it again. You can test the system by typing startx It should start in graphical mode. You can then change the id:3 back to a 5 and reboot again. You should now have open GL support so you can play UT 2003, etc.

Hope this helps;

Marty

meterman 04-22-03 08:33 PM

More nvnet with RH9 on A7N266-VM
 
Hey, guys--

I have the same configuration. The 4349 graphics driver installed without a hitch and seems to work well.

As noted by others, the built-in audio support seems to work (though I haven't tried anything fancy).

However, I have never been able to successfully make nvnet. /proc/version returns:

Linux version 2.4.20-8 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13 17:18:24 EST 2003

I've tried the make in the nvnet directory, and from the nforce directory with a modified Makefile (ie, removing the reference to nvaudio). Here is a random sample of the errors:

In file included from /lib/modules/2.4.20-8/build/include/linux/irq.h:19,
from /lib/modules/2.4.20-8/build/include/asm/hardirq.h:6,
from /lib/modules/2.4.20-8/build/include/linux/interrupt.h:46,
from nvnet.h:30,
from nvnet.c:21:
/lib/modules/2.4.20-8/build/include/asm/irq.h:37: invalid suffix on integer constant
/lib/modules/2.4.20-8/build/include/asm/irq.h:37: parse error before numeric constant
/lib/modules/2.4.20-8/build/include/asm/irq.h:37: `disable_irq_R_ver_str' declared as function returning a function
/lib/modules/2.4.20-8/build/include/asm/irq.h:37: warning: function declaration
isn't a prototype
/lib/modules/2.4.20-8/build/include/asm/irq.h:38: invalid suffix on integer constant

So, any suggestions would be greatly appreciated.

Marty 04-24-03 07:39 AM

Hi Meterman;

Was yours a clean install of RH 9? I did an upgrade from RH 8 to 9. All I did to get my onboard nic working was to stick another one in the machine and reboot. When kudzu saw the new nic it also saw the onboard one. As long as I don't do the kernel update, it seems to work fine. The sound driver works fine with UT 2003 and anything else I have tried it with so far. If you like I can send you any configuration files in my set up. Let me know which ones you would like to see.

Marty

meterman 04-24-03 07:05 PM

Hi, Marty--

Thanks for the reply. This was a clean install of RH 9, but I updated several components via up2date after the install. By accident, I also updated the kernel. But I'm still running the original kernel 2.4.20-8 with the matching sources. I have tried and failed building nvnet several times, so am not sure how clean the system is now. I have tried running "make clean oldconfig dep" in the kernel directory for whatever that is worth.

Interestingly, an 0248 nvnet build RPM from: http://www.pheran.com/nv7linux/
works. However, I couldn't build this version from source either.

From reading the posts, it sounds like several people have had trouble installing nvnet on RH9. If this is widespread, perhaps Nvidia will release an improved platform driver in the near future. I ran RH 8 for some time and was able to build and install the 0248 driver several times as the kernel updated.

So (also being something of a newbie), I'm not sure where to go from here. I could do a re-install of RH9.

Regards--

Marty 04-25-03 02:14 PM

:D
Did you try putting another pci nic into the machine and rebooting it? That's what finally woke kudzu up in mine. Also, you can use webmin to uninstall the 2.4.20-9 kernel and kernel header. It's a great swiss army knife for just about everything in the system and it's free. get it from www.webmin.com it has an update tool built into itself so you can keep it up to date easily. It works great for package management.

Hope this helps;

Marty

Marty 04-25-03 04:24 PM

:D

One last thought, did you look in /etc/modules.conf ?
you need to be logged in as root, and you can open the file with the text editor of your choice. Make sure there is a line "alias eth0 nvnet" you could also have a line "alias eth1 nvnet" both these lines appear in mine. RH9 seems to have native support for this network controller, I don't think you need to compile any drivers at all.

Good Luck;

Marty

zeroinfin 04-25-03 05:26 PM

HELP!!!
 
Hey Guys,

Thanks so far for your help your conversation has helped me so far.

But now for the NIC I have the same system that you guys have (nforce-a7n-266-VM). I have tried putting in a new NIC and yes Kadzu found that no problem but it still did not find the on-board NIC. Also I have gone in and added the alias eth0 nvnet to the modules.conf file and it returned not found or present.

Any Idea's, your help would be greatly appericated and is definatley needed.

Thanks

meterman 04-25-03 10:01 PM

OK!

Did a clean install of RH9 with a DFE-530TX+ NIC also installed. System comes up with the DFE as eth0 (alias eth0 8139too in modules.conf). No sign of nvnet.

Tried removing the DFE card and rebooting to trigger the installer. DFE card is successfully uninstalled, but still no sign of nvnet. Did a complete disk search for nvnet and found nothing. Did the add/remove NIC a couple of times, including manually adding nvnet to modules.conf, to no avail.

Finally, downloaded the 0256 tar file, edited the resulting /nforce/Makefile to remove the nvaudio subdirectory, and tried make and make install. Success! I am writing this on the resulting system.

By the way, I haven't installed the video driver yet. That went fine last time.

The next question is whether this will still work on an upgraded kernel. I think others have not had success.

Comments or ideas?

Thanks--
Meterman

zeroinfin 04-25-03 10:11 PM

I have everything working EXCEPT!
 
I have everything working EXCEPT the kernel upgrade. When you are prompted to upgrade DON'T,unless you can find the fix. I just went thru it and had to roll back to my previous version. Once you do the upgrade you will lose the NIC even if you have the nvnet installed.

Good luck and let me know if you have success,


All times are GMT -5. The time now is 11:56 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.