nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Slackware 9.0 (http://www.nvnews.net/vbulletin/showthread.php?t=10668)

vexer 04-23-03 07:04 PM

Slackware 9.0
 
1 Attachment(s)
Athlon 2600+
Soundblaster audigy
512mb ran
Geforce4 ti4200 128mb ddr agp8x
Dell M991
obo A7V8X (lan + sound)

Slackware 9.

I compiled my kernel (2.4.20) first thing. Downloaded the Nvidia drivers for I32 (auto installer) and ran it. It finished saying, sorry, you suck, no header files found. Taking the advice of other people, I download the GLX and Kernel and make, make install. I configure xf86config, uncomenting glx, editing "nv" to "nvidia", uncomment the video ram. Did startx, screen went black, bunch of random characters showed up not long after.

vexer 04-23-03 07:19 PM

recent update, the installer works, but screen still messes up.

iive 04-23-03 08:04 PM

slackware & kernel header files
 
you cannot compile kernel module.
In fact it is highly possible you to don't be able to compile anything. The problem is that gcc cannot find the linux include headers.
By some reason Slack8.1 & 90 install kernel headers directly into /usr/include, and not as usuall in /usr/src/linux/include. There are 2 ways to fix that. I do not recomend you to install the kernel-headers package if you don't use the distro kernel.
The right way to fix it is to do:

ln -s /usr/src/linux/include/linux /usr/include/linux
ln -s /usr/src/linux/include/asm /usr/include/asm

usually /usr/src/linux is symlink to the current kernel (e.g. /usr/src/linux-2.4.20)


I've mailed slackware support with details of this (common) problem, so it should be fixed next release).

vexer 04-23-03 08:06 PM

1 Attachment(s)
The installer, aka, Nvidia-blah-blah.run works fine, it finds my headers and everything. Just that after I try to startx, after modifying XFree86, it doesn't work. lsmod shows no driver either. Modprobe finds nothing either.

Reviewing my log file, i found that it says it works! But in reality, I just get gardbage on the screen. Most of the time it's 1 big vertical white bar on the right side of the screen and anothere 3 horizontal bars across. I can't ctrl-alt-del reboot and can't ctrl-altally.-backspace to get out of X, i need to shutdown my system manu

iive 04-23-03 08:40 PM

hmm, i'm out of ideas. can't see anything strange in xf86config and in the log.

1. try to see if the card works in graphics,
try the svgalib (there are demo/test programs in /usr/lib/svgalib/ )
2. try to set the safest and slowest options in bios, mainly about agp. You know make it run, then make it run faster. (there was module option for apg 4x and specific MotherBoard)

vexer 04-24-03 03:41 PM

I tried accel, it tells me no acceleration supported. I tried testaccel 24 (24 behind 1024x7**x64k) and it works fine...

douglass 04-25-03 05:11 AM

Are you loading the kernel AGPGART? What about framebuffer devices?
You have this in your XF86Config file:
Section "Device"
Identifier "Geforce4"
Driver "nv"

Which is wrong, and needs to say nvidia.

You also have this in the Modules section

# This loads the GLX module
# Load "glx"

Which needs to be uncommented.

Not that it is specifically relevant to your issue, but I notice you are only using Ugly fonts with X. After you get X started, you should fix that.

Just to verify, the problem shows up in the log, too:


(**) |-->Screen "Screen 1" (0)
(**) | |-->Monitor "My Monitor"
(**) | |-->Device "** NVIDIA (generic) [nv]"

vexer 04-25-03 02:25 PM

it works now, I set Option "NvAGP" "0"

maxim 04-28-03 09:43 AM

1.0-4363 works well on Slack 9.0 ?!
 
I recompilled kernel, edited XF86Config and started installation script(1.0-4363). I was very surprised, everything worked as it should. All open GL screensawers work and also Quake III.

Hardware: Pentium 3 1GHz
512 MB ram
Ge force 2 mx/mx 400
i815 board

volt 04-28-03 10:13 AM

Yep.

Slack 9 does not have kernel source on the CD-ROM because of space constrains. Get a new kernel, compile it, boot it and install the drivers. Should work.

maxim 04-29-03 03:35 AM

slackware kernel
 
Downloaded it before from ftp site ( I think /slackware-9.0/slackware/k dir or something like that).
Didnt write it because Slack user should know it.
There is REDME on ftp!!!
There is also some good stuff in /extra dir (like checkinstall, java support, emu tools ...) that are not on CD (iso image).

I just wanted to say that new drivers work. I was surprised !!!!


All times are GMT -5. The time now is 01:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.