nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   forcedeth driver for ethernet in Shuttle XPC Glamour Series (http://www.nvnews.net/vbulletin/showthread.php?t=106750)

pgordon13 01-23-08 11:50 AM

forcedeth driver for ethernet in Shuttle XPC Glamour Series
 
Hi -

Question here about getting ethernet drivers to play with the Shuttle XPC Glamour series. These sysems have Nvidia Geforce 7/ nforce 630a graphics/chipset onboard. These systems have an onboard gigE controller
(Marvel 88E1116 Gigabit Ethernet Controller).


Initially tried installation of CentOS 4.5 (2.6.9-55 kernel), many important driver modules wouldn't load - sata_nv, ahci, or forcedeth all failed when probing the system.

Then tried downloading most recent nforce driver package (before support seems to have vanished)

[url="http://www.nvidia.com/object/linux_nforce_1.23.html"]

and incorporated newer drivers into the CentOS initrd ramdisk:

http://www.redhat.com/archives/kicks.../msg00081.html

this step helped in probing and loading ahci and sata_nv drivers, but not forcedeth module.


I've confirmed this behavior on both the Shuttle XPC SN68SG2 and G5 models (AMD x86_64 based), which have identical nforce chipsets.

Have also tried installs with CentOS 5.0, with kernel 2.6.18-8, with similar ethernet detection problems.

Anyone have any suggestions or similar experiences with this chipset?

Thanks in advance,

Peter Gordon

mlauss 01-23-08 11:54 AM

Re: forcedeth driver for ethernet in Shuttle XPC Glamour Series
 
Did you try the "sky2" or "skge" driver? These are for Marvell ethernet chips.
And get a newer kernel. 2.6.18 is over 18 months old!

pgordon13 01-24-08 07:29 AM

Re: forcedeth driver for ethernet in Shuttle XPC Glamour Series
 
Thanks for the suggestions!

I recompiled the 2.6.23-13 kernel with PHY device support and added in the
MII PHY device driver, and now it plays nice.

This solves my immediate problem, but while I'm at it, might as well push my luck. The reason I'm using the relatively out of date 2.6.9 kernel is because this machine is network installed via kickstart/anaconda (along with a number of others), and as such, it is tethered to the ramdisk image supplied by CentOS/RedHat.

I've found the hard way that kickstart doesn't play nice with rebuilt kernel initrd files build from, say, mkinitrd, so I'm struggling to figure out how one might add in the necessary drivers one needs into the CentOS supplied ramdisk, given that these may be new additions. Updating drivers doesn't seem too difficult, (as in link supplied in original note), but I'm at a loss as to how to incorporate newer ones...

Peter


All times are GMT -5. The time now is 01:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.