nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   1.0-4349 + 2.4.20 + Sis 645: HELP !!! (http://www.nvnews.net/vbulletin/showthread.php?t=10716)

Schott 04-24-03 10:49 AM

1.0-4349 + 2.4.20 + Sis 645: HELP !!!
1 Attachment(s)
Hi there,

I'm experiencing problems trying 1.0-4349 driver, but I guess I am doing something wrong. Here are the facts.

On My RH8 box using default kernel (2.4.18-14), install scripts works fine, X works (I guess fine).

On the same machine, booting on my freshly compiled 2.4.20 kernel, after executing install script with succes, X freezes before logo display, just showing weird characters (especially ) sometimes colored, sometimes B&W. At this point, CTRL+C won't do anything, CTRL+ALT+BACKSPACE either, I can't switch to an other term, all I can do is CTRL+ALT+DEL which reboots the machine.

As I don't change anything but kernel, I guess I made something wrong selecting options.

I've spet several hours trying pieces of advice found on this forum, tryied several NvAGP options, rebuilt my kernel several times... still nothing working. The last line in XFree log is: (II) NVIDIA(0): Setting mode "1024x768"

The machine is a PIV 2.53 on a Sis 645 based board with a GeForce4 MX 420 card.

You'll find my .config file attached, as I really suspect this is the point.... I'll post XFConfig & log if you need them, but I've used the log (verbose 5 mode) to check my compiling options, there's no EE line anymore.

Thanx in advance for your help


Schott 04-24-03 11:28 AM

Well, keeping trying, logging at verbose 7 level, no EE line, one WW line in log (mode clock 65MHz exceeds DDC maximum 60MHz) , whatever kernel I use.

I've tryied every NvAGP option, still the same: works on 2.4.18-14, not on 2.4.20.

Nvidia driver is of course reinstalled (with succes according to the log) every time I boot a different kernel.

Well, it seems that my problem is not AGP-related, but I still have no clue.

Keeping trying, keeping an eye on this forum...

Any advice appreciated.


Schott 04-25-03 12:26 PM

1 Attachment(s)
Hi there,

Keeping trying, but getting less and less optimistic....

These are my latest tries:

I've taken RH8.0 .config file (from /usr/src/linux-2.4.18-14), put it on my /usr/src/linux dir (actually /usr/usrc/linux-2.4.20, linked to /usr/src/linux) after a make mrproper, then done a make oldconfig and rebuilt my 2.4.20 kernel & modules.

I now have a 2.4.20 kernel matching RH8 original .config. SO....

I Have the same kernel options, the same XFree conf file, using the same driver on the same machine and guess what: it's still not working on 2.4.20.

I've tried every AGP option, including disabling it, same result every time.

I've tried barnd new 4363 driver... nothing has changed.

What am I doing wrong??? There is no error in nvidia installer log, no EE line in verbose 5 Xfree log, not even a warning except to tell me that mode clock 65MHz exceeds DDC maximum 60MHz, but I get the same on the RH kernel ! Nothing appears in any syslog.

Did anyone managed to get this card running on 2.4.20 kernel? Any issue I've missed?

Please help, as I'm really getting fed up with building kernel, rebooting... I sometimes feel that I'm running XP !!

Here's attached Xfree log file, using 2.4.20 kernel with RH .config file and 4349 driver (found no difference with latest one) and my XFConfig file, disabled AGP version is:

# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"# Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"

Section "InputDevice"
# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc102"
Option "XkbLayout" "fr" #Option "XkbVariant" ""

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30.0 - 54.0
VertRefresh 50.0 - 120.0
Option "dpms"

Section "Monitor"
Identifier "Tele"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30.0 - 50.0
VertRefresh 60.0 - 60.0

Section "Device"
# no known options
Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
Option "NvAGP" "0"
# Option "NoLogo" "true"
# Option "RenderAccel" "true"
# Option "TVOutFormat" "SVIDEO"
# Option "TVStandard" "PAL-N"

Section "Screen"
# Monitor "Tele"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"

Section "DRI"
Mode 0666

Any other file you may need to help will be posted on request.

Best regards,
starting missin his good old Matrox Mystique

Schott 04-25-03 01:12 PM

Here's my /proc/driver/nvidia/cards/0:

Model: GeForce4 MX 420
IRQ: 11
Video BIOS:
Card Type: AGP

Maybe that will help...


Schott 04-25-03 10:24 PM

1 Attachment(s)

As the only warning I've found in XFree log was about modclock in 1024x768, I've tryed using 800x600... same result !

My motherboard is a MSI 6533:

If I can get some usable MS-DOS bootable floppy, I'll try to update the bios (latest revisions description talk about VGA & AGP).

Last file I can attach is the installer log: here's 4363 one.


I'm also a little surprised some get helped to get root on their system, and I don't even get a thing like "I've looked at your files, found nothing, good luck since there's no hope".

Schott 05-03-03 11:47 PM

Guess what...

It's now working !

A friend of mine (well, this one is a reaaaaal good one!) lent me his Intel845PE based mother board and everything works just fine.

It seems hard to believe but Geforce4+2.4.20+Sis645 is a non functional combination.

By the way, I'm quite deceived by this forum. I just have to look at the number of downloads of the files I've posted to see that my problem didn't interested many of you... I'll look twice before I buy an other nvidia product as this lack of real support has really been painful. Would you buy a product you know you'll have to wait 2 weeks before learning that you can spend 140 euros more to have it working ? never again.

Andy Mecham 05-03-03 11:58 PM

Sorry, I completely missed this thread.

How did you configure your 2.4.20 kernel? Your problem is likely caused by some change made to 2.4.20, as 2.4.18-14 worked for you. It would help to see your .config to help narrow it down.


All times are GMT -5. The time now is 01:52 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.