nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   rh9 / 4363 breaks open office and xmms (http://www.nvnews.net/vbulletin/showthread.php?t=10732)

athlonuser 04-24-03 03:25 PM

rh9 / 4363 breaks open office and xmms
 
mobo - epox 8kta3
proc - athlon 900
video card - GeForce2 MX 400
video bios - 03.11.01.26.02
driver - Linux-1.0--4363
distro - rh9 (2.4.20-6 kernel)

both xmms and openoffice fail to even start.
both programs showed similar behavior under the previous (-4349) driver.
i'd seen mention of the later 2.4.20-9 kernel patch in the discussion threads. should i give this a shot before doing anything else?

bwkaz 04-24-03 03:47 PM

I'd at least try it, though I don't know how much it'll help.

When you say they don't start, what actually happens? Run them from a terminal, and see what gets printed.

athlonuser 04-24-03 04:12 PM

xmms
 
looks like segmentation fault for xmms, don't know how to start openoffice from shell...
will have to download the 20-9 kernel patch. as i'm on dialup it may take a bit. thanks for the response.

bwkaz 04-24-03 04:27 PM

I think you can start OpenOffice with ooffice, but I'm not sure -- hit oo, then hit the tab key a couple of times to see what it thinks exist, in the way of executables that start with "oo".

athlonuser 04-24-03 05:03 PM

open office
 
the oofice seemed to do the trick, unfortunately it returned the same "segmentation fault" as xmms seemed to. still downloading the kernel patch, so we'll see.

bwkaz 04-24-03 05:10 PM

Maybe doing something like export LD_ASSUME_KERNEL=2.2.5 before starting xmms might help? If it does, then redo the nVidia drivers, but pass --force-tls=new to the installer.

I remember a very few people who couldn't get the installer to detect their glibc / kernel TLS support correctly; you might be having that same problem. Maybe. Try the LD_ASSUME_KERNEL thing first.

athlonuser 04-24-03 05:39 PM

LD_ASSUME_KERNEL=2.2.5
 
the export L_ASSUME_KERNEL_2.2.5 worked beautifully. it ran both programs but while running xmms reported

libGL.so.1: cannot handle TLS data

now should i uninstall the nvidia driver, then do the

sh NVIDIA-Linux-1.0-4363.run --force-tls=new

Andy Mecham 04-24-03 05:43 PM

You need to upgrade your glibc package - the boxed version of RedHat 9 shipped with a broken glibc. That's the source of your problems.

--andy

athlonuser 04-24-03 05:54 PM

glibc
 
so after downloading and installing the new and improved glibc i need to reinstall the nvidia drivers or is simply installing the non-broken glibc enough?

Andy Mecham 04-24-03 05:56 PM

The tls_test in the installer might have failed, depending. It's probably best to reinstall the driver to make sure the TLS libraries are installed. You shouldn't need to force them.

--andy

athlonuser 04-25-03 06:55 PM

sorry no joy
 
tried the glibc i686 upgrade rpm, the 2.4.20-9 i686 kernel upgrade rpm, uninstalled and reinstalled the nvidia drivers after both, still needed to use the
export LD_ASSUME_KERNEL=2.2.5
to make xmms and openoffice jump.
even tried to force the tls as bwkaz mentioned trying and it still didn't help.

bwkaz 04-25-03 09:45 PM

Just to make doubly sure the glibc update happened, what does running /lib/libc.so.6 tell you, in the first line, where it has the version string?


All times are GMT -5. The time now is 11:05 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.