nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA FreeBSD (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47)
-   -   Several Issues with several drivers (http://www.nvnews.net/vbulletin/showthread.php?t=107623)

lguerb 02-07-08 03:57 PM

Several Issues with several drivers
Hi, I can't get the ndivia drivers work properly on my new laptop. The card is a GeForce 6100 Go.

Now, first, I installed DesktopBSD 1.6, which is based on FreeBSD 6.3-RC2. The driver was 100.14.19, and this was the only system in which I found no problems at all.

After that, I decided to upgrade to FreeBSD 7.0-PRERELEASE (from scratch, not from DesktopBSD). I build the driver via ports, which was again 100.14.19, and I found some problems in X: some things aren't well rendered. Some examples:

- the "close tab" button in a firefox tab.. when I put the mouse over it, it makes the border of the tab just above it disappear.. like if the button was zoomed or something.

- colours are really weird. I mean, at first sight everything is ok. But I remember Xfce4 default theme for xfwm4 being definitely blue, while here it's gray (??). Also the other colours are a bit corrupted (I have the same XFce 4.4.1 in my desktop computer to compare).

- other issues in firefox: sometimes some lines "move" or have the feeling of being bigger, for example when I select two consecutive lines, or when I put the mouse over a link.

Now, probably you would say that this must be a FreeBSD 7 issue.. I don't really think so, and later you will see why.

I decided to try with latest driver, 169.07 (disabling the version checking in nv-freebsd.h; everything compiled and installed perfectly). Now, the above problems continue.. AND, also a new problem appears that wasn't present before: when I switch from X to a console via CTRL+ALT+FX, the console is all blurry and corrupted, barely can read, and everything is like water, slightly moving..

Ok, now, the reason why this is NOT a FreeBSD 7 issue: after removing DesktopBSD 1.6, and before installing FreeBSD 7, I also tried my laptop with Linux Slackware 12. All the problems I mentioned above (including the blurry console) already happened here. In Slackware I tried 100.14.19, 169.07, 169.09, and everything was the same (except perhaps a less blurry console in 100.14.19; still weird though).

So, what is going on here? If I use the nv drivers everything is perfect (and in fact I can use this to compare the colours in the same computer, for example; another issue just came to me: fonts are much bigger than using nv, and they shouldn't be, they're set to size 9). How is it possible that in DesktopBSD the drivers work fine and they don't work neither in FreeBSD 7 nor in Slackware 12? I find it somehow weird.. I will try in the next hours DesktopBSD again (I didn't use Firefox then, and never tried xfce), maybe the little problems with firefox et al. were there after all.. but kde worked very fine. I even literally copied the xorg.conf file of desktopbsd to the other ones, and tried several modifications too.

I'm totally clueless about this. I can't use neither FreeBSD 7 nor Slackware.


I have the following maybe useful information:

with the nv driver, xdpyinfo gives me

1280x800 pixels (433x271 millimeters)
75x75 dots per inch

while with the nvidia drivers, the output is

1280x800 pixels (322x201 millimeters)
101x101 dots per inch

zander 02-07-08 04:26 PM

Re: Several Issues with several drivers
Do these problems reproduce if you disable COMPOSITE?

lguerb 02-07-08 04:31 PM

Re: Several Issues with several drivers
Yes, they're still there.. I tried all combinations of the two following:

Section "Extensions"
Option "Composite" "Disable"

Section "ServerFlags"
Option "AIGLX" "off"

Colors are fine. For some reason, the xfwm4 theme is grey where it should be blue, but nv shows it grey too. This is the only non-issue of the above though.

lguerb 02-07-08 09:54 PM

Re: Several Issues with several drivers
Ok, I partially fixed the problem.

The nvidia driver was using EDID from the card to obtain the DPI.. but it took 101x101, and that's not working good. So I forced the DPI in Xorg.conf and now 100.14.19 is FINE.

With 169.07, also there is no problem at all in X, but.. when switching back to consle, it gets blurry. I've seen this problem on the linux forum and couldn't find a solution.

alexdupre 02-08-08 01:02 AM

Re: Several Issues with several drivers

Originally Posted by lguerb
With 169.07, also there is no problem at all in X, but.. when switching back to consle, it gets blurry. I've seen this problem on the linux forum and couldn't find a solution.

You are 'lucky', many of us don't have the console at all after starting X.

lguerb 02-08-08 09:03 AM

Re: Several Issues with several drivers
Well, mine is so blurry.. words actually move.. it's not usabe at all.

FatButtLarry 02-15-08 08:23 AM

Re: Several Issues with several drivers
3 Attachment(s)

I'm having strange issues too.

Ubuntu 7.10 + 169.09 driver. Compositioning is enabled.

I'm running metacity as a window manager, and with some gtk apps (mostly firefox), the window title bar will change to psychedelic colors and/or completely disappear.

The colors appear to be a negative of the actual colors (see "invert.png" attached below for reference), and usually the entire bar for that application (and only that application) will change.

This happens with identical driver version at home on Ubuntu 7.10 AMD64 with Emerald, and I don't remember it happening prior to upgrading 169.09.

For example, if Firefox is showing this psychedelic border, apps such as Pidgin or Terminal Server Client look fine.


Both stations that show this are running avant-window-navigator (not sure if its related), and my home station is very far from vanilla (kde + emerald + customized awn), however, the station at work is mostly stock ubuntu.

Regardless, it's not a major issue, just a bit bazaar! Thanks for amazing linux support, most else works great!!!


lguerb 02-17-08 02:39 PM

Re: Several Issues with several drivers
The problems relating to the corrupted tty's do not solve anywhere.

I tried drivers 169.07 and 169.09 with Slackware 12, and the console tty's are corrupted after starting X, even disabling the framebuffer devices from the kernel and recompiling. Leaving the framebuffer, driver 100.14.19 corrupts them also, but not so much. Disabling the framebuffer, 100.14.19 work fine.

And in FreeBSD, exactly the same thing (169.07 corrupting console, 100.14.19 not).

My laptop has a GeForce Go 6100, with 256 MB taken from the 1 GB RAM, Turion 64 MK-38, and I don't know if you need to know anything else.

It would be nice if nvidia developers try to catch this out, since it doesn't even seem related to OS issues.

If anyone tells me how to take a snapshot in a tty, I will gladly post it here.

All times are GMT -5. The time now is 05:20 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.