nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nForce2 on Mandrake 9.1 (http://www.nvnews.net/vbulletin/showthread.php?t=10789)

andnaess 04-25-03 03:38 PM

nForce2 on Mandrake 9.1
I tried to get my brand new nForce2 card (Abit NF7-M) up on running under Mandrake 9.1, to no avail. I first attempted a rpm install (using the current rpm from Nvidia). I simply copied the .o files that came with this RPM and tried to run insmode. The result was lots of missing symbol errors, so that didn't work.

I then tried to download the source version, as I ran make, but this failed with a huge error message, parts of which I've added to the end of this posting.

I tried to follow the advises in the error message displayed by the failed compile, but this was unsuccessful.

In the end I had to go back to 9.0 and use the supplied rpm (which works).

Has anyone been able to compile the nforce software under Mandrake 9.1? Does anyone know where I'm going wrong? I'm kind of desperate because I can't seem to find any RPM-files for 9.0, so among other things I can't install the kdenetwork package , which contains two of the programs I use hte most: gaim and knode. :(


[root@localhost nforce]# make
make -C nvnet
make[1]: Entering directory `/home/andre/nforce/nvnet'
cc -c -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.19-16mdk/build/include nvnet.c
In file included from /usr/include/linux/prefetch.h:13,
from /usr/include/linux/list.h:6,
from /usr/include/linux/module.h:11,
from nvnet.h:20,
from nvnet.c:21:
/usr/include/asm/processor.h:55: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/processor.h:55: requested alignment is not a constant
In file included from /usr/include/linux/module.h:20,
from nvnet.h:20,
from nvnet.c:21:
/usr/include/linux/modversions.h:1:2: #error "================================================= ======"
/usr/include/linux/modversions.h:2:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/modversions.h:3:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/modversions.h:4:2: #error ""
/usr/include/linux/modversions.h:5:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/modversions.h:6:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/modversions.h:7:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/modversions.h:8:2: #error "currently running kernel. They should only be"
/usr/include/linux/modversions.h:9:2: #error "included via other system header files - user space"
/usr/include/linux/modversions.h:10:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/modversions.h:11:2: #error "<asm/*.h> as well."
/usr/include/linux/modversions.h:12:2: #error ""
/usr/include/linux/modversions.h:13:2: #error "To build kernel modules please do the following:"
/usr/include/linux/modversions.h:14:2: #error ""
/usr/include/linux/modversions.h:15:2: #error " o Have the kernel sources installed"
/usr/include/linux/modversions.h:16:2: #error ""
/usr/include/linux/modversions.h:17:2: #error " o Make sure that the symbolic link"
/usr/include/linux/modversions.h:18:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/modversions.h:19:2: #error " the matching kernel source directory"
/usr/include/linux/modversions.h:20:2: #error ""
/usr/include/linux/modversions.h:21:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/modversions.h:22:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/modversions.h:23:2: #error ""
/usr/include/linux/modversions.h:24:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/modversions.h:25:2: #error " compiler option to use the correct include files:"
/usr/include/linux/modversions.h:26:2: #error ""
/usr/include/linux/modversions.h:27:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/modversions.h:28:2: #error ""
/usr/include/linux/modversions.h:29:2: #error " instead of"
/usr/include/linux/modversions.h:30:2: #error ""
/usr/include/linux/modversions.h:31:2: #error " -I/usr/include/linux"
/usr/include/linux/modversions.h:32:2: #error ""
/usr/include/linux/modversions.h:33:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/modversions.h:34:2: #error "================================================= ======"

ngandriau 04-25-03 10:32 PM

personnaly I just received my shuttle SN41G2 which is has an nforce2.

I have installed Mandrake 9.1 which install almost everything well but the driver card.

So I have check for the nvidia nforce drivers and I selectionned this version : NVIDIA_nforce-1.0-0256.src.rpm.

To compile it, I had to install the kernel sources which are on the CD of Mandrake.

then log as root and type
rpm --rebuild NVIDIA_nforce-1.0-0256.src.rpm

It will compile a binary RPM located at

a small rpm -i will finish the install.

My X server was then very unstable so I installed the video driver which come has a nice installer ready for mandrake 9.1


It works very well for 2D. But I still have to investigate for opengl which is not very stable on my new station. (I have another one based on an old k7s5a with geforce 4 ti 4200 and mandrake 9.1 everything is fine)

hope it help

andnaess 04-26-03 11:53 AM

I just wanted to let everyone know that I got it working. All I had to do was install the kernel-source RPM, having done so I simply did a make, make install, and then edited modules.conf as described in the README. Works like a charm :)

souljah 04-26-03 12:35 PM

and your NVIDIA ETHERNET works too ?
3com port works for me , but not the nvidia ethernet port....

can u say me how i can make it work please ?

(xcuse my english...)

andnaess 04-26-03 10:03 PM

Yeah I was mainly concerned with the Ethernet. This is the Abit NF7-M, and there is only one ethernet on it. What I did was fairly simple. I installed Mandrake 9.1, I then installled the linux kernel source. This was a file named kernel-source-2.4.21-0.13mdk.i586.rpm

After installing the kernel source files, I simply unpacked the tar file from NVidia, then did make, make install, and finally updated the modules.conf file as described in the installation instructions.

Good luck :)

davecs 04-29-03 07:16 PM


It seems that all one has to do with Mandrake 9.1 is install kernel-source-xxxx.rpm from Disc 3 and then the instructions with the nvidia drivers .tar.gz file release 0256 work ok.

They did for me!!!

How easy why was it so difficult finding out?


andnaess 04-30-03 05:41 AM

Well my problem was simply that I *did* select the Kernel sources for installation, what I didn't know was that they were on disk 3 which I didn't have, so I couldn't understand why it wasn't working, the Mandrake installer gave me no indication of what hadn't been installed. :P

All times are GMT -5. The time now is 10:14 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.