nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RedHat 9 with a Gforce 3 (http://www.nvnews.net/vbulletin/showthread.php?t=10804)

ixisi 04-25-03 07:09 PM

RedHat 9 with a Gforce 3
 
I am new to linux, I just installed RedHat Linux 9 last night and everything seems to be working well. I would like to update the drivers for the Gforce 3, but I do not know which linux drivers are the correct ones.

On the software download page there are options for Linux IA32, Linux AMD 64, Linux IA64, and FreeBSD. I cannot seem to find out which ones I need.

Also, I read of a linux nvidia installer, would I be able to get this and use this with RedHat 9? If so, where can I download it from?

Thank you for reading this and any help is greatly appreciated!

ixisi 04-25-03 07:41 PM

Additional Info
 
1 Attachment(s)
Video Card: GForce 3 Ti-200
Video Card Driver Version: it reads nv, not sure I am looking in the right place but it is the default driver for a GForce 3.
Distribution: I am not sure what this means
Video Bios Revision: When I go into /proc/driver the directory only contains a file named rtc, and no sub-directories
Processor: AMD 1.2 GHZ
Motherboard: EPOX EP-8K7A

I have attached a copy of my
/var/log/XFree86.0.log

I cannot seem to attach another file, so the /etc/X11/XF86Config file will be attached to the following reply.

ixisi 04-25-03 07:42 PM

1 Attachment(s)
Here is the other file

Andy Mecham 04-25-03 08:13 PM

You should use the IA32 driver. You can use the installer with Red Hat 9. If you're using the boxed, retail version of RH9 (ie: you bought it), you'll need to update your glibc package - you should be able to download a new package from any RH mirror, or use their update utility.

--andy

ixisi 04-25-03 08:33 PM

I have downloaded the NVIDIA-Linux-x86-1.0-4363.run file and when I ran it in /home/ix using sh NVIDIA-Linux-x86-1.0-4363.run, I was given the following error:

ERROR: nvidia-installer must be run as root

I tried to copy the file into my root directory / and into the /root directory but was given the error that read I do not have permissions to write to this folder.

What am I missing?

Andy Mecham 04-25-03 08:35 PM

You need to become root to run the installer. You should either use 'su', or log out and log back in as root.

--andy

ixisi 04-25-03 09:09 PM

I am able to become root, however I receive an error that reads:

You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at www.nvidia.com.

I began to read the readme file but I am stuck at how to correctly edit the inittab file to not load X. I did purchase the box set of RedHat Linux 9. However, the only documentation included are installation guides.

I think I need to learn more about this operating system and it's terminology before attempting to update my drivers.

Any suggestions on helpful Linux websites for tutorials, FAQ's, or general info would be great. I appreciate your help Andy.

bwkaz 04-25-03 09:41 PM

To correctly edit the inittab file, just open it up in any editor (you have to be root to be able to write to it).

Look for the line that reads id:5:initdefault:, and change it to read id:3:initdefault: instead (i.e. change the 5 to a 3).

Then, save and exit, and reboot. You'll be greeted by a text-mode login screen. Log in as root, and then run the installer like you have been doing. If it fails, then you should be able to startx to get a GUI working again; post your /var/log/nvidia-installer.log file if it does fail.

If it doesn't fail, then you'll still need to edit your /etc/X11/XF86Config file while still in text mode. I think pico or nano is probably going to be the easiest, if you have one of them installed. If not, just vi /etc/X11/XF86Config and hit the i key. Go down to where you need to make your edits, and change the stuff (in RH 9, it should be only the driver line that needs to change), then hit the escape key. Then, hit colon, and type wq. Then hit enter (the preceding :wq tells vi to save and exit; enter actually does that).

Then, startx to see if it works. If not, post /var/log/XFree86.0.log (make a copy of it, then edit your XF86Config file back, then launch X to post the copy).

deadlycheese 04-26-03 01:29 PM

Ooof. I think editing inittab is a little heavy-handed for something this simple and temporary. I think users should be advised to do the following:

1) log out of X
2) switch to a virtual console (Ctrl-Alt-F1)
3) log in as root
4) init 3
5) install drivers
6) init 5
7) log back into X as typical user

This is faster and safer than messing with inittab.


Just my two cents ...

ixisi 04-26-03 06:39 PM

1 Attachment(s)
I think I have it working now, my only concern is that under system settings->display it still says NVIDIA GeForce 3 (generic) and on the Advanced tab the Enable hardware 3D Acceleration option is still grey'd out. Is something not right?

bwkaz 04-26-03 08:05 PM

No, everything is fine. The "system settings->display" thing is based on nothing more than text strings in a card database; it does not reflect how the card is actually being driven anymore.

The hardware 3D checkbox is grayed out because, as far as RH is concerned, no nVidia card will ever have hardware acceleration (RH is forced to use the "nv" driver, which is 2D only, due to GPL restrictions on the Linux kernel). That, too, does not reflect how your card is currently configured.

ixisi 04-26-03 08:12 PM

ok excellent, one more thing and I do not know if this is related to the nvidia driver but when I boot up now the screen stays black for about 4 minutes before it throws up the login screen. Is this amount of time normal for linux? Besides the OS installation and browsing the web, all I have done is install the nvidia driver and I don't remember the long blank screen pause before.


All times are GMT -5. The time now is 04:06 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.