nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Gettys (virtual consoles) still inaccessible? (http://www.nvnews.net/vbulletin/showthread.php?t=10822)

linuxvvhore 04-26-03 10:47 AM

Gettys (virtual consoles) still inaccessible?
 
I've upgraded to the 4363 drivers, and I'm elated at the fact that I no longer need to use the KT400 workarounds. Kudos to Andy and the NVidia guys. :)

However, I still have problems switching to any of my virtual consoles or even just plain shutting down. The screen goes blank (but not off) and the computer becomes unresponsive. Any idea if this was supposed to be adressed in this driver release? If not, is there a workaround yet?

Thanks!
(Redhat 9 & GeForce4 Ti4200 8x)

linuxvvhore 04-26-03 11:49 PM

Is this a common problem? Anyone have any ideas?

bwkaz 04-27-03 07:29 AM

It's a sort-of common problem, but the only solution I know of (turn on vesafb), I think you've tried, and IIRC, it didn't work.

:(

Jon_e 04-28-03 07:23 PM

For some people this also happens with a TV connected.

I don't know if this also happens with other types of dual display setups.

dougster 04-28-03 08:53 PM

VesaFB fixes it on mine.
 
After rebuilding with VESAFB and then booting the kernel with the vga=9 parameter this totally resolved the problem for me. I don't know why this is, only that doing this re-enabled the virtual terminals where none others seemed to work; i.e. the "vga16 framebuffer" doesn't work, and the default "no framebuffer" doesn't work either. Not a fix, only a workaround, although the vesafb console drivers seem stable enough and there is no big reason not to use them with a nVidia card.

linuxvvhore 04-29-03 07:40 PM

So, if I understand correctly, I need to recompile my linux kernel with vesafb support enabled.

Any tips on how to do this without configuring the kernel from scratch? Is there a file I can simply modfy to say VESAFB=yes and then rpmbuild or something? I don't like having to use stock kernels when Redhat has patches they use in the official release.

linuxvvhore 04-29-03 08:18 PM

Erm, well., maybe vesafb support is compiled in by default on the RH kernels. However, I'm still having problems. "vga=9" doesn't work for me. I look in /usr/src/redhat/BUILD/kernel-2.4.20/linux-2.4.20/Documentation/fb/vesafb.txt and see this table of values:

| 640x480 800x600 1024x768 1280x1024
----+-------------------------------------
256 | 0x301 0x303 0x305 0x307
32k | 0x310 0x313 0x316 0x319
64k | 0x311 0x314 0x317 0x31A
16M | 0x312 0x315 0x318 0x31B


None of these look like "9" to me. I tried some of the 640x480 and 800x600 modes, but neither of them seemed to fix my gettys problem. What am I missing?


All times are GMT -5. The time now is 02:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.