nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nVidia GeForce4 Ti4200 AGP 8x on Debian 3.0 Woody (http://www.nvnews.net/vbulletin/showthread.php?t=10827)

3do 04-26-03 11:59 AM

nVidia GeForce4 Ti4200 AGP 8x on Debian 3.0 Woody
1 Attachment(s)
Hello you all,
and thanks for your help yet from now. I purchased a GeForce4 Ti 4200 and I have succesfully installed it on my Asus A7v 266 with AGP 4x. The X server of my Debian GNU/Linux 3.0 woody with kernel 2.4.18-bf2.4 distribution doesen't start up, but I have succesfully installed the module (I have tried to load it as described in the FAQ file and it works, I've seen it with "lsmod").
The problem is in the configuration of the XF86Config-4 file, but I can't understand where. The problem I saw in the log is: "(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!", but I can't really understand why, the module is OK, the monitor section is absolutely OK, the problem is the device. Can you help me?

Linux distribution: Debian 3.0 Woody
Kernel Version: 2.4.18-bf2.4
XFree86 version: (Come with Debian)
NVidia driver: 1.0-4349 (I have the 1.0-4363 version, but I'd like to solve the problem before upgrade)

Thanks a lot for your professionality and efforts for Linux community.
P.S: I have attached the log file and the configuration file for your examination.

An italian student

bwkaz 04-26-03 01:02 PM

There's probably a reason in the kernel logs that explains why your system can't initialize the kernel module. But 90% of the time, it's due to incorrect BIOS settings -- PnP OS should be off, and Assign IRQ to VGA should be on.

3do 04-27-03 10:29 AM

1 Attachment(s)
Thanks a lot for your suggestions, but I still haven't solved the problem. I disabled from the BIOS the PnP feature, but I haven't found the "assign IRQ to AGP" voice on my Award BIOS.
The problem is always the same, I post you also the kern.log file now (for the unchanged XF86Config-4 and XFree86.0.log file refer to the previous post).
My IRQ configuration, if useful, is
IRQ 3 : Serial 1
IRQ 4 : Serial 2
IRQ 5 : Parallel port
IRQ 7 : PCI slot 1&5 [PCI5: SBLive! 5.1 - PCI1: empty]
IRQ 9 : PCI slot 2 [empty]
IRQ 10 : PCI slot 3 [internal 56k modem Conexant]
IRQ 11 : PCI slot 4 [Realtek ethernet card]

If you have any tips on what to try or what to do to find or solve the problem, you're obviously welcome...
Thanks for your patience, I'm going crazy!

bwkaz 04-27-03 10:48 AM

Who made your motherboard? Try asking them how to make sure you assign an IRQ to the AGP slot.

That's almost assuredly the problem, now that I see your list of IRQs used. The AGP slot isn't there.

3do 04-27-03 03:13 PM

1 Attachment(s)
The AGP IRQ is 9, shared with the first (empty) PCI slot. But nothing change...
The module always fail to initialize.
Ok, you really think is the IRQ the problem?
I really don't know what to think about this problem. I have attached the output of the commands lspci -t (a pseudo tree of the PCI structure) and lspci -v (the verbose command, with some useful info about devices - video board is the last one) plus the other files (kern.log, XFree86.0.log, XF86Config-4).
Can you or someone help me?
Thanks a lot

bwkaz 04-27-03 04:12 PM

Well I'm only going on past experience, but 9 times out of 10, that is the problem.

Unfortunately, enough BIOS setup writers either see that value as "dangerous" (which is completely WRONG; it can't possibly break anything unless the default is on; in all the cases where it's a problem, the default is off), or they're just so locked into the MS way of doing stuff that they can't see any possible use for such a setting.

In either case, the BIOS writer needs a good LART. Unfortunately, there isn't much we (as users) can do about it, other than just stay away from all preassembled machines (very few Dell or Gateway (let alone Compaq and friends) machines that I have ever seen let you do much in the BIOS other than change the time and the boot order), and any motherboard manufacturer that is that closed-minded.

Anyway, I'll get off my soapbox now. ;)

3do 04-28-03 12:59 PM

Thnaks for the reply, but I haven't understood so much... what's a LART? What's a BIOS writer? Where does it writes? How can I solve my problem (consider that may not be the BIOS settings...)?
Thanks a lot another time

bwkaz 04-28-03 02:19 PM

Ah, I forget... English idioms (well... mostly).

The BIOS writer is the person (or organization) that put the code together that runs your BIOS. They're the people that decide, among other things, which settings to allow you to change, and which to completely hide.

A LART is a Luser Attitude Readjustment Tool, courtesy of the BOFH archives (current BOFH incarnations can be found linked from www.theregister.co.uk). Oftentimes, it takes the form of a two-by-four, about four feet long, but it could be a baseball bat as well. Or an electrical shocking device. Or something -- you get the idea, I think. ;)

I was just blowing off steam at the ten tons of organizations that are either completely clueless (the ones that think "assign IRQ to VGA" can cause problems), or are so pro-Microsoft that they actively break other operating systems.

That post wasn't intended to be a solution, unfortunately.

alien999999999 04-28-03 07:22 PM

appearantly you have a very new card(8x) in an older mobo(4x).
I'm not sure, but I though I saw more than one memory range from your card, so is the BIOS correctly set? also disable memory hole at 16M, assign IRQ for VGA, ... just check for VGA or mem related stuff in BIOS, you never know you missed a setting, apart from that, try setting AGP to 0 in the config file, is your system using a AGP module?

just trying to help

3do 05-04-03 01:26 PM

Ok guys, thanks a lot for your help, but nothing of that we could think about was: As I said in my first post, I can load the module, so I tried to start the X server with the module manually loaded, and as I supposed all worked! Now I only want to know why I must load the module manually before starting X, but I'm sure I'll find the answer in the FAQ, so I can finally launch "startx" with the dinamically loaded module running!
Thanks you all for your help (it has been useful however!)

bwkaz 05-04-03 03:16 PM

Oh... I thought you had tried it with the kernel module loaded, and it still didn't work.

OK, that's an entirely different problem then. :)

Debian uses one of either /etc/rc.modules, or /etc/modules, or some file similar to that. It's either a list of kernel modules to load (if it's that, then just add "nvidia" to that list somewhere), or it's a sequence of /sbin/modprobe <kernel module> command (if it's that, then add /sbin/modprobe nvidia somewhere).

That'll load it on every boot.

All times are GMT -5. The time now is 12:38 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.