nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   4363, still no X with AGP 4x card in KT400 mobo (http://www.nvnews.net/vbulletin/showthread.php?t=10904)

alien999999999 04-28-03 07:10 AM

4363, still no X with AGP 4x card in KT400 mobo
 
I've retried again with the new drivers, but it's exactly the same...

I did however find the problem that the installer has...

if I used the nvidia installer and uninstalled it again, my X will not work anymore...

I think i did an ldconfig after uninstalling, but i'm not sure...

the problem was the libGL.so.1 file, maybe it expected a newer version (that was installed with the nvidia drivers).

I was kind of hoping that this time it would work...

but still, this is a great effort in finalizing the nvidia driver, almost all problems are solved...

thanx for helping

alien999999999 04-28-03 03:54 PM

anyone know what to do?

Andy Mecham 04-28-03 04:56 PM

Are you using NVAGP?

--andy

alien999999999 04-28-03 07:51 PM

standard value, haven't touched the AGP settings in the XF86Config file...
except for changing nv to nvidia driver ofcourse

what I was wondering is this: maybe you're using the wrong AGP version on my card...

after all: the mobo can go 4x and 8x (and probably 2 as well); the video card can only go 4x: the bios sets 4x; but maybe the nvidia driver tries 8x(just a guess)???? and that's why it's not working?

Andy Mecham 04-28-03 07:53 PM

No, that's not the issue.

You should be using NVAGP. Make sure you have
Code:

Option  "NvAgp" "1"
in your XF86Config file, and that AGPGART is *not* compiled into your kernel.

You'll probably have to reboot if you change AGP drivers.

--andy

alien999999999 04-28-03 08:28 PM

why does it have to be NvAGP? before there never was a need to do that... anyway i'll try and do that. I'm not exactly sure as how to get rid of the AGPGART thing, IF I have it.

Andy Mecham 04-28-03 08:30 PM

The AGPGART shipped with most 2.4 kernels doesn't correctly support the KT400. NVAGP does.

--andy

alien999999999 04-30-03 08:00 AM

ok, tried it:

I don't have /dev/agpgart ; looked for agpgart in differen locations, didn't find it.

lsmod:

no agpgart

then tried setting Option "NvAGP" "1" and later "0"

nope, it does not have any effect.

when disabling AGP, the line before the last line in the log just disappears, but that's all.... (that line is: AGP is successfully initialized)
last line: setting 1024x768...

why does that not work?

alien999999999 05-01-03 01:12 PM

any help? anyone, andy?

Is this a bug in the latest drivers or is it something else...?

Andy Mecham 05-01-03 01:16 PM

I'm not sure what's causing this. Can you start X with the "nv" or "vesa" drivers?

--andy

alien999999999 05-01-03 01:29 PM

yes, after i uninstalled the nvidia drivers.

the log gives no errors, AGP disabling doesn't help

no AGPGART on system, at least I didn't find it.

nv works perfectly, but with nvidia it fails.

I have a KT400 mobo using mdk9.1.

it's the same error as in the previous drivers

will it help trying to get AGP info after installing drivers, installer log, startx -- -logverbose 5 2>~/logverb , or anything else?

thanks

Alien


btw: you're missing an ldconfig after uninstalling nvidia drivers

alien999999999 05-02-03 02:02 PM

any answer?


All times are GMT -5. The time now is 02:50 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.