nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Geforce4 Mandrake 9.0 Beta 3 (http://www.nvnews.net/vbulletin/showthread.php?t=1095)

soomon 08-24-02 11:05 AM

Geforce4 Mandrake 9.0 Beta 3
 
Hi,
I installed Mandrake 9.0 Beta 3.
But I can't configure the X-server.
I tried it with the official Readme but I get te following error(s):

hostname: Unknown host

execve failed for /etc/X11/X (errno2)
giving up.
xinit: no such file or dir (errno2): unable to connect to xserver
xinit: no such process (errno3) server error

I used NVIDIA_kernel-1.0-2960.mdk82up.i586
and NVIDIA_GLX-1.0-2960.i386

what does that mean???
help me please.

logan 08-24-02 03:35 PM

Check what your hostname is, and what's in /etc/hosts.

soomon 08-24-02 04:49 PM

Hi
I tried it again.
now i get another error message.
Te following lines are from the log file:

NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0) (--) NVIDIA(0): Linear framebuffer at 0xC0000000 (--)
NVIDIA(0): MMIO registers at 0xCE000000
(EE)
NVIDIA(0): Failed to initialize the NVdriver kernel module! (EE)
NVIDIA(0): *** Aborting *** (II)
UnloadModule: "nvidia" (II) UnloadModule: "vgahw" (II)
Unloading /usr/X11R6/lib/modules/libvgahw.a (EE) Screen(s) found, but none have a usable configuration.
Fatal server error: no screens found
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log". Please report problems to xfree86@xfree86.org.

Can you explain me what that means?
My host name is: Mandrake

logan 08-24-02 06:36 PM

Try to load up the module first before entering X, see if there's any errors.

insmod NVdriver

leonbrooks 08-24-02 11:16 PM

It probably needs a rebuild
 
9.0 uses kernel 2.4.19, NVidia's RPMs install a module for kernel 2.4.18. You may have to download the SRPM (.src.rpm) and rebuild that (rpm -bb specfile) to get something that works.

soomon 08-25-02 04:56 AM

insmod NVdriver returns: no module with this name found
and
rpm -bb NVIDIA_kernel-1.0-2960.src.rpm
returns: this file is no specfile
bad :-(
help me please!

rtz 08-25-02 05:31 AM

Mandrake 9.0 Beta 4:

http://www.linuxcompatible.org/article.php?sid=107

soomon 08-25-02 05:34 AM

Now I have a new fresh installation.
I didn't boot it and I didn't trie to startx the X-server during the installation.
shall I trie to install the nforce driver?
or the kernel and the glx-files?
but which kernel?
NVIDIA_kernel-1.0-2960.mdk82up.i586.rpm
or
NVIDIA_kernel-1.0-2960.src.rpm
and rpm -bb didn't work !?
what to do now?

rtz 08-25-02 06:48 AM

You have an nForce motherboard too? Install those drivers first.

Use this instead of RPM's:

http://download.nvidia.com/XFree86_4....0-0241.tar.gz

http://download.nvidia.com/XFree86_4...e-1.0-0241.txt

Just follow the directions:

http://download.nvidia.com/XFree86_4...960/README.txt

http://download.nvidia.com/XFree86_4....0-2960.tar.gz

http://download.nvidia.com/XFree86_4....0-2960.tar.gz

These are just as easy as the RPM's are.

soomon 08-25-02 08:04 AM

during the installation of the kernel
i got many error messages.
the i installed the glx driver and startx
returned the same error message I wrote above :-(

srlinuxx 08-25-02 11:38 AM

Dude, save yourself some grief and just use the tarballs. They can be used for (practically) any linux distro or any linux kernel. I suggest you read the readme and double check that you've edited your XF86Config-4 file correctly.
-s

soomon 08-25-02 02:55 PM

I edited everything correctly, but the first error appears during the installation.
The tar's produce many error's. The NVidia driver can't be installed I think.
I will trie the Beta 4 now.
But I think I have to wait :-(
If you have other ideas please tell me !!!
Thx


All times are GMT -5. The time now is 04:33 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.