nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   glxgears seems a bit slow with nforce2 IGP (http://www.nvnews.net/vbulletin/showthread.php?t=10979)

daclink 04-29-03 11:05 AM

glxgears seems a bit slow with nforce2 IGP
 
Hi... whenever i run glxgears i about 840 fps... i think i'm right in thinking this i low. I think i have hardware acceleration turned on (correct me if i'm wrong!), but i'm running out of ideas.

i'm running an nforce2 chipset with an integrated geforce 4 mx.
Xfree 4.3.0
Drivers: 4363
Athlon XP 2100
256MB RAM


Any suggestions would be appreciated

DaClink


XF86Config:

Section "Module"

Load "dbe" # Double buffer extension

SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

Load "type1"
Load "speedo"
# Load "freetype"
# Load "xtt"
Load "glx"
# Load "dri"

EndSection

Section "Files"

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
# FontPath "/usr/X11R6/lib/X11/fonts/TrueType/"
# FontPath "/usr/X11R6/lib/X11/fonts/freefont/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

# ModulePath "/usr/X11R6/lib/modules"

EndSection


Section "ServerFlags"

EndSection


Section "InputDevice"

Identifier "Keyboard1"
Driver "Keyboard"

Option "AutoRepeat" "500 30"

Option "XkbRules" "xfree86"
Option "XkbModel" "microsoftinet"
Option "XkbLayout" "gb"

EndSection



Section "InputDevice"


Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
Option "Resolution" "512"


EndSection



Section "Monitor"

Identifier "56i"
HorizSync 31.5 - 64.3
VertRefresh 50-90

EndSection


Section "Device"
Identifier "G4"
Driver "nvidia"
VideoRam 65536
# Insert Clocks lines here if appropriate

Option "NvAGP" "3"
Option "RenderAccel" "true"
EndSection



Section "Screen"
Identifier "Screen 1"
Device "G4"
Monitor "56i"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection



Section "ServerLayout"

Identifier "Simple Layout"

Screen "Screen 1"

InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection

# Section "DRI"
# Mode 0666
# EndSection

jobeus 04-29-03 01:05 PM

Yeah, I get 840ish with a PIII 1Ghz and a GeForce2Go...

Your XF86Config looks fine though... to me, at least. What's that omit DGA part about? I don't have that, anyways.

Cheshiremackat 04-29-03 08:46 PM

RAM RAM RAM RAM... :)
 
How much RAM do you have? Do you only have 1 stick of RAM?

1st... check your bios settings... you can increase the video ram there... that should speed things up a *little* but will take RAM away from system stuff.... best bet is...

MORE RAM... RAM is really cheap these days, and if your using the integrated graphics, then the RAM is shared so you need more than you might think. PLUS and this is *very* important... the nforce is a *dual* DDR setup, meaning that if you add another stick of ram into the second memory channel, you will double your memory bandwidth (thus a big payoff in FPS)... read your manual to see where the memory goes... usually the slots are colour coded so you get it in the right spot...

So... best bet is more RAM (same size as what you already have)... then increase the size of video RAM in BIOS... then check for FPS...

_CMK

jobeus 04-29-03 09:16 PM

I don't see how it could be RAM... I have 256 ram as well. That's definitely a bad score for his system.

Type 'glxinfo' and paste the output in here

Cheshiremackat 04-30-03 12:26 AM

1 or 2 dimms?
 
It really depends on your setup... if you have 2x128 then your system will run in "dual" mode using twice the bandwidth to the northbridge (graphics)... if he is using only 1 stick of ram, then his bandwidth is halved...

as a general rule on nforce boards is to use two sticks of ram, thus getting the better bandwidth...

_CMK

jobeus 04-30-03 12:37 AM

Okay, sure, but I don't see how that could make an Athlon 2100+ with Geforce4MX be the same speed as a PIII 1000 with a Geforce2go, that's all.

Cheshiremackat 04-30-03 12:44 AM

weeeeel
 
Quite honestly, the difference is 3.2mb/sec vs 6.4 mb/sec... Plus with only 256mb total, he is only using 64mb of video ram (XF86 config)... what does the bios say? The BIOS could be only allocating 32mb... Plus with more RAM the nforce 2 can allocate upto 128mb for vid ram...



Plus what speed ram is he using? PC 3200 or 2700? Or did his dealer install crappy PC 2100 or worse...

I think we need some more info... what Mobo are you using? How many sticks of RAM, etc?

_CMK

Cheshiremackat 04-30-03 12:45 AM

Also....
 
What are the RAM settings in the BIOS... have you made any alterations to the BIOS... maybe he has the RAM running out of spec/sync with the FSB...

Just my .02...

_CMK

daclink 04-30-03 05:36 AM

Cheers for replies so far guys... heres the info u asked for.

1. The 64Mb in the X config file is also allocated in the bios.
2. The Memory is only 1 stick... i'll borrow a stick to see what difference 2 makes.
3. The memory is pc2100 Crucial prtn no. CT3264Z265
See Webpage
it has a cas rating of 2.5 which is set in the bios.

Settings in bios are:
FSB Freq : 133
T(RAS): 6
T(RCD): 3
T(RP):3
CAS Latency: 2.5

4. The pc is a shuttle SN41G2 - which i think has a shuttle FN41 motherboard.

5. I have no idea what the dga thing is... it was put there by the X config tool. It seems to make no difference if it is there or not.

6. glxinfo produces this

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_SGIX_swap_group, GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_NV_float_buffer
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 MX Integrated GPU/AGP/SSE/3DNOW!
OpenGL version string: 1.4.0 NVIDIA 43.63
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_point_parameters,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_window_pos, GL_S3_s3tc, GL_EXT_abgr,
GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_minmax,
GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements,
GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
GL_EXT_paletted_texture, GL_EXT_point_parameters, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square,
GL_NV_fence, GL_NV_fog_distance, GL_NV_light_max_exponent,
GL_NV_packed_depth_stencil, GL_NV_pixel_data_range, GL_NV_point_sprite,
GL_NV_register_combiners, GL_NV_texgen_reflection,
GL_NV_texture_env_combine4, GL_NV_texture_rectangle,
GL_NV_vertex_array_range, GL_NV_vertex_array_range2, GL_NV_vertex_program,
GL_NV_vertex_program1_1, GL_NVX_ycrcb, GL_SGIS_generate_mipmap,
GL_SGIS_multitexture, GL_SGIS_texture_lod
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x21 24 tc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x22 24 dc 0 32 0 r y . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x24 24 tc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x25 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x27 24 tc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x29 24 tc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x2a 24 tc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2b 24 tc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2c 24 tc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x2d 24 tc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x2e 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x2f 24 dc 0 32 0 r . . 8 8 8 0 0 24 8 16 16 16 16 0 0 None
0x30 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 None
0x31 24 dc 0 32 0 r y . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x32 24 dc 0 32 0 r y . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x33 24 dc 0 32 0 r . . 8 8 8 0 0 16 0 16 16 16 16 0 0 None
0x34 24 dc 0 32 0 r . . 8 8 8 8 0 16 0 16 16 16 16 0 0 None
0x35 24 dc 0 32 0 r y . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x36 24 dc 0 32 0 r y . 8 8 8 8 0 0 0 16 16 16 16 0 0 None
0x37 24 dc 0 32 0 r . . 8 8 8 0 0 0 0 16 16 16 16 0 0 None
0x38 24 dc 0 32 0 r . . 8 8 8 8 0 0 0 16 16 16 16 0 0 None

daclink 04-30-03 05:40 AM

I also noticed that Side band addressing and Fast write are disabled in X. They are both enabled in the bios... would this make the difference, and if so how do i turn them on?

Cheshiremackat 04-30-03 02:11 PM

my $$$ is on 1 stick
 
Try out another stick of RAM, just remember that it needs to be the EXACT same as the one you already have...


_CMK

daclink 05-02-03 06:13 AM

I've stuck in a another matching 256MB stick... so the chips runs in dual mode. This makes an increase to about 1500 - 1600 fps in glxgears. Is this acceptable for this setup ? or is this still low?


All times are GMT -5. The time now is 07:54 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.