nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   KDE compile error (http://www.nvnews.net/vbulletin/showthread.php?t=10987)

firestorm 04-29-03 12:29 PM

KDE compile error
I just installed the 4363 drivers, and KDE no longer works (when X tries to start KDE, I get a "KDE init failed")

This happened to me on another system, and I had to reinstall KDE to get it working. When I tried compiling kdelibs on this one, I get this:

../dcop/dcopidl/dcopidl: relocation error: /usr/lib/tls/libGLcore.so.1: undefined symbol: __gl_tls_var0

I've tried going back to older drivers, but i can't get it to work at all. I'm guessing the error is in the graphics drivers, not the kde install, but I could be wrong. Any ideas?

Red Hat 9: 2.4.20-8
AMD Athlon 1500+

spartak 05-03-03 11:57 AM

I have the same problem! I start kde and almost anything does not run or start konsole, knoqueror etc.. i keep getting kio slave and kio file errors. Can someone please help us this is really horrible! I run gentoo with 2.4.20 gaming kernel, i have tried so much stuff to get this to work and nothing tried almost every kernel recompiled qt and kdebase with no opengl supporte etc.. nothing seems to take please help!

firestorm 05-03-03 11:37 PM

I might have a solution, although we've got 2 different problems. You seem to be able to get into KDE.. it the K-apps that fail. My KDE core wasn't loading... I couldn't even get to my desktop after I supplied a login and p/w. I managed to get around it.

Instead of using the source for the kde-libs and kde-base files and compiling, I grabbed the RPM's. Then I FORCED them in... Now it works fine :D

rpm -ivh kde-libs.whatever.rpm --force

give 'er a try

NoHair 05-04-03 11:31 AM

LibGL compile errors
Before you compile KDE, make sure you have your OpenGL environment set to Xfree and not the Nvidia OpenGL libraries. You will get an error and be unable to compile it.

Usually there is a script to run. For Suse it is switch2nvida, Gentoo is 'opengl-update xfree'.

Sorry, I don't use other distros, so I do not know what theirs is. But I hit upon the same issue with KDE when recompiling the KDEGraphics package.

Also follow the other gents suggestion to force a reinstall of KDE using the --force --nodeps options.

spartak 05-04-03 02:34 PM

Well that would be good but i compiled kde from scratch i use gentoo did not get any errors and i assume that when i compiled my kde which was right after i emerged xfree the Gl libs were automatically set to xfree's since i didnt install nvidia stuff yet or am i to assume wrong? my problem is not compiling it its the kde apps that cant launch getting all sourts of errors same thing happens in gnome but not fluxbox which is what im using now.

-- Thanks for ur help!

NoHair 05-06-03 08:57 PM


Originally posted by spartak
Well that would be good but i compiled kde from scratch i use gentoo
Interesting. I have gentoo as well. I cannot get X working at all with the .20 kernel series they have although it worked fine with the .19 set. Works ok on my Suse 8.2 .20 kernel though. Identical config file even.

Anyway, make sure you run "opengl-update xfree" before compiling it just to be on the safe side. I could get get the kdegraphics package to even finish compiling until I did this although the maintainer swears it should not matter.

That is what it took for me to compile it. Also take a look at your use statements to make sure you have opengl defined in it. That is the only other thing I can think that may have an effect on it at the moment.

spartak 05-06-03 10:50 PM

Thanks for the reply as of know that is how its been compiled. The problem is that as soon as i enable the nvdia driver my kde / gnome cannot launch programs they just time out in kde i get io-slave errors etc.. but in fluxbox everything works fine i can even launch the kde stuff fine as well as the gnome stuff. Man its wierd i dont think its x since fluxboxworks to my knowledge. I am really at a loss here. Anyone please help!

spartak 05-10-03 12:12 PM

Hi, i fixed it i think it was a specific problem with my card and the nvidia drivers since i got a new video card and everything works fine now. I had an ELSA Gladiac ULTRA which is a Gf2Ultra. Now i got the Golden sample ti4600 from gainward and i love it!

All times are GMT -5. The time now is 04:27 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.