nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Unstable and garbaged screen (http://www.nvnews.net/vbulletin/showthread.php?t=11029)

easeofuse 04-30-03 07:06 AM

Unstable and garbaged screen
 
I have this really stupid problem with my Nvidia (GF2Ti) card. As you know, you can select between the regular generic "nv" driver that comes
with X, and the 3D accellerated nvidia-driver from nVIDIA. My problem is when using nvidias own driver. It is highly unstable, more unstable
than I've ever heard anyone telling before. It's not just it's unstable, also nicely spread around graphical intensive things on the screen,
there appear some "error-fuzz". Interference of some kind. My screen looks horrible sometimes, especially when using the Option "backingstore"
in XF86Config (which some kind of 2D accelleration i presume). I can use my PC with that driver, but it's annoying when garbage appear all the time.

Typically those interferences appear imidiately after running an OpenGL application (like Quake III, XMMS vizualisation e.g.). Ironicly those OpenGL
applications windows run perfectly (if not, the nvidia binary driver would be total useless for me). When moving the standard OpenGL
XMMS visualization (colorized bars) around on the screen while it's running, it leaves trails behind on the root-window. When browsing the web, loading
pictures is terrible. Some symmetric lines mess up the pictues while its loading(, but when it finishes it repaints fine). You can imagine what
scrolling pictures look like. When I'm surfing pages with much or complicated graphics X often freezes and theres nothing I can do
locally. Print screen (command: import screenshot.png) saves a file with symmetrical errors on the whole picture. I've seen similar problems before.
One time i solved it by setting the AGP (transfer rate?) from 4X to 1X in the BIOS. That does not work for me. If my problem would appear in Windows,
I would decrease the hardware accelleration (Desktop --> Properties etc.) I don't know why Windows has so many steps, not just "no 3D accell" and
"yes, 3D accell". For me its anyway Driver "nv" or Driver "nvidia", as i know.

I think this is a really strange problem. Since X starts fine it thinks for itself that everything is okay. I think there's no way for X to realize my problem (discover those error-dots? i think not), so there's nothing strange in the logs. I don't have Windows installed, but when I had some time ago, i think the problem was present there too (Win98). But i don't think Windows XP has it. I really should try to install it and have a look.
Maybe this is some bad combination of chipset or so?

I convinced that i'm the only person on the planet having this problem, so if you can proove me wrong, i would appreciate it. I thankful for whatever help i can get.
One more thing I should try:I have a friend with NVIDIA GF4MX??, maybe i should ask him if we could switch graphics card sometime...
I've testet the nvidia-driver in RedHat Linux 9 too, and it's exactly the same problem.

I run Debian GNU/Linux stable
XFree86 ver. 4.2.1
Downloaded the newset nvidia-drivers today (noticed that the kernel module has a new name: nvidia, not NVdriver)
Motherboard: Aopen AK77.
Graphics card: MSI NVIDIA GeForce 2Ti (or 2GTS)

Andy Mecham 04-30-03 01:06 PM

Can you post an X log for me?

--andy

easeofuse 04-30-03 02:16 PM

X log
 
1 Attachment(s)
Here's the X log. I haven't really gone through it very detailed, but i don't know exacly what to look for either.

I've taken a screenshot with the import command so you can see what it looks like. Even the import command makes more errors than was not originally on the screen, so it's not as bad as it looks like. But it can be. But anyway that command clearly says that something is not right.

http://kaja02.fastcom.no/~stig/garba...shot_thumb.png

I tried to put the log as an attachtment, but if you can't find it, here's a link:
kaja02.fastcom.no/~stig/XFree86.0.log

brennanmh 04-30-03 05:44 PM

I have the same problem
 
I'm seeing the same problem with my GeForce 3. I think that
it might be AMD related, although I'm not certain.

I happen to dual boot this system, Mandrake 9.1 and Windows
XP and the problem occurs in both, so it is not linux specific.

I have found that I can only use the 3123 Linux drivers.
Otherwise either X takes forever to start or the colors are
garbled. Unfortunately, it was a real pain in the ass to back
out NVidia's latest drivers because I couldn't find an uninstall
option with their fancy new installer. I did manage to get
it working again, but GLX doesn't work anymore because the
installer messed up some libraries. I'm sure there is any
easy fix, though.

My Config is thus:
Athlon XP 1700+
GeForce3 Ti200
18.1" digital flat panel

Also, you need to make sure you have a pretty recent linux
kernel as there are AMD/AGP issues in older ones. Redhat 9
and Mandrake 9.1 contain these fixes and there are RPM updates
for older versions of both. There are probably updates for all
the other flavors as well.

In closing, I would try and back out the latest drivers and go
with 3123. These are the last drivers from NVidia that have
worked for me.

-Brennan

Andy Mecham 04-30-03 06:03 PM

Quote:

Unfortunately, it was a real pain in the ass to back
out NVidia's latest drivers because I couldn't find an uninstall
option with their fancy new installer.
Use the --uninstall option.

--andy

brennanmh 04-30-03 06:08 PM

sweet, thx.

-Brennan


All times are GMT -5. The time now is 07:39 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.