nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   garbage with 4363 in some resolutions (http://www.nvnews.net/vbulletin/showthread.php?t=11085)

beetle-driver 05-01-03 04:43 AM

garbage with 4363 in some resolutions
 
1 Attachment(s)
Hello,

when I start X, the NVIDIA-splash-screen is displayed correctly but when it disappears, the screen gets unreadable. The lines seem to have a wrong length. It's impossible to recognize anything but the mouse-pointer, which is displayed correctly.
The problem only exists in conjunction with some resolutions (e.g. 1400x1050, 1600x1200). It seems to be a problem with the virtual screen size: Setting it to 2048x1536 I can switch to 1400x1050 or 1600x1200 using CTRL-ALT-+ without problems. But I don't like a virtual screen that is bigger than the visible screen.

Disabling AGP or "RenderAccel" or using the "UseEdidFreqs" - Option, as mentioned in another thread, had no effect.

I had the same problem with the previous release (4349 I think), whereas 4191 goes well.

My configuration:
Geforce 3
Athlon-Thunderbird 1000 (133x7.5)
Enmic 8TTX+

beetle-driver 05-01-03 04:45 AM

1 Attachment(s)
Me again. As it is impossible to attach more than one file per message, here is my XF86Config.

Andy Mecham 05-01-03 11:33 AM

Were you using XFree86 4.3 with 1.0-4191? It's certainly possible that you're not getting the right modelines from X. Have you tried using 'gtf' to make some modelines for the incorrect resolutions?

--andy

beetle-driver 05-01-03 02:13 PM

Yes, I was using XFree86-4.3 with 4191. All I did was changing from 4191 to 43xx.

Erm ... what is 'gtf' ?

Andy Mecham 05-01-03 02:24 PM

gtf is a modeline generation tool distributed with XFree86 4.3*.

--andy

beetle-driver 05-01-03 02:55 PM

OK, I generated a modeline for 1400x1050@85Hz with 'gtf' and replaced the existing "1400x1050"-modeline in my XF86Config with the new one.

Unfortunately this didn't solve the problem.

Nevertheless, thanks for your help.

I don't know whether it is important: I'm running an LFS-System (www.linuxfromscratch.org) with Kernel 2.4.20

beetle-driver 05-04-03 03:14 PM

Hello,

this weekend I tried some other modelines (several 1400x1050 and 1600x1200 modes) created with gtf. None of them worked. It's always the same problem: When the NVIDIA-splash-screen (which is displayed correctly!!!) disappears, the screen gets unreadable, because the displayed lines seem to have a wrong length. Amazingly setting the virtual size to 2048x1536 all modes go well.

This is quite frustrating, especially as 1400x1050@85 works with v4191 using exactly the same settings in my XF86Config.
Am I really the only one with this problem?
At least will it be fixed in a future release?

fisken 05-05-03 10:27 AM

I have the exact same symptoms on my system. The highest I can go without the screen being garbled after the splash screen is 1280x1024. I haven't tried the virtual screen stuff - sounds like an acceptable interim solution - but I'd like to get it to work without dirty tricks...

I run this:

PIII 800 MHz
GeForce2 GTS 32 Mb
ASUS CUSL2-C mobo
384 Mb SDRAM
LFS, kernel 2.4.20 xfree86 4.3.0
nvidia module 4363

The 'nv' driver from xfree works fine at 1600x1200.

I also have a gentoo system on the same box with the latest nvidia drivers (should be 4363) and it works at 1600x1200. I've tried using the XF86Config from that setup, but it doesn't work.

Not very helpful, I'm afraid, but at least you know you're not alone. ;)

beetle-driver 05-05-03 11:42 AM

First of all, thanks for your reply.

Quote:

Not very helpful, I'm afraid, but at least you know you're not alone.
This is reassuring. :afro:



As the driver works for your gentoo-system, it's a problem with LFS perhaps?
What kernel do you use with gentoo?

fisken 05-05-03 04:31 PM

Oops! Turns out I don't have the latest drivers on my gentoo system - they haven't updated the ebuild yet (for my profile anyway). So I'm using 1.0.4349 there.

I use gaming-sources 2.4.20-r3, but I've used gentoo-sources and ck-sources before with no problems (not sure which nvidia driver versions though - I run emerge -u world just about every time I boot gentoo :) ).

I'll try 4349 on LFS to see if that fixes things.

fisken 05-06-03 04:40 AM

Ok, I tried both 4349 and 4191 on my LFS system and I get the same results as you: 4191 works above 1280x1024, 4349 doesn't.

4349 does work on my gentoo system with the 2.4.20-gaming-r2 kernel. Wish I knew how the gentoo people do it...

beetle-driver 05-06-03 02:28 PM

OK, I tried kernel 2.4.21-rc1 --- without success.

Also I tried starting with vga=normal instead of vga=0x31A with the same result as above.

Hopefully NVIDIA will fix it in the next release.


All times are GMT -5. The time now is 11:33 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.