nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X server takes forver to start (http://www.nvnews.net/vbulletin/showthread.php?t=11087)

curien 05-01-03 06:37 AM

X server takes forver to start
 
OK, this problem seems awfully strange, at least to me. But then, I'm fairly new to Linux, so who knows? Anyway, here's the deal. First, I'm using Debian Sarge (XF86 4.2), but I was having the same problem with Debian Woody (stable) on a Athlon XP 1800 with a Soyo Dragon Plus (KT266A) and a PNY GeForce3 Ti 200. If I use the nv driver that ships with XFree86, everything works fine. If I use the nvidia driver, everything works fine... eventually. The problem is that it takes four minutes (not kidding, I timed it... I get up and go watch TV while I wait) for the X server to start or "redisplay" (I don't know the correct term... like if you do Ctrl+Alt+F1 to get a virtual console then Alt+F7 to go back to X). Once X starts, my DE or DM (depending on how I started X) starts fine and everything works great from there. I think I might even be getting a few more FPS in Q3A than I did with Win2K. ;-} The first driver version I tried was 4191, but the problem occurs with 4363 as well (used the automatic installer). I've tried it with kernels 2.4.18 and 2.4.20... same problem.

One thing to note. When I first tried the installer for 4363, it was immediately after compiling my 2.4.20 kernel. It gave me an error about the kernel headers not matching the running kernel (this was after I rebooted into 2.4.20). I had made the kernel with Debian's make-kpkg utility:
# make-kpkg kernel_image && dpkg -i ../kernel_image*
After rereading the manpage, I noted that this doesn't install the headers, so I did
# make-kpkg kernel_headers && dpkg -i ../kernel_headers*
And then the installer worked. The 2.4.18 kernel, though, I compiled and installed by hand (used make bzImage, make modules, etc instead of make-kpkg).

I suppose the first questions people will ask are what my config and log files are, so I'll make them available online: XF86Config-4 and XFree86.0.log.

I don't really know what to try, other than reinstalling my system. But I don't want to do that, and I wouldn't really learn anything that way. :-} So does anyone have any ideas or any suggestions that might enable me to at least determine what's going wrong?

Oh, one other thing. For some reason, the module can't figure out that it's supposed to load itself. Before starting X, I have to
# insmod nvidia
to load the driver.

bwkaz 05-01-03 09:07 AM

Well, I don't know how much of this is related, but the config file that you've linked to isn't the one that generated the log that you linked to.

Your config file has the Driver "nv" line, and the Load "dri" line; both of these should be gotten rid of (and Driver should be changed to "nvidia"). However, in your log, it seems that you are using Driver "nvidia" -- at least, the log shows nvidia_drv.o loading.

However, the log also shows "(EE) NVIDIA(0): Failed to load GLX". When you edited your config file the first time, did you add a Load "glx" line in the Modules section?

curien 05-01-03 09:30 AM

Oops
 
I was switching back and forth between the nv and nvidia driver... I could have sworn I changed it back before copying it to the web server (updated it since your post). I had the Load "glx" line in before, and I also tried commenting out the Load "dri" line (I think the log is actually from when dri was commented out). Neither seemed to help, or have any discernable effect other than changing the messages in the log, though.

Thank you for taking a look.

bwkaz 05-01-03 12:28 PM

From the looks of the log, the only modules you had loading at the time were "ddc", "extmod", "freetype", "int10", "record", "speedo", "type1", and "vbe".

What I'd try is getting rid of the ones you aren't actually using. "ddc" is, I think, loaded automatically from something else, so don't bother with it. You don't need int10, and you don't need vbe. You also likely don't need record, but I'm not sure on that.

It may also help to use the IgnoreDisplayDevices option in your Device section. The README mentions this; don't know if you've tried it or not.

Oh, and your other question, about autoloading the kernel module -- add another line to /etc/modules (I think that's the file anyway) that just reads nvidia.

Andy Mecham 05-01-03 12:39 PM

Yeah, you're probably going to have to use the IgnoreDisplayDevices option for your TV out. The README has details on how to use it. Alternatively, you can see if your card vendor has a better vbios available for you on their website.

--andy


All times are GMT -5. The time now is 08:51 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.