nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   black screen, machine NOT frozen (http://www.nvnews.net/vbulletin/showthread.php?t=11111)

tuosiq 05-01-03 03:51 PM

black screen, machine NOT frozen
 
1 Attachment(s)
Hi

I installed nvidia linux driver 1.0-1512 on debian woody 3.0r1. Linux 2.4.18 - XFree86 version 4.1.0.1. modprobe NVdriver loads it just fine. startx yields no errors, but leaves the monitor at a black screen. The machine is still responsive, ctrl+alt+backspace brings it down.

This card worked fine when I installed gentoo 1.4. I do not remember the XFree86/Nvidia versions. I only say this to show that this hardware configuration has worked before.

athlon 1800xp
via kt266a
nvidia geforce2 440mx

Any help would be greatly appreciated.

XFree86.0.log attached

XF86Config-4 follows:


Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
# Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "pex5"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "xie"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mouse0"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
# BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-70
VertRefresh 50-100
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Andy Mecham 05-01-03 04:59 PM

Have you tried a more recent version? 1.0-1541 is over a year and a half old. Can you try 1.0-4363?

--andy

tuosiq 05-01-03 08:06 PM

I just installed 1.0.4363 (show below). Nothing changes. Still the black screen.

(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4363

Andy Mecham 05-01-03 08:10 PM

It's not clear if it would affect you, but you should definitely enable MTRRs in your kernel to avoid
Quote:

(WW) System lacks support for changing MTRRs
Does disabling AGP work? Are those the correct hsync and vrefresh values for your machine?

--andy

tuosiq 05-01-03 08:20 PM

When you say disable AGP, do you mean this as a kernel change as well?

Andy Mecham 05-01-03 08:22 PM

No - sorry I wasn't clear. You should try adding
Code:

Option  "NvAgp" "0"
to the Device section of your XF86Config file.

--andy

Soul-Crusher 05-01-03 10:30 PM

I'm actually having the same problem after upgrading from XFree 4.2 to XFree 4.3 and using the latest nVidia drivers. I think it has more to do with XFree86 4.3 than with nVidia. Try emerging XFree 4.2 and see if you still have the problem.

I'll keep you guys posted if I can figure out what's wrong with 4.3.

Soul-Crusher 05-01-03 11:30 PM

Strangely, X 4.3 seems to work fine when I'm load a desktop manager. However, it appears only with a blank screen whatn I'm trying to run "X" without a deskop manager. Very strange...

But again, I think it's an XFree86 problem, not an nVidia problem.

Andy Mecham 05-01-03 11:35 PM

You're not seeing a mouse cursor, are you? Some distros have gotten in the habit of changing the X root weave to a solid color, like black.

--andy

Soul-Crusher 05-01-03 11:51 PM

Yep, I see the cursor. Going off what you said, I ran X :1 & and then in another virtual console I did this (Using bash shell):
export DISPLAY=:1.0
xterm

and xterm came up.

So you think it's a distro thing and not an XFree86 4.3.x thing?

Andy Mecham 05-01-03 11:59 PM

Running X doesn't start a window manager. The black screen you're seeing is actually the X root weave - things are working normally. You could start a window manager remotely with 'gnome-session' or 'startkde' or (my personal favorite) 'openbox'.

--andy


All times are GMT -5. The time now is 07:36 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.