nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Errors Installing BFG 6200 OC on a Fedora 8 i686 32bit machine. Please Help! (http://www.nvnews.net/vbulletin/showthread.php?t=111188)

witakr 04-06-08 01:01 AM

Errors Installing BFG 6200 OC on a Fedora 8 i686 32bit machine. Please Help!
 
4 Attachment(s)
Hello, I'm running Fedora 8 (2.6.23-1.42.fc8 i686) on a 32bit system

I am trying to install and use my BFG GeForce 6200 OC video card.

A. When I install the card WITHOUT modifying the etc/X11/xorg.conf file I get the Kernel Panic error in the first two screenshots(there are 2 edited screenshots of the same screen, I was forced to do that because the original pic was bigger than 100kb, KernelPanic-A.jpg and KernelPanic-B.jpg are from the same screenshot)

B. When I install the video card after editing the file, /etc/X11/xorg.conf:
After changing the Driver setting to 'nv' then reboot with card installed. I get an error screen that contains only [<c####>] messages just like in KernelPanic-A.jpg, however I am unable to get a picture that is helpful because the screen will continuously scroll those trace messages much faster than is possible to read them. and when you look at them they are all one big blur.

Code:

Section "Device"
    Identifier    "Videocard0"
    Driver        "nv"
EndSection

C. When I reboot after removing the video card I get an error that says it couldn't load X. then it gives the messages found in the 2 log files i have attached.

D. When i reboot after editing /etc/X11/xorg.conf and change the Driver setting to 'nouveau' I get the error screen shown bellow in in the screenshots named C-Trace-A.jpg and C-Trace-B.jpg, again edited for file size.

Code:

Section "Device"
    Identifier    "Videocard0"
    Driver        "nouveau"
EndSection

E. When I reboot after removing the video card I get an error that says it couldn't load X. then it gives the messages found in the 2 log files i have attached.

If you need more detail please ask, I will be checking this thread several times a day for replies.,

Thank you for your help.


Here is a URL to the Log files, I couldn't upload them both, also due to restriction imposed on this forum:
http://www.witakr.com/xorglogs

witakr 04-06-08 03:01 AM

Re: Errors Installing BFG 6200 OC on a Fedora 8 i686 32bit machine. Please Help!
 
I would like to add that I have had problems installing some packets and drivers that i believe relate to this problem.

I have screenshots of some of the errors if you would like to see them.

NvFuchs 04-06-08 07:06 AM

Re: Errors Installing BFG 6200 OC on a Fedora 8 i686 32bit machine. Please Help!
 
1) read http://www.nvnews.net/vbulletin/showthread.php?t=72490
2) try the "nvidia" driver. Nouveau is _not_ supported here,
"nv" maybe, but it's probably not what you want.
3) tell us which nvidia driver (nvidia, not nouveau nor nv)
you installed, how you installed it (READ the sticky)
and create a nvidia-bug-report file as mentioned in the
other sticky thread ( http://www.nvnews.net/vbulletin/showthread.php?t=46678 )

Fuchs

witakr 04-06-08 12:33 PM

Re: Errors Installing BFG 6200 OC on a Fedora 8 i686 32bit machine. Please Help!
 
I will give that a shot a little later and I will reply with my results.


Thank you

witakr 04-06-08 06:09 PM

Re: Errors Installing BFG 6200 OC on a Fedora 8 i686 32bit machine. Please Help!
 
OK, I tried that and got these outputs:
all ran under root with su - then password

runnng: # yum install kernel-devel xorg-x11-server-sdk pkgconfig
Code:

[root@localhost ~]# yum install kernel-devel xorg-x11-server-sdk pkgconfig
Loading "priorities" plugin
Setting up Install Process
Parsing package install arguments
Package kernel-devel - 2.6.24.4-64.fc8.i686 is already installed.
Package kernel-devel - 2.6.23.1-42.fc8.i686 is already installed.
Package pkgconfig - 1:0.22-4.fc8.i386 is already installed.
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-server-sdk.i386 0:1.3.0.0-44.fc8 set to be updated
---> Package kernel-devel.i586 0:2.6.23.1-42.fc8 set to be installed
--> Finished Dependency Resolution
--> Running transaction check
---> Package xorg-x11-server-sdk.i386 0:1.3.0.0-44.fc8 set to be updated
---> Package kernel-devel.i586 0:2.6.23.1-42.fc8 set to be installed
---> Package kernel-devel.i686 0:2.6.24.4-64.fc8 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                Arch      Version          Repository        Size
=============================================================================
Installing:
 kernel-devel            i586      2.6.23.1-42.fc8  fedora            4.8 M
 xorg-x11-server-sdk    i386      1.3.0.0-44.fc8  updates          373 k
Removing:
 kernel-devel            i686      2.6.24.4-64.fc8  installed          32 M

Transaction Summary
=============================================================================
Install      2 Package(s)       
Update      0 Package(s)       
Remove      1 Package(s)       

Total download size: 5.2 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  package kernel-devel-2.6.24.4-64.fc8.i686 (which is newer than kernel-devel-2.6.23.1-42.fc8.i586) is already installed
  package kernel-devel-2.6.23.1-42.fc8.i586 is already installed

Error Summary
-------------



running: # yum update
Code:

[root@localhost ~]# yum update
Loading "priorities" plugin
livna                    100% |=========================| 2.1 kB    00:00   
rpmforge                  100% |=========================| 1.1 kB    00:00   
adobe-linux-i386          100% |=========================|  951 B    00:00   
updates                  100% |=========================| 2.3 kB    00:00   
freshrpms                100% |=========================| 2.1 kB    00:00   
dribble                  100% |=========================|  951 B    00:00   
fedora                    100% |=========================| 2.1 kB    00:00   
Setting up Update Process
No Packages marked for Update



I wish to use SELinux so here is the output for that:
running:
Code:

[root@localhost ~]# chcon -t texrel_shlib_t /usr/lib/xorg/modules/drivers/nvidia_drv.so
chcon: /usr/lib/xorg/modules/drivers/nvidia_drv.so: No such file or directory
[root@localhost ~]# chcon -t texrel_shlib_t /usr/lib/xorg/modules/extensions/libglx.so.1.0.9631
chcon: /usr/lib/xorg/modules/extensions/libglx.so.1.0.9631: No such file or directory
[root@localhost ~]# chcon -t texrel_shlib_t /usr/lib/tls/libnvidia-tls.so.1
chcon: /usr/lib/tls/libnvidia-tls.so.1: No such file or directory
[root@localhost ~]# chcon -t texrel_shlib_t /usr/lib/libGLcore.so.1.0.9631
chcon: /usr/lib/libGLcore.so.1.0.9631: No such file or directory

Any ideas?

witakr 04-06-08 06:17 PM

Re: Errors Installing BFG 6200 OC on a Fedora 8 i686 32bit machine. Please Help!
 
Quote:

Originally Posted by NvFuchs
3) tell us which nvidia driver (nvidia, not nouveau nor nv)
you installed, how you installed it (READ the sticky)
and create a nvidia-bug-report file as mentioned in the
other sticky thread ( http://www.nvnews.net/vbulletin/showthread.php?t=46678 )

Fuchs

Problem is I don't think i have an 'nvidia' driver installed because I did try changing my driver to 'nvidia' in the /etc/X11/xorg.conf file and it gave me the same Kernel Panic error i get when i don't edit the xorg.conf file.

and the 2nd link you gave is hard for me to understand, im not 100% with the file system yet, I'm new to Linux and I am used to win32 based file systems. I am getting the hang of it but I am not clear on what zander was talking about in that sticky thread.

witakr 04-08-08 07:37 PM

Re: Errors Installing BFG 6200 OC on a Fedora 8 i686 32bit machine. Please Help!
 
New Error Info:

I went to BFG tech's website for support and they linked me to nvidia's website support page for drivers for x86 linux.

They instructed to download
Code:

NVIDIA-Linux-x86-169.12.pkg1.run
then to
Code:

sh NVIDIA-Linux-x86-169.12-pkg1.run
( my path was different so i added the correct path)

After following their instructions i got this output:

Code:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue Apr  8 18:30:37 2008

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall              : false
  driver info            : false
  precompiled interfaces  : true
  no ncurses color        : false
  query latest version    : false
  OpenGL header files    : true
  no questions            : false
  silent                  : false
  no recursion            : false
  no backup              : false
  kernel module only      : false
  sanity                  : false
  add this kernel        : false
  no runlevel check      : false
  no network              : false
  no ABI note            : false
  no RPMs                : false
  no kernel module        : false
  force SELinux          : default
  no X server check      : false
  force tls              : (not specified)
  X install prefix        : (not specified)
  X library install path  : (not specified)
  X module install path  : (not specified)
  OpenGL install prefix  : (not specified)
  OpenGL install libdir  : (not specified)
  utility install prefix  : (not specified)
  utility install libdir  : (not specified)
  doc install prefix      : (not specified)
  kernel name            : (not specified)
  kernel include path    : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path    : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list          : (not specified)

Using: nvidia-installer ncurses user interface
-> Tagging shared libraries with chcon -t textrel_shlib_t.
WARNING: You do not appear to have an NVIDIA GPU supported by the 169.12 NVIDIA
        Linux graphics driver installed in this system.  For further details,
        please see the appendix SUPPORTED NVIDIA GRAPHICS CHIPS in the README
        available on the Linux driver download page at www.nvidia.com.
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID
  '14432' of a runnning X server.
ERROR: You appear to be running an X server; please exit X before installing.
      For further details, please see the section INSTALLING THE NVIDIA DRIVER
      in the README available on the Linux driver download page at
      www.nvidia.com.
ERROR: Installation has failed.  Please see the file
      '/var/log/nvidia-installer.log' for details.  You may find suggestions
      on fixing installation problems in the README available on the Linux
      driver download page at www.nvidia.com.

My questions:

1. How do i update My NVIDIA GPU so that i may install my driver?
2. How do I exit X server?


A link to the nvidia page where I got this information: http://www.nvidia.com/object/linux_d...32_169.12.html


All times are GMT -5. The time now is 12:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.