nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Kernal watzit problems (http://www.nvnews.net/vbulletin/showthread.php?t=11137)

Matto 05-02-03 03:08 AM

Kernal watzit problems
 
I've been trying to install the 4363 driver on box MDK 9.0 box and while the installer is quite happy when I try to launch X it fails and drops back into the shell. When I look at my Free86 log an error message occurs at the end, funnily enough, about not being able to load the kernal watzit. I'll post my X11config-4 and XFree11.0.log in a few minutes, I still have to surf the net via windows till I get my Lucent winmodem running through linux. I'm also having sound card issues and my coffees gone cold.

My system is :
P4 2.4gig
GF MX440SE
Mandrake 9.0
Kernal 2.4
Gigabyte GA-ST800

Cheers Matto
:confused:

Matto 05-02-03 03:51 AM

OK the problem seems to have changed a little
 
1 Attachment(s)
So, I've booted back into linux and reinstalled the 4363 driver and checked the approapriate bits have appeared in X11Config-4, which they have. When I've tried to load X11 my screen has shown garbled ascii symbols and my system has locked. My log file doesn't show any problems anymore so I suppose there may be a hardware conflict. Just to be sure you know my system is:

Mandrake 9.0
Kernal 2.4
GF MX440SE
P4 2.4gig
Gigabyte GA-ST800

Andy Mecham 05-02-03 06:03 PM

Does disabling AGP help? You can disable AGP by putting
Code:

Option  "NvAgp" "0"
in the Device section of your XF86Config file.

--andy

Matto 05-02-03 08:53 PM

Just tried. Same result.
 
OK, I added the option line to my config file but am still getting the same result. I've attached it so you can have a look.
Also I had a look to find my video bios but the path described in the READ FIRST threat wasn't there??? There is no nvidia folder in my /proc/driver/ path hidden or otherwise???? Could this be the problem?:eek:


Cheers Matt

Matto 05-02-03 08:54 PM

Oops! Here the attachment
 
1 Attachment(s)
Thanks

bwkaz 05-03-03 07:21 AM

You won't have a /proc/driver/nvidia directory unless and until the "nvidia" kernel module gets loaded. Try an /sbin/modprobe nvidiaas root.

In addition, you won't get the video BIOS version numbers in the one file under there unless X is running (and you might even have to be using the nVidia driver, I don't know). The easiest way to get the BIOS version might be to watch for your card's bootup message.

Matto 05-04-03 07:27 PM

close but no cigar
 
I did the modprobe and followed the path for the video bios, but it don't know it. Video bios showed as ??.??.??.??.??
I'll watch while booting up.

Cheers.

Andy Mecham 05-04-03 08:50 PM

You'll only be able to get vbios info when X is active. Your vbios version is also printed out in your X log (new in 1.0-4363).

--andy

Matto 05-05-03 01:04 AM

Still not doing the trick
 
Yep X was running when I did the modprobe and I just tried again to be sure and this is what I got:

model: GeForce4 MX 440-SE
IRQ: 16
Video Bios: ??.??.??.??.??
Card Type: AGP

I also hit pause during boot up and looked in my X log file and I think my vid bios is 1102 0002 1102 8064 0401??? Can't be too sure though as I about 10 options to choose from. But my XFree86.0.log file is posted above.

Matt:confused:

bwkaz 05-05-03 08:00 AM

Quote:

(--) NVIDIA(0): VideoBIOS: 04.17.00.69.00
This is your video BIOS revision.

That other number you quoted is very likely your motherboard BIOS revision. Your vbios should be printed on the screen before that (when the video card does its POST, not when the rest of the system does its POST). :)

Matto 05-05-03 09:50 AM

Cool
 
Brill! Thanks;)

Matto 05-05-03 09:30 PM

Any new ideas??
 
My system still locks when I try to boot X with the 4363 driver. I've tried adding the option Andy suggested above but no change. I've attached my XF86config-4 and XFree11.0.log files previously and my system is:

Processor: P4 2.4
Mother Board: Gigabyte GA-ST800
Driver: 4363
Video Card: GeForce4 MX 440-SE
Video Bios: 04.17.00.69.00 (Thanks bwkaz)
Distribution: Mandrake 9.0
Kernel: 2.4.19

I'm nearly out of hair to pull out. Maybe it's just not going to work on my system:(


All times are GMT -5. The time now is 03:50 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.