nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xserver black screen - logfile attached (http://www.nvnews.net/vbulletin/showthread.php?t=11145)

zent 05-02-03 07:35 AM

Xserver black screen - logfile attached
 
1 Attachment(s)
Hello,

we bought a couple of new PCs and try to run them using Debian 3 (Woody).

First the specifications.

Hardware:
AMD Athlon XP 2400+
Epox 8RDA Motherboard (Nforce 2)
SMC Network Card

Video Card:
AOpen Geforce4 MX 440

Information from /proc/driver/nvidia/cards/0

Model: GeForce4 MX 440 with AGP8X
IRQ: 5
Video BIOS: 04.18.20.15.c3
Card Type: AGP


Software:

Debian GNU/Linux 3.0r1
Nvidia Installer Version 1.0-4363

Whenever we try to start the XServer the screen wents black and you cannot work on a local shell anymore. Remote access via ssh is still possible.

Attached is a logfile using the new 4363 driver.

Has anyone any Ideas?

zent 05-02-03 07:57 AM

1 Attachment(s)
... and here our XFree86Config.

Spirit[Si] 05-06-03 04:12 PM

Hello,

I have exactly the same problem as you do and my hardware is similar to yours.

AMD Athlon XP 2400+
Abit NF7 motherboard, Nforce2 based
Gainward Geforce4 MX460 graphics

I'm running Gentoo Linux 1.4_rc4 and I've tried nvidia drivers 1.0-4363 and 1.0-4349 but with the same problem. When starting X, I get a black screen and X is then locked. I can access my machine using ssh, so it is only X that has frozen the terminal. I can do a kill -9 on the X server which at this point gives me 100% CPU usage. Once that is done, all I can do is reboot because the console is wasted. Once X is killed, I can however type to the console, but it is impossible to see what I write since its all scrambled, possibly because the monitor is still in graphics mode.

I'm using a 2.4.20 kernel, the "xfs" one. This seems to be one of the few kernels that has support for the nForce2 IDE controler and support for the nForce2 USB controllers at the same time. Newer kernels will not boot with USB enabled and older kernels doesn't have working IDE support.

My logs are pretty much the same as yours, everything seems to be fine, except that all I get is that annoying black screen.

X version is 4.3. The nv driver that comes with X works fine.

/Spirit

Emphroon 05-07-03 09:28 AM

Hi,

No panic. It has something to do with the latest BIOS for the EPOX mobo. It seems that downgrading to BIOS version 3129 solves the problem.

Epox released a new beta version of the BIOS which you can download from:

http://www.aoaforums.com/forum/showt...0&pagenumber=1

Maybe this solves the problem, I did not test myself.

P.

Spirit[Si] 05-07-03 10:32 AM

Hi,

I'm not running the latest bios for the EPOX mobo on my ABIT mobo, so that doesn't help me much.

/Spirit

Emphroon 05-17-03 06:36 AM

Hi Zent,

Have you tried to put all your devices to IRQ5? Disable IRQ10, 11 and 12 in your BIOS, but make sure that the MIDI still points to IRQ10 (otherwise your devices get no IRQ mapping at all).

This solved the problem for me. Downgrading to BIOS 3129 killed my mobo... :(

For some reason the Epox BIOS cannot handle interrupts >= 10 properly.

My /proc/interrupts:

CPU0
0: 312717 XT-PIC timer
1: 11953 XT-PIC keyboard
2: 0 XT-PIC cascade
5: 1225416 XT-PIC usb-ohci, usb-ohci, NVIDIA nForce Audio, bttv, eth0, btaudio, nvidia
8: 1 XT-PIC rtc
14: 25826 XT-PIC ide0
15: 201 XT-PIC ide1
NMI: 0
ERR: 0


Currently running nVidia 1.0-4363 on an Epox EP-8RDA+ with a GeForce4 Ti4200/128.

Cheers

P.

zent 05-18-03 05:27 PM

You're the man!
 
Thank's a lot Emphroon that really helped us out.
Your suggestions work for us!!

We didn't not only kill one but three Mobos trying to downgrade the bios version. :-(

Then we swichted to Suse 8.2 which did not have that problem, but now we can install debian again.

Do you think that disabeling the IRQs will slow down system performance?

Thanks again!

zent

Emphroon 05-19-03 04:21 PM

Hi zent,

I'm happy that my suggestions works for you. But maybe you should thank mr. hmepas at thread

http://www.nvnews.net/vbulletin/show...&postid=124645

from whom I've got the solution!

Anyway, I am running Slackware 9.0 kernel 2.4.21rc1 with this IRQ configuration for 3 days now, and I do not have any significant performance loss. The only problem I notify is the sounddriver (i810_audio) which sometimes is not available to other applications. But then again, this module already has some known problems, it might be the driver itself.

Furthermore, USB, tv-card etc. work perfectly OK.

Cheers

Peter.

zent 05-20-03 02:09 PM

Only IRQ11
 
Hi,

we just tried some different configurations and found out that for our system IRQ11 is the troublemaker.

If we disable only IRQ 11 everything works charming.

Maybe you can bring all the other IRQs back to life again, too.

Bye

zent

Emphroon 05-20-03 04:14 PM

Well, that doesn't work. I can enable IRQ#10, but to this one the MIDI gets assigned to.

If I only disable IRQ#11 then some devices get assigned to IRQ#5 and 12, but I get the same old story again: black screen.

So it appears that I have to disable at least IRQ#11 and 12 to get the driver running.

Just for sake of curiosity, what is your BIOS version? Mine is from 7-5-2003.

P.

zent 05-22-03 10:12 AM

bios version
 
we have two different versions.

they are from 02.04.2003 and 05.03.2003.

Both types work with this settings.


All times are GMT -5. The time now is 11:29 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.