nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Newbie plugging along... (http://www.nvnews.net/vbulletin/showthread.php?t=11198)

djembeman 05-03-03 07:59 AM

Newbie plugging along...
 
Newbie questions here:

I'm running Mandrake 9.1. When the Nvidia documentation says to 'exit your x server' before installing, how is that done? I know what the X server is (I'm using KDE and Gnome) but my only options on the logon screen are: KDE, Gnome, Failsafe, and Default. I tried Ctrl-ALt-Back and got the same options as 'logout'. If I select 'Failsafe' I get a non-GUI interface in the lower right corner of the logon screen but the installer still said my X server was running. So I rebooted, hit I for interactive startup, and selected somthing like "Multiuser command line with network"

This is where I installed from. Earlier I figured out how to install binutils (cool), and found my XFree86-4 file. Now I taught myself how to use vi, and changed 'nv' to 'nvidia'. Also I learned about su to become root.

Rebooted and could not start X. :-( checked the XFree log file and:

EE Unable to load Nvidida Kernel Module , (or something similar)

Went back to the readme, checked the following in XFree86 file:
Load "glx" -there
there was no "dri" or "GLcore" -cool

Back to the log file,

Using the right config file -check (==)config file:xf85config-4
(II) LoadModule: "nvidia" line was there -check .

BUT-- Under the /dev folder there is NO nvidia anything! In another post I read to check for nvidia files being there. (That was an absolute path, right?)

SO I am stumped. Really want to play Tuxracer. If I change nvidia back to nv in the xfree file I can at least get back to X.

Any ideas, I really don't want to give up. My card is a Geforce 4 4200. I think it has something to do with where I installed from. Typing this from M$, not happy...

djembeman 05-03-03 08:15 AM

My XF86config-4 file
 
# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 70 Hz"
HorizSync 31.5-57.0
VertRefresh 50-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

bwkaz 05-03-03 11:39 AM

/sbin/modprobe nvidia as root, then startx as your normal user.

:)

If you still get the same errors, check your kernel logs (they get output by the dmesg command), but most of the time, if the kernel module's loaded and you still get that error, it's due to PnP OS being turned on in your BIOS (it should be off), or Assign IRQ to VGA being turned off in your BIOS (it should be on).

djembeman 05-03-03 08:53 PM

Will try
 
You know, I think you're right. I should have checked that earlier.
I'll try tonight and post tomorrow.

Thanks

djembeman 05-04-03 03:29 PM

Worked, with a catch
 
So I entered those commands under the appropriate users, and got X under openGL!
PLayed Tuxracer.

(Didn't have to touch my BIOS)
However, I get this error after modprobe:

Using /lib/modules/2.4.21-0.13mdk/kernel/drivers/video/nvidia.o
Warning: loading /lib/modules/2.4.21-0.13mdk/kernel/drivers/video/nvidia.o will taint the kernel: non-GPL license - NVIDIA
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module nvidia loaded, with warnings

...and once I restart I lose it and have to repeat those commands from failsafe over again. It's not "sticking".... Another poster has the same issue. See http://www.nvnews.net/vbulletin/show...threadid=11227

Thanks for getting me this far though.

paleq 05-04-03 03:51 PM

must be a line missing
 
Check your /etc/modules.conf file for a line reading

alias /dev/nvidia* nvidia

If this isn't there i can only think that you didn't install as root, and the installer couldn't edit the file because of restrictive permissions....

hope this works :D

djembeman 05-04-03 04:54 PM

questionable line in modules.conf
 
alias char-major-195 nvidia

is the last line of my modules.conf file.
However the exact line that you specified wasn't there. Should I modify this one? Enter a new line keeping this one?....

djembeman 05-04-03 04:56 PM

Oh yeah...
 
Another question:

What is the *proper* way to 'stop' the x server??

In my first post I kind of asked this question.
I've been restarting into failsafe and choosing text with networking. When installing as root, I'll use su to become root, etc...

SO I did install as root. In fact, when I first tried i wasn't root and it told me I had to be root.

bwkaz 05-04-03 05:19 PM

I've answered in that other thread.

If you're using Mandrake, you should be editing /etc/modules, not modules.conf.

The correct alias is (if you insist on editing modules.conf...) not char-major-195, though. Since Mandrake uses devfs, the alias should be /dev/nvidia*, as paleq said.

The reason it's char-major is that you probably ran the installer in failsafe mode. Is this right? If so, then Mandrake does not mount devfs in failsafe mode, so the installer couldn't detect which alias you need correctly.

The correct way to stop the X server is to run /sbin/init 3 as root from a terminal (ctrl-alt-f1 and log in as root).

djembeman 05-04-03 10:27 PM

Thanks everyone!
 
Hey it's working great now! Thanks to bwkaz and paleq. See, I don't know alot about linux (obviously), but I think that the readme could have been a little more specific on the exact things to do when installing.

For example, I got screwed up because I installed after booting failsafe, instead of correctly exiting the x server (which thanks to you guys I now know how to do). And I was going through my Mandrake docs for an hour trying to find how to "exit x server".
ALL of the documentation assumes a certain level of linux knowledge that I feel is above a beginners head.
Sorry for the rambling...

Time to get some games going, and a good basic linux book.

Thanks again.


All times are GMT -5. The time now is 12:47 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.