nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   StartX Slow on various systems with GeForce 3 Ti 500 (http://www.nvnews.net/vbulletin/showthread.php?t=11213)

ZiggyTron 05-03-03 05:44 PM

StartX Slow on various systems with GeForce 3 Ti 500
 
I just reformatted my system and switched most of my components over to a new motherboard and CPU. I installed the stock copy of RedHat 9 (Shrike), and am running kernel 2.4.20-9. When I boot, I always default to runlevel 3 (that's my personal preference, not a part of the problem.) Anyway, I installed nVidia's drivers version 1.0-4363. Now when I run startx to bring up KDE, it takes about 4 minutes time to boot. Basically, startx just starts so slowly that it makes it a pain in the butt to even get into KDE to do the one or two tasks I need it for. If it didn't take forever to load, maybe I'd use it for more things, but right now I just jump from terminal to terminal.

I am pretty sure this is NOT chipset related, CPU related, BIOS setting related, or system memory related, since all of those components changed when I reformatted and rebuilt my system, and the problem existed with the old system just as it does now (with the same drivers).

Old System:
--------------
CPU: Athlon XP 1700+ (1466MHz)
Memory: 512MB PC2100
HDA: 200GB
HDB: 200GB
HDC: 13GB
Chipset: Via KT400
Board: Abit AT7-MAX2
Graphics: Nvidia GeForce 3 Ti 500
Monitor: Digital Flat Panel 19" Planar LCD Screen

New System:
--------------
CPU: Pentium 4 2.66GHz
Memory: 256MB PC2700
HDA: 200GB
HDB: 200GB
HDC: 30GB
Chipset: Intel 845
Board: (unknown - ships in Dell Dimension 4550 systems)
Graphics: Nvidia GeForce 3 Ti 500
Monitor: Digital Flat Panel 19" Planar LCD Screen

--------------

The older drivers took forever to load - these take forever to load too. I cannot ssh into my machine from another linux machine while startx is loading - it says "connection timed out" every time I try. The screen on the local system just goes black. There is no disk activity until about 2 seconds before the nvidia logo shows up on the screen... it just sits there totally unresponsive. I've tried changing options in my XF86config file (IgnoreEdid, UseEdidFreqs), etc, but it doesn't help. I noticed that a while ago a lot of people were having problems with TNT chips and this exact same situation, but that thread hasn't been posted to in 5 months. Their solution was to wait for a better driver release - which eventually came.

The GeForce 3 was never all that popular of a model, though, so I wonder if nvidia will ever fix this for us. Anyway, if you have any ideas, please let me know - I'd rather not have to go shopping, take a shower, eat lunch, and watch a movie only to come back and find that startx is just finishing up with its load. :-)

One other thing to note - when I look in "top" after it gets into X, X has used up about 3 minutes of CPU time - the amount of time it takes to load. Why would this be?

Thanks in advance for everyone's help.

bwkaz 05-03-03 06:47 PM

From the README, the FAQ section:

Quote:

Q: X takes a long time to start. What can I do?

A: Most of the startx delay problems we have found are caused by incorrect
data in video BIOSes about what display devices are possibly connected
or what i2c port should be used for detection. You can work around
these problems with the XF86Config option "IgnoreDisplayDevices"
(please see the description in (app-d) APPENDIX D: XF86CONFIG OPTIONS).

ZiggyTron 05-04-03 01:48 AM

Fixed it - Thanks!
 
Thanks for your help - adding that to the config file fixed my problem. I read that README.txt from nvidia.com three times over and missed that part. Oops! Thanks for pardoning my stupidity.

In other news - I really think that Nvidia needs to note that for DVI output cards, if you are using a DVI port instead of VGA, you NEED to turn this option on or otherwise expect boot to take a long time. It's buried so deep in their documentation that I never even noticed it!

Me read good.

--Kevin

procy 05-07-03 06:04 PM

I have the same problem as you describe. When I startx as root it takes ages for it to start up. When I use a display manager like xdm or kdm X won't start at all, I'll just get the nvidia logo for a moment, then see a the xdm background for about half a second and the screen turns to black again for about 2 minutes, this goes on indefinitely (well at least for a couple of hours). Setting the IgnoreDisplayDevices option to "DFP, TV" fixes that issue but now I can't use nvtv anymore to use tvout (which makes sense I guess). It can't find any modes.

Didn't have this problem with the older drivers (although I cant remember exactly at wich version this problem was introduced).

Is there a solution?

My hardware:

GF3 Ti500
Asus A7V266-E (via kt-266a)
Athlon XP 1700+

My Software
Mandrake 9.1
(But the same thing happens on both debian & gentoo)

Andy Mecham 05-07-03 11:33 PM

This is a problem with your vbios, not the driver, as indicated in the README. Please check with your video card manufacturer to see if they have an updated vbios available for you.

--andy

procy 05-08-03 04:37 AM

It's a hercules prophet III titanium 500. According to their site there is no bios update available.

Seems i'm out of luck :(


All times are GMT -5. The time now is 01:54 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.