nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   module nvnet not working (http://www.nvnews.net/vbulletin/showthread.php?t=11222)

pixelxeno 05-03-03 11:12 PM

module nvnet not working
 
Hello,

I got a brand new shuttle, the SN41G2, with a nforce2 chipset inside, and everything is working really nice and fine under linux expect the network. I'm running a debian and here what I get:

With the bare 2.4.18-bf kernel shipped with the debian system, I get the message "PCI: Setting latency timer of device 00:04.0 to 64" when I modprobe nvnet, then if I try to ifconfig eth0 up the device, the kernel goes panic inside the syscall of ifconfig. Further call to ifconfig or rmmod nvnet does freeze.

Then I tried to compile both a 2.4.20 and 2.4.21-pre7 kernel, and there the module loads perfectly, I can ifconfig eth0 up the nvnet adapter, but it simply doesn't work. If I try to send packets thru the interface, the little led behind the machine doesn't blink. And of course, ifconfig shows that packets are emitted, but no packet at all are received. And things like ethereal shows that nothing goes out the interface (with ethereal running on another computer linked to the shuttle) nor in (with ethereal running on the shuttle, hence the kernel actually thinks it sends the packets, so I can see them)

So, well, what should I do? It seems that this bug was not already reported (I went through the forum, and I didn't see any message like mine)

I'm actually running the shuttle under linux with a third party PCI network card which is not a good solution for me since I've got only one PCI slot in the shuttle :rolleyes: So I really would like the nvnet driver to be working :)

pixelxeno 05-04-03 08:11 AM

Ok, my bad, I did mistaken with some bits in my installation of the driver, it is working now ;-)

But I'll stick around this forum to help out a bit if I can. See you!

elforro 07-22-03 09:08 AM

module nvnet not working
 
Hey, i had the same problem with my SN41G2 and Debian woody !!! ... can you tell me how did you solve the problem ?? Please, I don't want to switch to RedHat !

Thanks !

pixelxeno 07-22-03 10:53 AM

In fact, I was using a custom kernel 2.4.21-pre7, and since there is firewire in the machine, I enabled the thing for it, and thus, it created an eth0 for that. My nvnet device was eth1. So, it should work perfectly with a 2.4.21 kernel.

elforro 07-23-03 09:55 AM

mmm ... ok, I'll test with a 2.4.21 kernel ... I'm not sure to understand everything about the firewire (your firewire is used as eth0 ?) but I gona try it ... thanks ! :)

pixelxeno 07-23-03 10:12 AM

Using a simple cable, you can link two computer directly with firewire ports. The linux ethernet-over-firewire driver supports that, and thus, build an ethernet device over the line.

elforro 07-23-03 11:46 AM

:(

it does not seem to work for me ... maybe I'm doing something bad ... the kernel works well, the nvnet module compile and loads fine, I can ping machines over internet but I can't connect to them ! can you send me your kernel .config file ?

pixelxeno 07-23-03 12:32 PM

If you CAN ping machines on the net, then it's allright! You only have to finish configuring your network! Just verify your /etc/resolv.conf is well defined and does contain a valid nameserver.

elforro 07-23-03 03:33 PM

it's strange ... I can ping a domain like www.google.com but I can't connect to the website ! idem for all the FTP servers I've tried ... I can't figure where is the clue !!

:(

elforro 07-29-03 12:07 PM

Please, this problem is eating all my time !! I can't get a proper network configuration, but I suspect a kernel issue ... can you send me a .config kernel file ?

leibold 07-30-03 01:33 AM

Try building a kernel without ACPI, or turn off ACPI on the boot commandline. At least that works for me on the ASUS A7N8X.

elforro 07-30-03 05:14 AM

thanks for your response :) but unfortunatly it didn't change anything ... and I can't figure if it's the nvnet module which works bad or my linux configuration. I have a debian laptop in the same network, with the same configuration, and it works perfectly...


All times are GMT -5. The time now is 03:47 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.