nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   yet another poor soul with nvnet woes (running RH9) (http://www.nvnews.net/vbulletin/showthread.php?t=11224)

Jasonofabitch 05-03-03 11:20 PM

yet another poor soul with nvnet woes (running RH9)
 
I'm running Red Hat 9 with the 2.4.20-8 kernel. I've tried using both the SRPM and the tar file from nVidia's site, and I can't seem to get either working for the life of me.

First I tried:
rpmbuild --rebuild <package name>

Then I tried (after unpacking the tar of course):
cd nvnet
make clean
make
make install

In either case, I'm getting errors. When using the SRPM I get this:

*** [nvnet.o] Error 1
Leaving directory '/usr/src/redhat/BUILD/nforce/nvnet'
*** [nvnet_make] Error 2
Bad exit status from /var/tmp/rpm-tmp.3756 (%build)

When going through the tar install I get this:

mkdir -p //lib/modules/2.4.20-8/kernel/drivers/net
install -b -m 644 nvnet.o //lib/modules/2.4.20-8/kernel/drivers/net
install: cannot stat 'nvnet.o': No such file or directory
make: *** [install] Error 1

I'm at my wit's end. I've read countless posts on these forums and tried anything and everything I can think of. I'm quite the newbie when it comes to linux so this is starting to get rather frustrating. Can anyone give me any idea as to what I need to do to get this working?!

*Note* I forgot to mention before that I've added the line alias eth0 nvnet to modules.conf.

pixelxeno 05-04-03 06:22 AM

In all cases your error reporting is not enough. When it says

*** [nvnet.o] Error 1

it means the true error message is one or more lines above, and this error message is really necessary to help you out on this one ;-)

Brad Smith 05-04-03 01:45 PM

nforce & RH 9
 
When I try to rebuild the nforce source rpm I get the following:

nvcrush.c: In function `Nvaudio_mmapwrite':
nvcrush.c:426: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nvcrush.c:426: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nvcrush.c:426: too few arguments to function `remap_page_range_R2baf18f2'
nvcrush.c: In function `Nvaudio_mmap':
nvcrush.c:465: warning: passing arg 1 of `remap_page_range_R2baf18f2' makes pointer from integer without a cast
nvcrush.c:465: incompatible type for argument 4 of `remap_page_range_R2baf18f2'
nvcrush.c:465: too few arguments to function `remap_page_range_R2baf18f2'
make[2]: *** [nvcrush.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/nforce/nvaudio'
make: *** [nvaudio_make] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.89202 (%build)


The rpmbuild command is:
rpmbuild --rebuild NVIDIA_nforce-1.0-0256.src.rpm

I have not tried the tar file yet.

Thanks,

Brad

Jasonofabitch 05-04-03 02:43 PM

Give me a few minute pixelxeno and I'll get back to you with the full error message. :)

Jasonofabitch 05-04-03 07:53 PM

Ok, so that was far more than a few minutes. At any rate, there are a ton of warning messages with both the SRPM and the tar file. I couldn't begin to type them all here. The bottom line is I'm getting exactly the same type of errors that everyone else has been posting about and none of the solutions that have been posted have worked for me.

:(

pixelxeno 05-05-03 03:21 AM

I suspect that the audio part of the nforce driver from nvidia is taking you down on this one. Try going into the "nvnet" subdirectory and doing a single "make" there. It should compile fine. Then, do make install.

The nforce driver from nvidia has yet a poor installation method. Maybe they'll come with a better installation system, like they do with the NVidia GLX driver.

In all cases, I think you can safely take the tarball and not the srpm because you only want the nvnet part of the driver.

Jasonofabitch 05-05-03 04:13 PM

I tried going into just the nvnet directory with the tarball. I did:

make clean
make
make install

This didn't work. =/

pixelxeno 05-05-03 04:32 PM

Still with a huge error message too big to be pasted here?

Jasonofabitch 05-07-03 10:28 PM

No, it's not that it's too big to be pasted here... it's just that I can't get any networking set up, therefore I can't connect to the internet in order to access this forum. I would just copy/paste the error into a .txt file and throw it on a floppy, but the box doesn't have a floppy drive. I'm in quite a pickle. :/

Eci 05-08-03 04:34 AM

I'd same problems with Mandrake, but after I installed kernel sources from install cd, I managed to install nforce drivers from SRPM.


Eci

yurka 05-08-03 03:56 PM

the same trouble with nvnet
 
I have just installed Mdk 9.1 on A7V8X

When I compile nvnet it gives a mass of text and error "cc -c -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/usr/src/linux-2.4.21/include nvnet.c"

Still the quastion how to compile that module?

DeVioSiTY 05-22-03 08:28 PM

same trouble
 
the nvnet driver also fails to compile on my system. Here's the error:

/usr/src/nforce/nvnet# make
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/usr/src/linux-2.4.21/include nvnet.c
In file included from nvnet.h:20,
from nvnet.c:21:
/usr/src/linux-2.4.21/include/linux/module.h:21:34: linux/modversions.h: No such file or directory
make: *** [nvnet.o] Error 1

Is this only suppose to work as a module? I like to run a tight ship, so if you have module support disabled it makes a tighter kernel. Plus it can help keep the script kiddies at bay.

I have been able to get the object file created at one point, but now I'm not certain how to get it into the kernel. :(


All times are GMT -5. The time now is 10:51 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.