nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   "fatal server error no screens found" problem (http://www.nvnews.net/vbulletin/showthread.php?t=11232)

wyldedog 05-04-03 08:30 AM

"fatal server error no screens found" problem
1 Attachment(s)
After installing 1.0-4349 drivers for my TNT2 and editing XF86Config-4 i get this message when i start X. "fatal server error no screens found" Also tried with the new drivers but have the same problem. Any help would be appricated....

wyldedog 05-04-03 08:33 AM

1 Attachment(s)
Just the /var/log/XFree.log

bwkaz 05-04-03 12:09 PM


Q: My X server fails to start, and my XFree86 log file contains the error:

"(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!"

A: Nothing will work if the NVIDIA kernel module doesn't function
properly. If you see anything in the X log file like "(EE)
NVIDIA(0): Failed to initialize the NVIDIA kernel module!" then
there is most likely a problem with the NVIDIA kernel module.
First, you should verify that if you installed from rpm that
the rpm was built specifically for the kernel you are using.
You should also check that the module is loaded ('/sbin/lsmod');
if it is not loaded try loading it explicitly with 'insmod' or
'modprobe' (be sure to exit the X server before installing a new
kernel module). If you receive errors about unresolved symbols,
then the kernel module has most likely been built using header files
for a different kernel revision than what you are running. You can
explicitly control what kernel header files are used when building
the NVIDIA kernel module with the --kernel-include-dir option (see
`sh NVIDIA-Linux-x86-1.0-4363.run --advanced-options`
for details).

Please note that the convention for the location of kernel header
files changed approximately at the time of the 2.4.0 kernel release,
as did the location of kernel modules. If the kernel module fails to
load properly, modprobe/insmod may be trying to load an older kernel
module (assuming you've upgraded). cd'ing into the directory with
the new kernel module and doing 'insmod ./nvidia.o' may help.

Another cause may be that the /dev/nvidia* device files may be missing.

Finally, the NVIDIA kernel module may print error messages indicating
a problem -- to view these messages please check /var/log/messages, or
wherever syslog is directed to place kernel messages. These messages
are prepended with "NVRM".
Fun stuff, the README. ;)

You might also want to try to upgrade to 4363 rather than 4349. 4349 has a couple of bugs in it (none that cause this, that I know of, but there are others).

wyldedog 05-04-03 08:26 PM

thanks for the help...The Nvidia Module isn't loading or is being shut down due to the screens error...i can load it with insmod but it doesn't make any differance. Just indicates under lsmod that the module is loaded but unused. Im running Mandrake 9 and have tried the 4363 drivers to no avail...Same problem...The card is a tnt2 64..on a BX Master motherboard...The driver runs under the 3.6.6.X windows driver but with no 3d acceleration....Ive tried changing the resolutions thru xfdrake ect. but still no go ??? any help appriciated

bwkaz 05-05-03 07:51 AM

Huh? You need to be using X 4.0.1 or later, this driver WILL NOT work on 3.3.6.


The Nvidia Module isn't loading or is being shut down due to the screens error
No, not really. The screens error is not the root cause of anything, it's just a symptom. The cause is that the kernel module can't initialize itself for some reason. Fix that, and the no screens error will go away.

Have you tried doing /sbin/modprobe nvidia as root, then startx as your normal user (without rebooting)?

wyldedog 05-05-03 09:26 AM

Hiya...still trying..lol...
Done a complete new install of mandrake 9.0 on a bx Master motherboard with tnt2 m64 AGP video card ...celeron 400 cpu..reset the bios as per other posts on this forum..and installed latest 4363 drivers from nvidia..Guess wot...Still same problem??? lsmod
says nvidia module is loaded and am running xfree 4.2.1. if i chang the "nvidia" back to "nv" in the XF86Conf-4 file it runs but with some garbage on the screen occationally. If i look at /proc/drivers/nvidia/card it says the video bios is
". . . . . . . ."
Any Ideas


bwkaz 05-05-03 10:21 AM

After loading the module, startx, and if that fails, look in the output of dmesg | grep NVRM to see if any reason why got logged.

wyldedog 05-06-03 05:00 AM

hiya bwkaz...thanks for the help...well tried that and recieved the message...

0:NVRM: rm_init_adapter failed

does that mean the card is stuffed??? or the mobo??

im running outta options and ming have ta use the banshee instead

bwkaz 05-06-03 07:56 AM

Hmm... Well, I can't see the source for rm_init_adapter (it's in the nv-kernel.o file, which is precompiled), so I don't know what could cause it. But looking at the nv.c file, that function (rm_init_adapter) is returning 0 for whatever reason, when it should be returning nonzero.

Nothing useful comes back from Googling for the error, either. I get a Bulgarian LUG mailing list posting, but I can't read Bulgarian. ;)

I also get a single posting to another LUG list (in English this time), but there's no solution -- nobody even responded that I can see.

This sounds like one for the people that can see the source to rm_init_adapter -- Andy?

All times are GMT -5. The time now is 12:43 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.