nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Help with install in Mandrake 9.1 (http://www.nvnews.net/vbulletin/showthread.php?t=11272)

livewire43 05-05-03 12:29 AM

Help with install in Mandrake 9.1
 
1 Attachment(s)
I am running Mandrake Linux 9.1 on a Dell laptop with a built in GeForce 4 video card with 64meg of ram (i think that's all right). I used to run Mandrake 9.0 and I installed the nvidia drivers just fine for that (i believe i used the rpms) and they worked beutifully (especially because they let me run tux racer which i couldn't do with the generic drivers). Anyway, the problem is this... I tried installing the nvidia drivers using the .run file but had major problems. Here's how I went about it... I set the default runlevel to 3, rebooted, ran the .run file, edited the XF86Config-4 file to change the driver from nv to nvidia and set the default runlevel back to 5 (all of that was done as root). Then, I logged in as my normal user and ran startx. I got the nvidia splash screen and everything ran perfectly (even tux racer). I then rebooted and when it tried to start the graphical mode it would just flash the nvidia splash screen a couple times then go back to the console and say something about loading a module and then it would say "shutting down x server" and i'd be back to the console. This kept happening so I tried uninstalling the drivers and resetting the XF86 file and i would just get the login screen flashing in the same way w/o the nvidia logo. I finially just had to reinstall linux alltogether. Sorry for the long post but could somebody please tell me how to install these drivers properly?! Thanks to anyone who actually read all of this!

bwkaz 05-05-03 08:06 AM

You were probably very close before.

But seeing as you reinstalled (NOTE: this is not Windows -- reinstallation is very rarely needed...), the opportunity to fix it is gone.

What I'd do is boot to runlevel 3, run the installer, change the config file, startx, and make sure that all works.

Then reboot (to clear out the kernel modules; cleared modules is what I'm guessing your problem was -- seeing as we don't have an X log to go from, though, my guess is as good as anyone else's...), still to runlevel 3, and try to startx again. It sounds like you know your way around the shell, so it shouldn't be too hard to save the log file that's probably going to fail.

If it fails, /sbin/modprobe nvidia as root, and try again. It should work. Once you've verified that that's the problem (the kernel module not loading on boot), you can add an alias to /etc/modules.conf (or add "nvidia" to /etc/modules, either way):

alias /dev/nvidia* nvidia

If you edit modules.conf, then run /sbin/depmod -ae as root afterward.

livewire43 05-05-03 10:15 AM

Ok, I'm going to try that but I'm just curious if anyone has any guesses as to why I didn't have to go through any of that with Mandrake 9.0? Anybody know (or have a guess) what the change that could have caused the module not to load? I guess the change could have been something in the installer also as this was not the way I installed in 9.0 (because this installer didn't exist at the time). One more thing, could someone tell me why, even after uninstalling the nvidia drivers and changing nvidia back to nv in the XF86Config-4 file, X would still do the same thing? And if you do know, maybe you could tell me how to go about unintalling the nvidia drivers if I ever need to and make X work again. Thanks for the help guys.

livewire43 05-05-03 11:33 AM

Well, for whatever reason, upon reinstalling (the same way as before) it worked just fine. I'll just hope it keeps working...


All times are GMT -5. The time now is 03:59 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.