nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   X freezes after upgrade to RedHat 9 (http://www.nvnews.net/vbulletin/showthread.php?t=11333)

bdw 05-06-03 01:50 AM

X freezes after upgrade to RedHat 9
 
I recently upgraded my system to RedHat Linux 9 with XFree86 4.3.0.

What will happen is that X will freeze, though the mouse cursor can still be moved but I can't use the keyboard.

I have to login to my box with a laptop and kill the X process and restart it.

I have a Gigabyte 7ZXE motherboard, and it does use the VIA chipset that can cause problems with AGP 4x. I've sent the X driver (version 4063) to use 2x, but that doesn't solve the problem.

I've a ChainTech video card with a GeForce 4 MX 450.

Has anyone else had this problem, and if so, what was the resolution?

Thanks,
Brian

petteri 05-06-03 03:22 AM

I have the same problem with redhat-7.3. Problem solved when I use nv driver. No 3D graphics for me :(

tbs 05-06-03 06:29 AM

I have the exakt same problem...there must be a sulution....I have tried everything in the nvidia readmes etc....nothing works.....plz someone...help =P

bdw 05-06-03 03:30 PM

I may use NV in the interim.

But, I will file a bug report on the driver, looks like I'm not alone with this.

outabout 05-06-03 11:22 PM

Hi,

We have this problem as well

X consumes 100% cpu.

I can recreate this at will with a particular app it is an OPENGL app called Tecplot.

Ive logged it with the app developers but the call that seems to
cause all the problems is sched_yield().

I log in via another machine do an strace -f -p PID on both
X and the app with the problem but it seems X is okay
and the app is in some loop with sched_yield()

Kill the app and X still takes 100% cpu

Kill X and login again all is fine.....

This is on both RH8 and RH9 with the latest nvidia drivers

bdw 05-06-03 11:29 PM

That's the same thing that I've seen.

I login to the system on my laptop and X is using up about 100% of the time. I have to kill X and that seems to do the trick. Until it freezes again, of course

WaxyLemon 05-08-03 02:30 PM

Appears to be related:
http://www.nvnews.net/vbulletin/show...threadid=11383

Also:
http://www.nvnews.net/vbulletin/show...threadid=10972

At least I'd like to think there isn't more than 1 problem with the driver that produces identical symptoms.

Caveat: with Redhat 9 I reverted to NVidia driver release 3123. GLX will fail to load but at least it doesn't freeze on me. Only reason to do this is TwinView support and DVI support, otherwise I would just use the open source driver. Which leads me to believe the bug is either in NVidia's GL or GLcore... the consensus seems to be that it happens alot when mozilla does stuff with fonts.

Maybe I'll try to turn off GLX and see if the freezes go away in 4363.

AEvanVogt 05-08-03 04:08 PM

Its about normal. On all linux versions I have used, the nvidia driver required with different kernels was different, and each required its own kernel patch besides the driver. When you upgrade, you are changing the kernel, so a different nvidia driver and another patch would be required. The old nvidia driver causes a protection fault. X aborts and restarts over and over. Some versions of linux detect and stop the endless loop. Others do not. You have to get into a working linux prompt and install a new nvidia driver from NVIDIA. Otherwise you can use the minimally functional nv driver that comes with the distribution by editing XFree86config (or -4), putting nv for nvidia.


All times are GMT -5. The time now is 03:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.