nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Sreen freezes when I use the NVidia driver (http://www.nvnews.net/vbulletin/showthread.php?t=11383)

godot 05-07-03 12:04 PM

Screen (Probably only X, since the mouse moves) freezes when I use the NVidia driver
 
1 Attachment(s)
I tried to install the nvidia driver 1.0-4363. First I used the automatic installer, and in a second try I used the GLX and kernel .tar.gz, but the result was the same.
When I run 'startx', everything works fine, I got the nvidia screen and KDE starts. But in KDE, if I launch some applications as Mozilla for example, the screen freezes ! Only the mouse cursor can be moved (but without any effect when clicking on something). I have to reboot the system...
I had already tried the1.0-4191 version, but had the same problem.

Here is my configuration:

- video card : Riva TNT2 Model 64
- driver version : 1.0-4363
- distribution : Mandrake 9.1 (Build OS : Linux 2.4.21-0.13mdksmp i686 [ELF])
- video bios revision : 02.05.19.03.00
- processor : Pentium III 733Mhz
- motherboard model : ELITE P6BAP-ME (Chipset VIA 82c693A/596B)


Here is my XF86Config-4 file:

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Iiyama S700JT1"
HorizSync 30-70
VertRefresh 50-130

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "RIVA TNT2"
Driver "nvidia"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection




I attached my XFree86.0.log file.

I hope someone can help me and that there is a solution.... :confused:
Thanks for any help

Gromit 05-08-03 05:51 AM

I'm experiencing same problems:
sound + mouse still work whereas the screen freezes
Strg+Alt+Fx and Strg+Alt+Backspace dont work either
and: no such problems when i use nv instead of nvidia.
this is very annoying since it make smy system unusable....

after some time I now believe the problem is related to fonts and their rendering (well.. I guess so )

do nvidia-drivers work well together with XFree or freetype font rendering ?

omas 05-08-03 07:30 AM

Same problem.

I have had a longstanding issue with Mandrake 9.1 and freezes when starting Mozilla, nowadays i just skip using Mozilla and everything works fine.

BUT, i don´t like it when something is that sensitive.

I too suspect some form of rendering issue with fonts.

The problem occurs almost exactly at the same point when starting Mozilla and its when Mozilla shows up, and i try to write something in the addressfield, then my machine comes to a total halt, its completely frozen and the only thing to do is to hit the powerbutton.

Nothing at all in the logs, and i do mean nothing.

Ive had earlier problems with Gnome that also displayed the same problems with freezing...

WaxyLemon 05-08-03 09:26 AM

I think my problem may be related:
http://www.nvnews.net/vbulletin/show...threadid=10972

also seems to happen more often when mozilla is running.

have any of you tried to access your machine over the network after a freeze? if you have a 2nd computer with an ssh client you might find that you can still log in remotely. and if you run the program "top" (or simply ps afux) you'll probably find that X is using 100% of the CPU.

you can run "killall -9 X" which will hose the console, but then you can restart X (or if you use runlevel 5 it will start up again automatically).

godot 05-09-03 11:05 AM

I can't access my machine via ssh since I haven't a second machine to make a network. But I'll check if sound continues to play when X freezes.
I will also try some stuff I've read in different posts, as disabling apic and acpi. and also stuff like "NvAGP" "1" or "NvAGP" "0" or "NvAGP" "3". Maybe with luck.... I'll post the results when I've tried.

WaxyLemon> I think we have the same problem. I'll post in this thread and in yours anything that could help

WaxyLemon 05-09-03 03:00 PM

Turning off apic, acpi, agp, and just about everything else hasn't helped me. But your mileage may vary.

I submitted a bug report last week, but haven't heard about whether they've reproduced it or not. Any word Andy?

AutoPilot 05-09-03 10:12 PM

Repeatable way to lock X instantly
 
Same here...
One way to lock X instantly, which is very repeatable and surprizing that it got past regression testing, is to simply launch openoffice and pull up the open file dialog.

I've reported this with older drivers, and the newly released one (topic of this thread) has the bug as well.

Please see thread http://www.nvnews.net/vbulletin/show...p?postid=96556
for more info.

On a good note, the performance of the new driver is incredible!
With my measley GeForce2GTS64M card, I can run UT in 1600x1200 with very smooth performance (1400x1050 was pushing it before).

Unfortunately, not being able to run openoffice, or just have a stable X, means I have to rely on the non-accellorated nv driver.

thoromyr 05-10-03 09:34 AM

I have the same problem, SuSE 8.2 with TNT2 using 1.0-4363. Locks up randomly, usually after a few minutes of login. If I ssh in from another computer X is taking up ~98% cpu. If I kill the xserver it logs out the locked up session and the computer becomes usable again.

Happens with, for example, login and running only konqueror or login and running only kmail.

AutoPilot 05-10-03 02:13 PM

Please see my new thread titled: OpenOffice triggered NVidia X lockup isolated!!

http://www.nvnews.net/vbulletin/show...threadid=11568

Quick solution: remove the following line from XF86Config
Option "RenderAccel" "True"

WaxyLemon 05-12-03 08:04 AM

I'm not at my home workstation right now but I am pretty sure that I had already disabled RenderAccel to no avail. But I'm glad it fixed your problem.

karloch 05-12-03 06:42 PM

I'm getting the same problem with my nVidia Riva TNT 2 Ultra and using the lastest drivers available, the 4363.

I switched back to 3123 and the problem has gone...

godot 05-13-03 10:50 AM

It seems that disabling AGP solves my problem !
 
I have tried older drivers, and finally I reinstalled the driver 1.0-4363 (with the installer). I put the Option "NvAGP" "0", and it seems to work !!! I'm currently writing on the forum with Mozilla. It didn't crash on start, and it seems to be stable ! (before, it wouldn't even load the home page).
Well it seems that something goes wrong with Linux 2.4.21-0.13mdksmp i686 + Riva TNT2 Model 64 + driver 1.0-4363 ! (and also some older versions).

Woohoo, that works!!!

Of course I'm lucky, I think of persons like WaxyLemon who already tried to disable AGP, without success :(

Now, I'm going to try "NvAGP" "1" or "2", in case one of them works.


All times are GMT -5. The time now is 07:58 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.