nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Nvidia Linux Driver Problem Reedition For Andy (http://www.nvnews.net/vbulletin/showthread.php?t=11389)

tsubasa 05-07-03 02:46 PM

Nvidia Linux Driver Problem Reedition For Andy
 
1 Attachment(s)
Hello Andy,
This is the famous Log files :)

tsubasa 05-07-03 02:47 PM

and
 
1 Attachment(s)
This is the second famous Log files :

tsubasa 05-07-03 02:49 PM

Anf the Final
 
1 Attachment(s)
My Xfree Config

bwkaz 05-07-03 05:59 PM

From your X log:

Quote:

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
And from the README:

Quote:

Q: My X server fails to start, and my XFree86 log file contains the error:

"(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!"

A: Nothing will work if the NVIDIA kernel module doesn't function
properly. If you see anything in the X log file like "(EE)
NVIDIA(0): Failed to initialize the NVIDIA kernel module!" then
there is most likely a problem with the NVIDIA kernel module.
First, you should verify that if you installed from rpm that
the rpm was built specifically for the kernel you are using.
You should also check that the module is loaded ('/sbin/lsmod');
if it is not loaded try loading it explicitly with 'insmod' or
'modprobe' (be sure to exit the X server before installing a new
kernel module).
If you receive errors about unresolved symbols,
then the kernel module has most likely been built using header files
for a different kernel revision than what you are running. You can
explicitly control what kernel header files are used when building
the NVIDIA kernel module with the --kernel-include-dir option (see
`sh NVIDIA-Linux-x86-1.0-4363.run --advanced-options`
for details).

Please note that the convention for the location of kernel header
files changed approximately at the time of the 2.4.0 kernel release,
as did the location of kernel modules. If the kernel module fails to
load properly, modprobe/insmod may be trying to load an older kernel
module (assuming you've upgraded). cd'ing into the directory with
the new kernel module and doing 'insmod ./nvidia.o' may help.

Another cause may be that the /dev/nvidia* device files may be missing.

Finally, the NVIDIA kernel module may print error messages indicating
a problem -- to view these messages please check /var/log/messages, or
wherever syslog is directed to place kernel messages. These messages
are prepended with "NVRM".

tsubasa 05-07-03 07:09 PM

ey ?
 
if it is not loaded try loading it explicitly with 'insmod' or
'modprobe' (be sure to exit the X server before installing a new
kernel module).

I write insmod ? or insmod nvidia ?
i write modprobe ? or modprobe nvidia ? At Every Start ???

I am not a professionnal of linux :)
be sure to exit the X server before installing a new
kernel module). <- It Say I Do Reinstall Something ???

I dont about the kernel but i use a mandrake 9.1 u will know better me what kernel is use i think its 2.4 but i dont understand the lines :

If the kernel module fails to
load properly, modprobe/insmod may be trying to load an older kernel
module (assuming you've upgraded). cd'ing into the directory with
the new kernel module and doing 'insmod ./nvidia.o' may help.

I a little bit lost :'(

bwkaz 05-07-03 08:14 PM

Re: ey ?
 
Quote:

Originally posted by tsubasa
if it is not loaded try loading it explicitly with 'insmod' or
'modprobe' (be sure to exit the X server before installing a new
kernel module).

I write insmod ? or insmod nvidia ?
i write modprobe ? or modprobe nvidia ? At Every Start ???

For the moment, yes, on every reboot, do an /sbin/modprobe nvidia when su'ed to root, then exit the root shell and startx as your user. If X works that way, then we can try to get it to load automatically, either on boot or the first time it's needed. One step at a time. ;)

Quote:

be sure to exit the X server before installing a new kernel module). <- It Say I Do Reinstall Something ???
Well, I think I'd reword it if I could. It means "don't run the modprobe when X is running", basically. However, given the problem that the modprobe is fixing, that shouldn't even be a problem -- X is failing to start. ;)

When it says "install", it should really say "load". Linux lets you overwrite (AKA delete and recreate) any kind of file that's in use; what happens is, both copies of the file stay on disk until all processes close the file handle that they had on the old version. This is why it never takes a full reboot to upgrade anything but the kernel -- the files are just overwritten, and reloaded from disk next time they're needed. Much better. :)

But yeah, you have to not be running X to load the kernel module. You also should be outside of X when upgrading the driver, just so that the installer knows which module is loaded.

Quote:

I dont about the kernel but i use a mandrake 9.1 u will know better me what kernel is use i think its 2.4 but i dont understand the lines :

If the kernel module fails to
load properly, modprobe/insmod may be trying to load an older kernel
module (assuming you've upgraded). cd'ing into the directory with
the new kernel module and doing 'insmod ./nvidia.o' may help.

This very likely isn't even an issue anymore. I'd just not worry about it. :)

tsubasa 05-08-03 04:20 AM

For info
 
For information, i never try to install the nvidia driver with X start !
I always start Linux in Failsafe for install !

tsubasa 05-08-03 05:06 AM

Re
 
1 Attachment(s)
I have format my linux
-I reinstall a clean mandrake 9.1
-I boot in failsafe
-I install nvidia drivers 4363
-I VI the XFconf86-4 fot make the change
-I starts X, always the same errors
- I try your solutions, i write in the console /sbin/modprobe nvidia
"That says Nvidia kernel loading sucessfully with warning"
-I starts X, Black screen and stop my pc
-I reset my pc, and restart linux in konsole.
-I try another one /sbin/insmode nvidia, i have the same message "nvidia kernel loading sucessfully with warning".
-I startx, black screen and stop my pc
I look in the XFconf.log i have always the same error :'(.
Look at that :

tsubasa 05-08-03 05:09 AM

and
 
1 Attachment(s)
This is another log system if it can help you

Thanks for your help ! I am very disapointed

Best regards

bwkaz 05-08-03 08:20 AM

Is this error the one you get after modprobe'ing nvidia? Or before?

I have a feeling the issue that's causing the need to modprobe nvidia manually is that you booted to failsafe when you installed the drivers. In Mandrake, failsafe doesn't mount devfs (the device filesystem -- devfs is a completely in-memory filesystem; failsafe mode uses the on-disk device files instead), so the installer doesn't put the proper alias in /etc/modules.conf (the alias depends on whether your distro uses devfs or not; if it does, the alias should read alias /dev/nvidia* nvidia, and if not, it should read alias char-major-195 nvidia instead). So the kernel module doesn't load when you're back in real (non failsafe) mode.

Think of it this way -- you wouldn't install a video driver while booting Windows to safe mode, would you? I know I wouldn't... though I don't know exactly what all the differences are between Win normal and Win safe, I do know one very important one in Mandrake.

But if you're still getting that error after you modprobe nvidia, then you need to look in your kernel logs after an X attempt (use dmesg to see the kernel logs). It should have a reason in there that it failed.

tsubasa 05-08-03 08:33 AM

!
 
I probe nvidia after installing driver, i reset my computer i choose
Linux at liloo and my screen start flashing when mandrake is loading xinetd services after i have the error (ee) screen(s) found,but none have usable configuration.
At root i do a /sbin/modprobe nvidia, and i have this message "nvidia kernel loaded with warning". And i do a startx but the computer crashes too black screen.

but how can i do for start my mandrake for install driver ? I dont know how i can do that, the only thing i know to boot my linux without startx is the failsafe. Say me the another method please..

Thanx a lot a lot

tsubasa 05-08-03 10:51 AM

!
 
I have format and reinstall mandrake 9.1.

In KDE i open a console and in SU i write init 3.
I have try to install nvidia driver, and after i also modify the XFconf86-4.
At reboot, my pc crashes after load xinetd services and i have a black screen.
i have tried to modprobe nvidia and startx but it failed too, black screen.
I have copy the xfconf.log but its the same than the other one,

Kernel load failed
(EE)Screen(s) found, but non have a usabe confi....

:'(


All times are GMT -5. The time now is 05:46 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.