nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem with GLX and MDK 9.1 (http://www.nvnews.net/vbulletin/showthread.php?t=11417)

gpc 05-08-03 05:25 AM

Problem with GLX and MDK 9.1
 
1 Attachment(s)
Hello !

I've got a problem with the NVIDIA drivers in 3D mode :

I've experienced this problem on mandrake 9.0 and 9.1 with a lot of drivers (the one given in the standard Edition Box of mdk 9.1 for example), and the problem goes on with the NVIDIA-Linux-x86-1.0-4363.run.

I've experienced this problem with a Geforce 4 Mx 440 card, and with a TNT 2 Ultra, and a friend of mine experienced it with a Geforce 3.

I did the install as needed, and updated the XF86config-4, as said in the README file... and I have the Nvidia logo on X startup, but, when I have to deal with 3d apps... Nothing works...

When I launch glxgears, I get :

[root@localhost root]# glxgears
Error: couldn't get an RGB, Double-buffered visual

When I launch glxinfo, I get :

[root@localhost root]# glxinfo
name of display: :0.0
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Segmentation fault

When I launch Xdpyinfo, I get :

[root@localhost root]# xdpyinfo
name of display: :0.0
version number: 11.0
vendor string: Mandrake Linux (XFree86 4.3, patch level 5mdk)
vendor release number: 40300000
XFree86 version: 4.3.0
maximum request size: 4194300 bytes
motion buffer size: 256
bitmap unit, bit order, padding: 32, LSBFirst, 32
image byte order: LSBFirst
number of supported pixmap formats: 7
supported pixmap formats:
depth 1, bits_per_pixel 1, scanline_pad 32
depth 4, bits_per_pixel 8, scanline_pad 32
depth 8, bits_per_pixel 8, scanline_pad 32
depth 15, bits_per_pixel 16, scanline_pad 32
depth 16, bits_per_pixel 16, scanline_pad 32
depth 24, bits_per_pixel 32, scanline_pad 32
depth 32, bits_per_pixel 32, scanline_pad 32
keycode range: minimum 8, maximum 255
focus: window 0x1400004, revert to PointerRoot
number of extensions: 31
BIG-REQUESTS
DOUBLE-BUFFER
DPMS
Extended-Visual-Information
FontCache
GLX
LBX
MIT-SCREEN-SAVER
MIT-SHM
MIT-SUNDRY-NONSTANDARD
NV-CONTROL
NV-GLX
NVIDIA-GLX
RANDR
RENDER
SECURITY
SHAPE
SYNC
TOG-CUP
X-Resource
XC-APPGROUP
XC-MISC
XFree86-Bigfont
XFree86-DGA
XFree86-Misc
XFree86-VidModeExtension
XInputExtension
XKEYBOARD
XTEST
XVideo
XVideo-MotionCompensation
default screen number: 0
number of screens: 1

screen #0:
dimensions: 1024x768 pixels (321x241 millimeters)
resolution: 81x81 dots per inch
depths (7): 15, 1, 4, 8, 16, 24, 32
root window id: 0x58
depth of root window: 15 planes
number of colormaps: minimum 1, maximum 1
default colormap: 0x20
default number of colormap cells: 32
preallocated pixels: black 0, white 32767
options: backing-store NO, save-unders NO
largest cursor: 64x64
current input event mask: 0xd8403f
KeyPressMask KeyReleaseMask ButtonPressMask
ButtonReleaseMask EnterWindowMask LeaveWindowMask
KeymapStateMask SubstructureNotifyMask SubstructureRedirectMask
PropertyChangeMask ColormapChangeMask
number of visuals: 2
default visual id: 0x21
visual:
visual id: 0x21
class: TrueColor
depth: 15 planes
available colormap entries: 32 per subfield
red, green, blue masks: 0x7c00, 0x3e0, 0x1f
significant bits in color specification: 8 bits
visual:
visual id: 0x22
class: DirectColor
depth: 15 planes
available colormap entries: 32 per subfield
red, green, blue masks: 0x7c00, 0x3e0, 0x1f
significant bits in color specification: 8 bits


I don't know what else to do... The only thing I know, is that I managed to get the NVIDIA drivers working with an old tarball, when I used to run debian with gcc 2-95 inside... but with mdk... I couldn't get gcc-2.95 working, and I can't either find again the tarballs.

alien999999999 05-08-03 08:46 AM

the problem will modt likely have nothing to do with the nvidia drivers, perhaps your system has to many different GLX packages.

try uninstalling nvidia, uninstalling all gl rpm stuff and then installing nvidia again.

remember if you uninstall nvidia, you have to do a ldconfig, and better do that after uninstalling all gl rpm's as well (installing nvidia does that automatically).

if you're stuck in runlevel 3:

you can do

rpm -qa | grep gl

and try:

rpm -e <package-name>

for all those mesa and other gl rpms.

you didn't have any gl stuff sources built, did you?
try building rpms instead:

rpm -tb <tarball.gz> --clean --sign

Alien

gpc 05-09-03 05:54 AM

Not better
 
I tried what you suggested, and this didn't solve the problem...

I really don't know what to do with this stuff... Maybe is the error related with the segmentation I get with glxinfo...

Dunno...

Vadim 05-09-03 06:53 AM

I never tried to load glx without loading GLcore. and I don't know whether it possible or not. try to add line `Load "GLcore" ' in your Module section. you can also add line `Load "dri"', but i not sure nvidia drivers use dri.

btw, post your /var/log/XFree86.0.log

gpc 05-09-03 07:27 AM

log and GLcore
 
1 Attachment(s)
In the nvidia readme, i think it was written to delete line load "GLcore"
I post my logfile

bwkaz 05-09-03 08:40 AM

Yes, you should NOT be Load'ing "GLcore". If you try this, you'll either get the libGLcore.so file from DRI, which is wrong, or you won't get any GLcore at all, which will be no different. In no case will it ever help.

It looks like your X server is set up in 15-bit color. Is this right? AFAIK you have to be using 16 or 24 bit color to have an "RGB GLX visual". Try it and see.

Edit: Just looked at your log file. This does seem to be the problem:

Quote:

(WW) NVIDIA(0): OpenGL is only supported in depths 16 and 24

gpc 05-09-03 11:08 AM

THANK YOU, IT WORKS AND IT ROCKS...
 
bwkaz : I did what you said, and you were right... I can now launch glxgears, and play tuxracers and armagetron...

Nice... thanks again !


All times are GMT -5. The time now is 02:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.