nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Solaris (http://www.nvnews.net/vbulletin/forumdisplay.php?f=45)
-   -   Presario F767NR laptop problems (http://www.nvnews.net/vbulletin/showthread.php?t=114467)

rhb 06-07-08 04:41 PM

Presario F767NR laptop problems
 
I've been trying to get X working properly for several days and am quite baffled.

OpenSolaris 2008.05 works fine at 1280x800 w/ the Nvidia driver included by Sun.

Solaris 10 5/08 (aka U5) will ONLY work w/ the vga driver at 1024x768. I've created an xorg.conf file on OpenSolaris using the nvida-settings utility, but it doesn't help. I've also tried installing the 2 most recent Nvidia drivers w/o any luck.

How do I get more information about the problem? /var/log/Xerrors doesn't offer much but the suggestion I reinstall. It appears to me that the driver is misidentifying a device, but I can't really be sure. Is there something that will get more debug information?

Thanks,
rhb

rhb 06-07-08 06:39 PM

Re: Presario F767NR laptop problems
 
A bit more info:

If I use the xorg.conf generated in opensolaris on solaris 10 as is, I get a message:

"No matching Device section for instance (BusID PCI:0:1:3)"

If I add a BusID to the Device section w/ that ID I get the same message, but w/ (BusID of PCI:0:18:0)

If I set the BusID to that I get the first message and around I go.

rhb

Triskelios 06-08-08 02:43 PM

Re: Presario F767NR laptop problems
 
The Xorg log file is located at /var/log/Xorg.0.log. If you have to specify a BusID something is going wrong.

rhb 06-09-08 08:07 AM

Re: Presario F767NR laptop problems
 
Ah yes, quite correct. It's that and /var/dt/Xerrors. Both have similar content, though NOT the same. I was looking at both and getting pretty bleary.

So how to investigate? If I don't supply a BusID it complains; if I do it complains. The only driver that works is the vga driver at 1024x768 which is ugly on a 1280x800 display. Meanwhile OpenSolaris 2008.05 is happy as a clam w/ the Nvidia driver shipped w/ it.

Are there any dtrace probes I can use? Adding " -logverbose 5" to the Xorg startup didn't provide any new clues.

Reg

rhb 06-10-08 10:48 AM

Re: Presario F767NR laptop problems
 
FWIW reinstalling 173.14.05 solved the problem. Not sure why it didn't work the first time.


All times are GMT -5. The time now is 01:33 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.