nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   trying to run XFree86 on a secondary TNT PCI card (http://www.nvnews.net/vbulletin/showthread.php?t=11486)

bugfood 05-09-03 03:33 AM

trying to run XFree86 on a secondary TNT PCI card
 
1 Attachment(s)
Hello,

I have a GeForce4 Ti4200 8X AGP card and an old Riva TNT PCI card. I have both of them in my system right now, and I'm trying to get them both working simultaneously. I don't want to use TwinView or Xinerama - each display will be running a separate X server. My ultimate goal is to have two "work-stations" running on the same machine, as described here:
http://www.linuxplanet.com/linuxplan...orials/3100/1/
(if anybody knows a better way to do that, please let me know)

But, I haven't gotten that far yet (one step at a time). Right now I'm just trying to get the PCI TNT card to work when it isn't the primary display card. If I set my motherboard's BIOS to "Init Display First = PCI Slot", the TNT card initializes fine and the system boots normally. I can start XFree86, and even play Neverwinter Nights at an entire frame per second. :) However, if I set the bios to initialize the AGP card first, I don't have any luck with the PCI card when I try to start an X server on it.

I have configured my XFree86Config-4 with the appropriate BusIDs for each card, and defined different screens and layouts for each card. Whenever I try to start X on the TNT, when the Ti4200 is the main card, the process quits because it "Failed to initialize the kernel module". I have attached a full logverbose-5 log, along with my XFree86Config-4. Please see my two replies right after this for all the attachments.


What I've tried:

1. `rmmod nvidia' before starting X with the TNT layout. No good.

2. The nvidia README (Appendix H) mentions issues with SGRAM/SDRAM TNT cards. My card says it's SDRAM at boot, so I tried making the changes to os-registry.c, recompiling, and installing the modified driver. Everything seems to be the same.

3. I tried setting the BusID to something different, to make sure I have the right one. In this case, I just get "no devices detected".

4. I tried setting `Option "UseInt10Module" "1"' in the TNT device section. When this happens, I get the additionalerror "Cannot read V_BIOS". I don't know if that's pertinant. When I cat /proc/driver/nvidia/cards/0, the Video BIOS shows as ??.??.??.??.??. I have attached an XFree86 log of this too.

5. I read the Xinerama howto:
http://linuxdocs.org/HOWTOs/Xinerama-HOWTO-8.html
...and tried specifying the TNT screen to be RightOf the Ti4200 screen, just to see what happened. When I started X with that layout, the Ti4200 started up and the TNT quit with the usual "Failed to initialize the kernel module" error.


My system:
Gigabyte GA-7VAXP Ultra (KT400 chipset)
AthlonXP 2200+
Gainward GeForce4 Ti4200 AGP 8X
generic RIVA TNT PCI SDRAM

Linux kernel 2.4.21-rc1 (GCC 3.2.3)
Debian Sarge (Testing)
NVidia Linux drivers v4363 (GCC 3.2.3)


Does anybody have any ideas of what I should try or where I should read? I'd appreciate any help on the matter.

Thank you,
bugfood


Attachment #1: XF86Config-4

bugfood 05-09-03 03:35 AM

log of what happens without int10
 
1 Attachment(s)
attachment #2: XFree86.log

bugfood 05-09-03 03:36 AM

and here's what happens with int10
 
1 Attachment(s)
Attachment #3: XFree86.int10.log


All times are GMT -5. The time now is 08:06 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.